LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-02-2011, 03:07 AM   #1
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 524

Rep: Reputation: 45
NetworkManager don't start automatically


Hi, I have Slackware64 13.37 and I install NetworkManager from Slackbuilds.
The only problem is that I have to run rc.networkmanager when I do startx to see the applet running.

Isn't suppose to be automatic?
 
Old 05-02-2011, 03:53 AM   #2
rg3
Member
 
Registered: Jul 2007
Distribution: Fedora
Posts: 527

Rep: Reputation: Disabled
If rc.networkmanager resides in /etc/rc.d, make sure it's executable and launch it from /etc/rc.d/rc.local like:

Code:
/etc/rc.d/rc.networkmanager start
Important note: consider using "wicd" instead of NetworkManager. It's in /extra/wicd/.
 
Old 05-02-2011, 04:50 AM   #3
0men
Member
 
Registered: Mar 2011
Location: Brisbane
Distribution: Windows 10, Red Hat, Debian
Posts: 183

Rep: Reputation: 22
sudo /usr/sbin/slackpkg install wicd
 
Old 05-02-2011, 04:55 AM   #4
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.2 64 Multi-Lib
Posts: 523

Rep: Reputation: 210Reputation: 210Reputation: 210
I have used wicd for the last few years - but I'm planning on going with NetworkManager for the new rebuild of my laptop (with 13.37). I don't think wicd is practically supported anymore - there's hardly any movement at the home site. Also, Robbie Workman (who put wicd into Slackware anyway) appears to be pushing NetworkManager. That settled it for me.

Look for the spot in /etc/rc.d/rc.M where wicd is started and add the call to rc.networkmanager there.
 
1 members found this post helpful.
Old 05-02-2011, 07:21 AM   #5
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 524

Original Poster
Rep: Reputation: 45
Ok thanks for the replies, wicd is no longer supported so I'm moving to NM.
 
Old 05-02-2011, 07:24 AM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,368

Rep: Reputation: Disabled
NetworkManager is very nice and there are plugins for connecting to vpns etc. I would go with putting the startup line in rc.local though, to avoid it being lost if rc.M is overwritten on an upgrade.
 
1 members found this post helpful.
Old 05-02-2011, 07:47 AM   #7
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 524

Original Poster
Rep: Reputation: 45
Thanks dive, that is a good idea. I was thinking that put rc.networkmanager runnable was enough.
I put in rc.M and it works beautifully.
 
Old 07-21-2011, 10:47 AM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,566
Blog Entries: 1

Rep: Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885Reputation: 1885
Quote:
Originally Posted by rg3 View Post
If rc.networkmanager resides in /etc/rc.d, make sure it's executable and launch it from /etc/rc.d/rc.local like:

Code:
/etc/rc.d/rc.networkmanager start
I've tried that, twice, and both times it hung up the computer; couldn't even log on.
If started in a terminal, as root, and use the applet as user, it works, but not if the daemon is started on boot up.
 
Old 07-21-2011, 12:01 PM   #9
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Quote:
Originally Posted by cwizardone View Post
I've tried that, twice, and both times it hung up the computer; couldn't even log on.
If started in a terminal, as root, and use the applet as user, it works, but not if the daemon is started on boot up.
This works:

/etc/rc.d/rc.local:
Code:
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local startup commands in here.  Also, if you have
# anything that needs to be run at shutdown time you can
# make an /etc/rc.d/rc.local_shutdown script and put those
# commands in there.

# To disable networkmanager, chmod rc.networkmanager to 644
if [ -x /etc/rc.d/rc.networkmanager ]; then
  . /etc/rc.d/rc.networkmanager start
fi
/etc/rc.d/rc.local_shutdown:
Code:
#!/bin/sh

# To disable networkmanager shutdown, chmod rc.networkmanager to 644
if [ -x /etc/rc.d/rc.networkmanager ]; then
  . /etc/rc.d/rc.networkmanager stop
fi
 
Old 07-21-2011, 01:05 PM   #10
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,635

Rep: Reputation: Disabled
Quote:
Originally Posted by cwizardone View Post
I've tried that, twice, and both times it hung up the computer; couldn't even log on.
If started in a terminal, as root, and use the applet as user, it works, but not if the daemon is started on boot up.
This is odd. At what point does it hang? Did you disable wicd?

BTW, if you want help on this you may want to start a new thread as this thread is marked solved.

Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Services in runlevel don't start automatically tklima Linux - Server 5 12-12-2007 05:41 AM
How Do I start NetworkManager? lonecrow Linux - Software 12 09-28-2006 05:53 AM
Don't start automatically at boot, just directly muusle Slackware 7 04-07-2006 08:56 AM
I can't start NetworkManager ? naihe2010 Linux - Software 0 11-13-2005 05:51 PM
Mdk10rc1 don't start networking automatically eugeny Mandriva 1 03-27-2004 01:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration