LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-22-2016, 10:30 PM   #1
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64-current
Posts: 291

Rep: Reputation: 115Reputation: 115
Question mkfs.ext4 issue? Slackware64 with Fri May 20 updates


Not sure what went wrong here, I've set up a new test partition using gdisk then ran mkfs.ext4 as usual, done this successfully dozens of times in the past.
Code:
mkfs.ext4 -L test /dev/sda11
I reboot. I'm using Grub2 so I go into the grub console to verify
Code:
ls (hd0,gpt11)
  Partion hd0,11: No known filesystem detected - Partition start at ...
Re-tried with an old test partition on sda8, ran mkfs.ext4 on it, rebooted, went into the Grub2 console and got the same result, "No known filesystem".
Then I try again using the Slackware ISO install media, run setup, pick and format a partition etc then reboot into Grub2, same result, newer ext4 partitions are not recognizable. I give this another shot by rebooting into my work partition and trying ntfs this time:
Code:
mkfs.ntfs -f -L testing /dev/sda11
Another reboot, go into Grub2 console and this time Grub2 can see the partition and the filesystem on it
Code:
ls (hd0,gpt11)
  Partition hd0,11: Filesystem type ntfs - Label 'testing', UUID...
A couple more tries, using mkfs.ext2 and ext3, no issues, test partitions are visible in Grub2. Also, existing older ext4 partitions are recognizable in Grub2.
Any ideas?

Last edited by dr.s; 05-22-2016 at 10:34 PM.
 
Old 05-22-2016, 10:52 PM   #2
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 8,451

Rep: Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096Reputation: 6096
It's due to the e2fsprogs update. No word yet on if it'll be reverted or grub updated.

http://www.linuxquestions.org/questi...4/#post5548681

You can fix it with a quick sed (provided by DarkVision) followed by reformatting the partition.

Code:
sed -i "s:,64bit::g" /etc/mke2fs.conf

Last edited by bassmadrigal; 05-23-2016 at 06:40 AM.
 
2 members found this post helpful.
Old 05-22-2016, 11:07 PM   #3
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,460
Blog Entries: 15

Rep: Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040
I would update your Grub to the latest 2.02~beta3 if you have persistent issues.

Last edited by ReaperX7; 05-22-2016 at 11:09 PM.
 
2 members found this post helpful.
Old 05-23-2016, 02:59 PM   #4
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,829

Rep: Reputation: 596Reputation: 596Reputation: 596Reputation: 596Reputation: 596Reputation: 596
There is the entiry old .conf file

it Works for me


Quote:
[defaults]
base_features = sparse_super,large_file,filetype,resize_inode,dir_index,ext_attr
default_mntopts = acl,user_xattr
enable_periodic_fsck = 0
blocksize = 4096
inode_size = 256
inode_ratio = 16384

[fs_types]
ext3 = {
features = has_journal
}
ext4 = {
features = has_journal,extent,huge_file,flex_bg,uninit_bg,dir_nlink,extra_isize
auto_64-bit_support = 1
inode_size = 256
}
ext4dev = {
features = has_journal,extent,huge_file,flex_bg,uninit_bg,dir_nlink,extra_isize
inode_size = 256
options = test_fs=1
}
small = {
blocksize = 1024
inode_size = 128
inode_ratio = 4096
}
floppy = {
blocksize = 1024
inode_size = 128
inode_ratio = 8192
}
big = {
inode_ratio = 32768
}
huge = {
inode_ratio = 65536
}
news = {
inode_ratio = 4096
}
largefile = {
inode_ratio = 1048576
blocksize = -1
}
largefile4 = {
inode_ratio = 4194304
blocksize = -1
}
hurd = {
blocksize = 4096
inode_size = 128
}
 
1 members found this post helpful.
Old 05-23-2016, 03:51 PM   #5
Tonus
Member
 
Registered: Jan 2007
Location: Paris, France
Distribution: Slackware-current
Posts: 958
Blog Entries: 3

Rep: Reputation: 266Reputation: 266Reputation: 266
mkfs.ext4 issue? Slackware64 with Fri May 20 updates

Editing the mk2fs.conf with default 64-bit to 0 was enough for me : backed up the files on boot part, format the part, restore the files and the grub boots :-)

Thanks to DarkVision for showing the way !
 
1 members found this post helpful.
Old 05-24-2016, 07:01 AM   #6
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64-current
Posts: 291

Original Poster
Rep: Reputation: 115Reputation: 115
Thanks for your suggestions. The immediate workaround was to use ext3.
 
Old 05-26-2016, 06:17 PM   #7
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64-current
Posts: 291

Original Poster
Rep: Reputation: 115Reputation: 115
Thumbs up

Marking as solved.

Code:
Wed May 25 04:20:09 UTC 2016
...
a/e2fsprogs-1.43-x86_64-2.txz:  Rebuilt.
  Do not use 64-bit by default on ext4, since some bootloaders cannot handle
  it yet.  But use "auto_64-bit_support = 1", which will enable 64-bit if the
  number of blocks for the file system requires the feature to be enabled.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mkfs.ext4 shuts down machine loadedmind Linux - Newbie 2 09-18-2015 11:35 AM
[SOLVED] what is the cause of this mkfs.ext4 error? elsutjr Linux - General 3 05-29-2015 02:50 PM
[SOLVED] I accidentally mkfs.ext4'd my Windows partition moisespedro Slackware 17 04-11-2014 05:10 AM
mkfs.ext4 command is hanging after creating a LVM volume in rhel 6.5 smilemukul Linux - Newbie 13 02-18-2014 06:54 AM
recovering a 'ntfs' partition which got ruined by mkfs.ext4 command jagsir Linux - General 6 09-19-2010 07:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration