LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-08-2008, 10:31 AM   #1
hellasyoda
Member
 
Registered: Oct 2006
Location: HELLAS
Distribution: Slackware 12.1
Posts: 47

Rep: Reputation: 15
Kde kdm_greet[2788]: Can't open default user face


Hello.My pc its taking some time to load kdm.
I try some solutions:to disable glx module and this solutions but nothing

syslog
Code:
kdm_greet[2788]: Can't open default user face

the xsession
Code:
xset:  bad font path element (#162), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
startkde: Starting up...
kbuildsycoca running...
kio (KIOConnection): ERROR: Could not write data
 
Old 06-08-2008, 02:58 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Quote:
kdm_greet[2788]: Can't open default user face
The default location for user faces is /usr/share/apps/kdm/faces. There likely are no pictures stored there. Hence the error message.

If you open the Login Manager section of Control Center System Administration, you can change the preferences for the picture locations. See the User tab, User Image Source.

If you want to maintain all user login pictures in a central location, but do not have rights to /usr/share/apps/kdm/faces or do not want to use that location for fear of future updating, you can manually change the location to somewhere that wont get clobbered during an update. I have my /usr/local directory on a separate partition and I avoid such issues with that approach.

If you want to take that route, then as root, open /etc/kde/kdm/kdmrc.

Search for the [X-*-Greeter] section.

In that section look for the FaceDir keyline. If the keyline does not exit, then create.

Change the option to a directory you have full control or as in my case, is located in /usr/local where I never worry about updating.

Quote:
xset: bad font path element (#162), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
Been a long time since I looked at this infamous bug. My web page is a tad outdated with respect to file paths, but the general solution is available at Eliminating Common Nuisance Messages. Scroll to about the middle of the page.

I hope this helps.
 
Old 06-09-2008, 05:39 AM   #3
hellasyoda
Member
 
Registered: Oct 2006
Location: HELLAS
Distribution: Slackware 12.1
Posts: 47

Original Poster
Rep: Reputation: 15
Code:
The default location for user faces is /usr/share/apps/kdm/faces. There likely are no pictures stored there. Hence the error message
.
The default location is /usr/share/faces.I change the location but nothing.Is there any way to disable this feature?

Code:
These messages appear in the .xsession-errors log file and are caused by KDE. 
The problem usually is caused by an empty /opt/kde/share/fonts/override directory. 
Resolve the problem by copying a font file there. Then, as root, in that directory run mkfontdir, mkfontscale. 
Then run fc-cache -fv.
For this error the directory /kde/share/fonts/ doesn't exist. so i created... but nothing.

Thanks for your time

Last edited by hellasyoda; 06-09-2008 at 05:40 AM.
 
Old 06-09-2008, 01:43 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Quote:
The default location is /usr/share/faces. I change the location but nothing.
Use the Control Center Login Manager to assign pictures to each user account.

In the User tab section, select the "dummy" picture icon button and choose a picture. Or supply your own picture. The default location for the KDM images are stored in /usr/share/apps/kdm/pics/users. You can assign pictures from other locations too.

When you save the changes, the pictures will get stored in the location defined by the FaceDir keyline. If you configure the Login Manager for user priority, then the user can assign a picture, which will be stored in the user's home directory.

When you assign a picture to each user account, the new file stored in the FaceDir directory will be named using the format name.face.icon, where name is the user account name. The file actually will be the picture you selected from within the Login Manager. The file is merely renamed.

The best way to understand this is try each of the options and examine the results.

Quote:
For this error the directory /kde/share/fonts/ doesn't exist. so i created... but nothing.
Just copy any font file to the location. I copied the cursor font file cursor.pcf.gz to /share/fonts/override. I don't know why the KDE developers never corrected this nuisance error message, but this was the simple fix I found that worked for me. Many people would argue the error message is harmless and they would be correct, but the message demonstrates sloppy programming and is nonetheless a nuisance.
 
Old 06-14-2008, 02:22 PM   #5
hellasyoda
Member
 
Registered: Oct 2006
Location: HELLAS
Distribution: Slackware 12.1
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Woodsman View Post
Use the Control Center Login Manager to assign pictures to each user account.

In the User tab section, select the "dummy" picture icon button and choose a picture. Or supply your own picture. The default location for the KDM images are stored in /usr/share/apps/kdm/pics/users. You can assign pictures from other locations too.
Thanks this problem solved!


Quote:
Originally Posted by Woodsman View Post
Just copy any font file to the location. I copied the cursor font file cursor.pcf.gz to /share/fonts/override. I don't know why the KDE developers never corrected this nuisance error message, but this was the simple fix I found that worked for me. Many people would argue the error message is harmless and they would be correct, but the message demonstrates sloppy programming and is nonetheless a nuisance.

This problem remains.

Last edited by hellasyoda; 06-15-2008 at 04:10 AM.
 
Old 06-14-2008, 03:13 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Quote:
This problem remains.
Using the command line, return (cd /usr/share/fonts/override) to that directory. Then run:

mkfontdir
mkfontscale
fc-cache -fv


The following journal entry is oldish, but might help provide additional insight into the issue:

Slackware 10.0 Error MessagesóDay 20
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Solved: error message "localhost kdm_greet[15114]: Can't open default user face" jlinkels Linux - Software 4 02-12-2010 05:44 PM
default kde user configuration? m_yates Linux - Software 2 11-24-2005 12:54 PM
Kdm crash and kdm_greet problem ( kde 3.3.2 and 3.4 ) roughie Linux - Software 0 01-28-2005 10:36 AM
kdm_greet error: "Can't open default user face" ParticleMan Linux - Software 1 07-27-2004 05:20 AM
KDE default user theme Ph0enix2003 Linux - Newbie 5 06-12-2004 12:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration