LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-18-2006, 04:34 PM   #1
Southpaw76
Member
 
Registered: Dec 2005
Distribution: Slackware-13
Posts: 146

Rep: Reputation: 15
Having issues with my Fluxbox menu???


Hello fellow Slackers,
I seem to be having an issue with my Flux-Menu. First off, I have it set up so that you can right click on the menu and immediately after "User Styles" is a Wallpaper section where I can place my wallpapers and be able to switch them on the fly. Here's what it looks like...
Code:
~/.fluxbox/menu

[submenu] (My Backgrounds) {Choose a Background...}
     [Wallpapers] (~/.fluxbox/backgrounds) {fbsetbg -f}
[end]
...And then
Code:
~/.fluxbox/init

session.screen0.rootCommand:    fbsetbg -l
Now after I restarted X, my sub-menu was there but not my images!?!?
What gives???
 
Old 11-18-2006, 06:48 PM   #2
anupamsr
Member
 
Registered: Sep 2004
Location: India
Distribution: Kubuntu, Archlinux, Suse, Gentoo, Mandrake
Posts: 371

Rep: Reputation: 30
You may like to follow this link: http://forums.gentoo.org/viewtopic-p...7.html#3726577
 
Old 11-18-2006, 09:21 PM   #3
ryanoa
Member
 
Registered: Jan 2006
Location: Santa Cruz, CA
Distribution: Slack 10.2 and 11.0
Posts: 102

Rep: Reputation: 15
The backgrounds directory must be executable
Code:
chmod 755
I just tested it with read only permissions and the files didn't show up. Hope that's all it is
 
Old 11-19-2006, 08:41 AM   #4
thelastknowngod
Member
 
Registered: Nov 2006
Location: jersey
Distribution: Arch
Posts: 54

Rep: Reputation: 15
Code:
~/.fluxbox/menu

[submenu] (My Backgrounds) {Choose a Background...}
     [Wallpapers] (~/.fluxbox/backgrounds) {fbsetbg -f}
[end]
where you have [Wallpapers] it should be [wallpapers] with a lower case w. i made the same mistake just the other day.
 
Old 11-19-2006, 01:34 PM   #5
Southpaw76
Member
 
Registered: Dec 2005
Distribution: Slackware-13
Posts: 146

Original Poster
Rep: Reputation: 15
Forgive for asking ryanoa, but how do I go about making that directory executable???
 
Old 11-19-2006, 01:42 PM   #6
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
He already said it...

chmod 755 ~/.fluxbox/backgrounds
 
Old 11-19-2006, 07:19 PM   #7
Southpaw76
Member
 
Registered: Dec 2005
Distribution: Slackware-13
Posts: 146

Original Poster
Rep: Reputation: 15
Yeah, I tried that but my backgrounds still don't show up ...
 
Old 11-19-2006, 08:02 PM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Did you try with lower case? As thelastknowngod said, that seems to be the problem.
 
Old 11-20-2006, 09:21 AM   #9
Linux_Chick
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware & Arch
Posts: 21

Rep: Reputation: 15
As thelasknowngod mentioned, [wallpapers] can't have a capitol W.
and you may want to try removing this line "{Choose a Background...}"

Below is the working, entry in my menu, notice there is also no -f after the fbsetbg.

Hope that helps



[submenu] (Backgrounds)
[wallpapers] (~/.fluxbox/backgrounds) {fbsetbg}
[end]
 
Old 11-21-2006, 01:41 AM   #10
ryanoa
Member
 
Registered: Jan 2006
Location: Santa Cruz, CA
Distribution: Slack 10.2 and 11.0
Posts: 102

Rep: Reputation: 15
The -f flag just sets the background as full screen (see man fbsetbg). {Choose a background...} is just the title of the submenu. Both of these should not effect why your pics don't show up. Just make sure that the w in wallpapers is not capitalized and that the directory is executable and you should be good to go.
 
Old 11-23-2006, 12:07 PM   #11
Southpaw76
Member
 
Registered: Dec 2005
Distribution: Slackware-13
Posts: 146

Original Poster
Rep: Reputation: 15
Okay, I figured it out . I believe it was just a simple syntax issue. I think I had typed in something singular when it should have been plural.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox menu kirth Linux - Software 1 05-23-2005 03:44 AM
fluxbox menu help cs-cam Linux - Software 3 11-13-2004 09:05 PM
fluxbox menu issues.... detpenguin Linux - Software 2 03-17-2004 11:11 PM
FluxBox not in menu Darkseid Linux - Software 2 12-15-2003 08:16 PM
fluxbox in the menu rvijay17 Linux - Newbie 2 06-11-2003 05:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration