LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-06-2011, 05:32 AM   #31
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0

Quote:
Originally Posted by SeRi@lDiE View Post
What he meant its that most likely and it looks like you are... You are running on the default "Huge Kernel" of slackware.... There is a readme inside the cd explaining why this is not recommended.... What they recommend is to switch your kernel to generic.... And it "might help" with your problem.... Its done as follow....

Run in the cmd:

root@darkstar:~# /usr/share/mkinitrd/mkinitrd_command_generator.sh

Get the output of the script and run it...

root@darkstar:~# mkinitrd -c -k 2.6.37.6 -f ext4 -r /dev/sda2 -m usbhid:ehci-hcd:uhci-hcd:jbd2:mbcache:ext4 -u -o /boot/initrd.gz

It will generate the initrd file under /boot

Now go under lilo and add in a new line.... Here is an example of what I have.... In your case the root partition might change, etc...


# Linux bootable partition config begins
image = /boot/vmlinuz-generic-2.6.37.6
initrd = /boot/initrd.gz
root = /dev/sda2
label = Linux-G
read-only
# Linux bootable partition config ends

Than run lilo from the command line.

This is just an example. do not copy and paste!

Reboot and test.

Good Luck.
I am trying to do that but I have another problem and I posted it here:
http://www.linuxquestions.org/questi...4/#post4406602
Please see if you can help me further with this.
 
Old 07-06-2011, 06:41 AM   #32
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
Ok, that is settled then ethPCI is the e1000 ethernet card.
 
Old 07-07-2011, 05:26 AM   #33
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Smile

It seems Shifting to Generic kernel from Huge has resolved the problem.
I have not received any error so far in one day. Thanks for all the help guys you are awesome
 
Old 07-07-2011, 08:44 AM   #34
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Question

Sorry guys I have to reactivate this thread. The problem has started again.
After I switched to Generic Kernel it worked OK for a day but now I am getting the same error "Disabling IRQ #19"
Is there anyway I can find out what is causing this issue ? Is it a driver issue ? Also I would like to know under what condition kernel disables IRQs ?

Here is the syslog:
Code:
...
Jul  7 12:29:29 SA kernel: [ 9587.707539] irq 19: nobody cared (try booting with the "irqpoll" option)
Jul  7 12:29:29 SA kernel: [ 9587.707544] Pid: 0, comm: swapper Not tainted 2.6.37.6 #2
Jul  7 12:29:29 SA kernel: [ 9587.707547] Call Trace:
Jul  7 12:29:29 SA kernel: [ 9587.707549]  <IRQ>  [<ffffffff810aac2b>] __report_bad_irq.clone.2+0x2b/0xa0
Jul  7 12:29:29 SA kernel: [ 9587.707562]  [<ffffffff810aae2e>] note_interrupt+0x18e/0x1d0
Jul  7 12:29:29 SA kernel: [ 9587.707566]  [<ffffffff81074125>] ? sched_clock_idle_wakeup_event+0x15/0x20
Jul  7 12:29:29 SA kernel: [ 9587.707571]  [<ffffffff810abc85>] handle_fasteoi_irq+0xc5/0xf0
Jul  7 12:29:29 SA kernel: [ 9587.707576]  [<ffffffff81005a32>] handle_irq+0x22/0x40
Jul  7 12:29:29 SA kernel: [ 9587.707580]  [<ffffffff814bbf78>] do_IRQ+0x68/0xf0
Jul  7 12:29:29 SA kernel: [ 9587.707584]  [<ffffffff814bba93>] ret_from_intr+0x0/0xa
Jul  7 12:29:29 SA kernel: [ 9587.707586]  <EOI>  [<ffffffff81277c2c>] ? intel_idle+0xec/0x180
Jul  7 12:29:29 SA kernel: [ 9587.707600]  [<ffffffff81277c0b>] ? intel_idle+0xcb/0x180
Jul  7 12:29:29 SA kernel: [ 9587.707603]  [<ffffffff813cc021>] cpuidle_idle_call+0x91/0x130
Jul  7 12:29:29 SA kernel: [ 9587.707605]  [<ffffffff81000d2c>] cpu_idle+0x9c/0x120
Jul  7 12:29:29 SA kernel: [ 9587.707608]  [<ffffffff814a5a5d>] rest_init+0x6d/0x80
Jul  7 12:29:29 SA kernel: [ 9587.707610]  [<ffffffff818c5c49>] start_kernel+0x3c4/0x3cf
Jul  7 12:29:29 SA kernel: [ 9587.707612]  [<ffffffff818c5322>] x86_64_start_reservations+0x132/0x136
Jul  7 12:29:29 SA kernel: [ 9587.707614]  [<ffffffff818c5417>] x86_64_start_kernel+0xf1/0xf8
Jul  7 12:29:29 SA kernel: [ 9587.707615] handlers:
Jul  7 12:29:29 SA kernel: [ 9587.707615] [<ffffffffa00eb4d0>] (e1000_intr+0x0/0x140 [e1000])
Jul  7 12:29:29 SA kernel: [ 9587.707621] Disabling IRQ #19
...
Do you think that line highlighted in red above is related to this problem. How can I boot with 'irqpoll' option ?
Thanks for any further advice.

Last edited by FrazAQ; 07-07-2011 at 08:55 AM.
 
Old 07-07-2011, 09:59 AM   #35
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
You can boot with that option by editing '/etc/lilo.conf' and adding it the the append line, inside the quotes. Then you run 'lilo' as root to have it apply the settings.
 
1 members found this post helpful.
Old 07-12-2011, 09:28 AM   #36
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H View Post
You can boot with that option by editing '/etc/lilo.conf' and adding it the the append line, inside the quotes. Then you run 'lilo' as root to have it apply the settings.
Just wanted to confirm that adding "irqpoll" option has finally solved my problem.
Although I have not tested it on Huge kernel but since generic kernel is recommended, so I don't have any reason to test it.
Thanks everyone
 
Old 07-12-2011, 03:34 PM   #37
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 415

Rep: Reputation: 77
Quote:
Originally Posted by FrazAQ View Post
Just wanted to confirm that adding "irqpoll" option has finally solved my problem.
Good news. However, I would call this a workaround rather than a solution. If you get a chance to identify the responsible driver, a ticket on bugzilla.kernel.org might be in order.
 
Old 07-15-2011, 09:30 AM   #38
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Question

Quote:
Originally Posted by Martinus2u View Post
Good news. However, I would call this a workaround rather than a solution. If you get a chance to identify the responsible driver, a ticket on bugzilla.kernel.org might be in order.
Can you shed more light how I can do that ?

This is becoming extremely frustrating as the problem has started happening again now.
The worst thing is that I have not been able to detect a pattern or a clue that would help to find out what causes this problem.
I don't know what causes the kernel to disable an IRQ. I am clueless

I have "irqpoll" option in lilo.conf and I ran lilo with this setting in place and it worked momentarily. Strangely in syslog I still see the suggesion for "irqpoll":
Code:
Jul 15 13:44:11 SA kernel: [  917.343129] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.
Jul 15 14:44:11 SA kernel: [ 4515.056606] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.
Jul 15 16:07:37 SA kernel: [ 9518.395759] irq 19: nobody cared (try booting with the "irqpoll" option)
Jul 15 16:07:37 SA kernel: [ 9518.395762] Pid: 0, comm: swapper Not tainted 2.6.37.6 #2
Jul 15 16:07:37 SA kernel: [ 9518.395763] Call Trace:
Jul 15 16:07:37 SA kernel: [ 9518.395764]  <IRQ>  [<ffffffff810aac2b>] __report_bad_irq.clone.2+0x2b/0xa0
Jul 15 16:07:37 SA kernel: [ 9518.395771]  [<ffffffff810aae2e>] note_interrupt+0x18e/0x1d0
Jul 15 16:07:37 SA kernel: [ 9518.395774]  [<ffffffff810abc85>] handle_fasteoi_irq+0xc5/0xf0
Jul 15 16:07:37 SA kernel: [ 9518.395776]  [<ffffffff81005a32>] handle_irq+0x22/0x40
Jul 15 16:07:37 SA kernel: [ 9518.395780]  [<ffffffff814bbf78>] do_IRQ+0x68/0xf0
Jul 15 16:07:37 SA kernel: [ 9518.395781]  [<ffffffff814bba93>] ret_from_intr+0x0/0xa
Jul 15 16:07:37 SA kernel: [ 9518.395782]  <EOI>  [<ffffffff81277c2c>] ? intel_idle+0xec/0x180
Jul 15 16:07:37 SA kernel: [ 9518.395787]  [<ffffffff81277c0b>] ? intel_idle+0xcb/0x180
Jul 15 16:07:37 SA kernel: [ 9518.395791]  [<ffffffff813cc021>] cpuidle_idle_call+0x91/0x130
Jul 15 16:07:37 SA kernel: [ 9518.395792]  [<ffffffff81000d2c>] cpu_idle+0x9c/0x120
Jul 15 16:07:37 SA kernel: [ 9518.395795]  [<ffffffff814a5a5d>] rest_init+0x6d/0x80
Jul 15 16:07:37 SA kernel: [ 9518.395797]  [<ffffffff818c5c49>] start_kernel+0x3c4/0x3cf
Jul 15 16:07:37 SA kernel: [ 9518.395799]  [<ffffffff818c5322>] x86_64_start_reservations+0x132/0x136
Jul 15 16:07:37 SA kernel: [ 9518.395801]  [<ffffffff818c5417>] x86_64_start_kernel+0xf1/0xf8
Jul 15 16:07:37 SA kernel: [ 9518.395802] handlers:
Jul 15 16:07:37 SA kernel: [ 9518.395803] [<ffffffffa02bd4d0>] (e1000_intr+0x0/0x140 [e1000])
Jul 15 16:07:37 SA kernel: [ 9518.395809] Disabling IRQ #19
 
Old 07-16-2011, 03:30 AM   #39
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 415

Rep: Reputation: 77
Quote:
Originally Posted by FrazAQ View Post
Can you shed more light how I can do that ?
there is no fixed recipe, but maybe you can remove devices from your pci bus (either physically or maybe via BIOS?) and see which one is linked to the issue. Then, by association, you can name a candidate that should have handled the irq.

Of course, hardware issues can be more complex, but it might be a starting point.

Another approach might be to blame the e1000 driver straight away since it is listed in the call trace, create a bugzilla ticket prio high and see what happens. ;-)
 
Old 07-16-2011, 07:48 AM   #40
SeRi@lDiE
Member
 
Registered: Jun 2006
Location: /dev/null
Distribution: Slackware 13.1, Slackware 13.37, aptosid, rhel
Posts: 547
Blog Entries: 7

Rep: Reputation: 55
Quote:
Originally Posted by FrazAQ View Post
Can you shed more light how I can do that ?

This is becoming extremely frustrating as the problem has started happening again now.
The worst thing is that I have not been able to detect a pattern or a clue that would help to find out what causes this problem.
I don't know what causes the kernel to disable an IRQ. I am clueless

I have "irqpoll" option in lilo.conf and I ran lilo with this setting in place and it worked momentarily. Strangely in syslog I still see the suggesion for "irqpoll":
Code:
Jul 15 13:44:11 SA kernel: [  917.343129] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.
Jul 15 14:44:11 SA kernel: [ 4515.056606] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.
Jul 15 16:07:37 SA kernel: [ 9518.395759] irq 19: nobody cared (try booting with the "irqpoll" option)
Jul 15 16:07:37 SA kernel: [ 9518.395762] Pid: 0, comm: swapper Not tainted 2.6.37.6 #2
Jul 15 16:07:37 SA kernel: [ 9518.395763] Call Trace:
Jul 15 16:07:37 SA kernel: [ 9518.395764]  <IRQ>  [<ffffffff810aac2b>] __report_bad_irq.clone.2+0x2b/0xa0
Jul 15 16:07:37 SA kernel: [ 9518.395771]  [<ffffffff810aae2e>] note_interrupt+0x18e/0x1d0
Jul 15 16:07:37 SA kernel: [ 9518.395774]  [<ffffffff810abc85>] handle_fasteoi_irq+0xc5/0xf0
Jul 15 16:07:37 SA kernel: [ 9518.395776]  [<ffffffff81005a32>] handle_irq+0x22/0x40
Jul 15 16:07:37 SA kernel: [ 9518.395780]  [<ffffffff814bbf78>] do_IRQ+0x68/0xf0
Jul 15 16:07:37 SA kernel: [ 9518.395781]  [<ffffffff814bba93>] ret_from_intr+0x0/0xa
Jul 15 16:07:37 SA kernel: [ 9518.395782]  <EOI>  [<ffffffff81277c2c>] ? intel_idle+0xec/0x180
Jul 15 16:07:37 SA kernel: [ 9518.395787]  [<ffffffff81277c0b>] ? intel_idle+0xcb/0x180
Jul 15 16:07:37 SA kernel: [ 9518.395791]  [<ffffffff813cc021>] cpuidle_idle_call+0x91/0x130
Jul 15 16:07:37 SA kernel: [ 9518.395792]  [<ffffffff81000d2c>] cpu_idle+0x9c/0x120
Jul 15 16:07:37 SA kernel: [ 9518.395795]  [<ffffffff814a5a5d>] rest_init+0x6d/0x80
Jul 15 16:07:37 SA kernel: [ 9518.395797]  [<ffffffff818c5c49>] start_kernel+0x3c4/0x3cf
Jul 15 16:07:37 SA kernel: [ 9518.395799]  [<ffffffff818c5322>] x86_64_start_reservations+0x132/0x136
Jul 15 16:07:37 SA kernel: [ 9518.395801]  [<ffffffff818c5417>] x86_64_start_kernel+0xf1/0xf8
Jul 15 16:07:37 SA kernel: [ 9518.395802] handlers:
Jul 15 16:07:37 SA kernel: [ 9518.395803] [<ffffffffa02bd4d0>] (e1000_intr+0x0/0x140 [e1000])
Jul 15 16:07:37 SA kernel: [ 9518.395809] Disabling IRQ #19

Have you try updating your BIOS?
 
Old 07-16-2011, 07:51 AM   #41
SeRi@lDiE
Member
 
Registered: Jun 2006
Location: /dev/null
Distribution: Slackware 13.1, Slackware 13.37, aptosid, rhel
Posts: 547
Blog Entries: 7

Rep: Reputation: 55
Also if this is a kernel related issue which could be try to move a kernel version up or down to see if that helps... Though I got a feeling this issue will remain.
 
Old 07-17-2011, 03:23 AM   #42
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by SeRi@lDiE View Post
Have you try updating your BIOS?
Yes I updated the bios to the latest version but it did not make any difference.
 
Old 07-29-2011, 01:04 PM   #43
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
Strangely enough, I have a new netbook and it says the same thing on boot or shutdown "Disabling IRQ #19". It may be related to the mouse I plug into the USB controller using IRQ 19.
 
Old 07-30-2011, 03:47 AM   #44
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
Actually, it's not the mouse, it happens because of the experimental atl1c driver. The driver is unstable and causes some strange stuff, like bogus transfer data, and disables the irq when I run 'ifconfig eth0 down'.
 
Old 07-30-2011, 05:25 AM   #45
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by H_TeXMeX_H View Post
Actually, it's not the mouse, it happens because of the experimental atl1c driver. The driver is unstable and causes some strange stuff, like bogus transfer data, and disables the irq when I run 'ifconfig eth0 down'.
In my case it is Intel Pro e1000 driver, I suspect there is some kind of bug in the kernel because your card looks different than mine and I don't think that every driver out there for Linux is faulty.
Is there a way to re-enable a disabled IRQ, other than rebooting the system ? because it seems that is the only workaround to this bug.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel: Disabling IRQ #19 shogun1234 Linux - Kernel 1 11-21-2008 10:29 AM
Disabling irq #19 mengchun_khor Linux - Newbie 2 08-15-2008 10:10 AM
Disabling IRQ #17 okos Linux - Newbie 4 10-04-2007 07:54 PM
Disabling IRQ #11 keripukki Linux - Hardware 4 09-18-2004 05:54 PM
Disabling IRQ #7? rjerina Linux - Hardware 4 07-30-2004 12:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration