LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-02-2011, 03:35 PM   #1
czezz
Member
 
Registered: Nov 2004
Location: Poland/Warsaw
Distribution: Slackware/Solaris
Posts: 571

Rep: Reputation: 30
switch Huge SMP to Generic


I have installed Slack 13.37 for test on VMware.
I installed just all - also all avalible distro. kernel imiges:
Code:
vmlinuz-generic-2.6.37.6
vmlinuz-generic-smp-2.6.37.6-smp
vmlinuz-huge-2.6.37.6
vmlinuz-huge-smp-2.6.37.6-smp
and the default is vmlinuz-huge-smp-2.6.37.6-smp.
Im trying to switch to vmlinuz-generic-2.6.37.6

So, what I did:
fs = ext4
root fs = /dev/sda1
Code:
/boot#  mkinitrd -c -k 2.6.37.6 -m ext4 -f ext4 -r /dev/sda1
Edited lilo: pointing new image, lilo command executed.
Every time I start new kernel i got this error:
http://imageshack.us/photo/my-images...aptureics.jpg/

Anyone knows what is wrong ?

Last edited by czezz; 06-02-2011 at 03:36 PM.
 
Old 06-02-2011, 03:47 PM   #2
nivieru
Member
 
Registered: Feb 2008
Posts: 48

Rep: Reputation: 7
look for a script called mkinitrd_command_generator.sh
it's on the slackware dvd in /source/a/mkinitrd/ directory
it detects what modules you should pass to mkinitrd
 
Old 06-02-2011, 03:48 PM   #3
vulcan59
Member
 
Registered: Sep 2007
Location: UK
Distribution: Slackware 13.37 & 14.0
Posts: 71

Rep: Reputation: 24
Looks like you haven't installed the kernel modules package.
kernel-modules-2.6.37.6-i486-2.txz
 
Old 06-02-2011, 04:10 PM   #4
czezz
Member
 
Registered: Nov 2004
Location: Poland/Warsaw
Distribution: Slackware/Solaris
Posts: 571

Original Poster
Rep: Reputation: 30
nivieru: it suggested to add jdb2 and mbcache, which are added by default any way - still not working. This same error
vulcan59: As I have written, I installed all - kernel-modules-2.6.37.6-i486-2.txz is included in all.
 
Old 06-02-2011, 04:30 PM   #5
nivieru
Member
 
Registered: Feb 2008
Posts: 48

Rep: Reputation: 7
did you also add
Quote:
initrd = /boot/initrd
to lilo?
 
1 members found this post helpful.
Old 06-02-2011, 04:37 PM   #6
czezz
Member
 
Registered: Nov 2004
Location: Poland/Warsaw
Distribution: Slackware/Solaris
Posts: 571

Original Poster
Rep: Reputation: 30
Yes, did it previously.
Anyway, I just run script you told me before once again. This time more modules:
Code:
mkinitrd -c -k 2.6.37.6-smp -f ext4 -r /dev/sda1 -m mptbase:mptscsih:mptspi:jbd2:mbcache:ext4 -u -o /boot/initrd.gz
... and it is bootable now
Thanks!
 
Old 07-06-2011, 05:11 AM   #7
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by czezz View Post
Yes, did it previously.
Anyway, I just run script you told me before once again. This time more modules:
Code:
mkinitrd -c -k 2.6.37.6-smp -f ext4 -r /dev/sda1 -m mptbase:mptscsih:mptspi:jbd2:mbcache:ext4 -u -o /boot/initrd.gz
... and it is bootable now
Thanks!
I have the same problem. After excuting /usr/share/mkinitrd/mkinitrd_command_generator.sh I get the following command:

Code:
mkinitrd -c -k 2.6.37.6 -f ext3 -r /dev/sda1 -m usb-storage:xhci-hcd:usbhid:ehci-hcd:mbcache:jbd:ext3 -u -o /boot/initrd.gz
but after executing it and configuring lilo I cant boot and get the same error as post #1

Please help!
 
Old 07-06-2011, 05:29 AM   #8
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 555
Blog Entries: 2

Rep: Reputation: 71
The relevant section of your /etc/lilo.conf file should read as follows:
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz-generic-smp-2.6.37.6-smp
  initrd = /boot/initrd.gz
  root = /dev/sda?
  label = Slackware_Linux
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
Substitute your root partition number in the line "root = /dev/sda_" and run lilo after the file has been edited.

Last edited by psionl0; 07-06-2011 at 05:30 AM.
 
Old 07-06-2011, 05:37 AM   #9
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Lightbulb

Quote:
Originally Posted by psionl0 View Post
The relevant section of your /etc/lilo.conf file should read as follows:
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz-generic-smp-2.6.37.6-smp
  initrd = /boot/initrd.gz
  root = /dev/sda?
  label = Slackware_Linux
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
Substitute your root partition number in the line "root = /dev/sda_" and run lilo after the file has been edited.
My lilo.conf looks like this:

Code:
 image = /boot/vmlinuz-generic-2.6.37.6
 initrd=/boot/initrd.gz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends
There are no smp in the image name but it is what I have in my /boot/ dir after excuting the script.
 
Old 07-06-2011, 06:04 AM   #10
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,022
Blog Entries: 52

Rep: Reputation: Disabled
Quote:
Originally Posted by FrazAQ View Post
My lilo.conf looks like this:

Code:
 image = /boot/vmlinuz-generic-2.6.37.6
 initrd=/boot/initrd.gz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends
There are no smp in the image name but it is what I have in my /boot/ dir after excuting the script.
In the initrd line, you need a space before and after the = sign.
 
1 members found this post helpful.
Old 07-06-2011, 06:09 AM   #11
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
I must also mention that when I execute lilo after changing lilo.conf I get a warning saying "lba32 addressing assumed"
I searched about it but I don't understand how to get rid off this warning.
 
Old 07-06-2011, 06:18 AM   #12
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,022
Blog Entries: 52

Rep: Reputation: Disabled
Put lba32 in the global options in lilo.conf:
Code:
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
lba32
# Normal VGA console
 
1 members found this post helpful.
Old 07-06-2011, 06:49 AM   #13
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Rep: Reputation: 48
Quote:
Originally Posted by FrazAQ View Post
My lilo.conf looks like this:

Code:
 image = /boot/vmlinuz-generic-2.6.37.6
 initrd=/boot/initrd.gz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends
There are no smp in the image name but it is what I have in my /boot/ dir after excuting the script.
Hi FrazAQ:

Here is a great link for setting up Slackware: http://genek.net/LinuxAdventures/sysadmin/index.html

Read: A Basic Slackware Setup

HTH,
 
Old 07-06-2011, 10:26 AM   #14
FrazAQ
LQ Newbie
 
Registered: Feb 2008
Distribution: Slackware 13.37 x86_64
Posts: 19

Rep: Reputation: 0
Smile

Thanks guys! It is working now, I added the spaces.
Also I think I added lba32 at wrong place before and it was not being accepted.
I am on generic kernel now I hope this solves my problems.
 
Old 07-07-2011, 04:57 AM   #15
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Rep: Reputation: 32
Sorry for the slight hijack. I want to switch away from the huge kernel, but dont actually use lilo (cuz ubuntu was on the machine first to be honest).
Can this all be done using grub? or am i stuck with huge?
Thanks, and sorry again,

Tom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 13.1 huge smp is not huge cs_strong Slackware 4 11-16-2010 07:41 AM
13.0 64 bit just Huge & Generic, no "smp" kernels installed acummings Slackware 2 10-01-2009 09:59 AM
[SOLVED] How to user vmlinuz-generic instead of vmlinuz-huge-smp? cola Slackware 12 09-15-2009 01:54 PM
slack 12, switch to generic kernel from huge kernel, using grub? jaguarrh Slackware 8 09-19-2007 06:29 AM
Switch from huge-smp-2.6.21.5 to generic-2.6.21.5 tronayne Slackware 1 07-30-2007 08:34 AM


All times are GMT -5. The time now is 04:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration