LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-06-2011, 03:18 AM   #1
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, CentOS, FreeBSD
Posts: 3,373

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
Can't print documents in landscape format


Hi,

I have Slackware 13.37, LibreOffice 3.4.2 (Alien packages) and a Brother HL-2030. For some obscure reasons, I can't print in landscape format. It always comes out "upright" formatted (don't know the exact word) and cut at the edges. I don't even know where the problem comes from: LibreOffice? CUPS? Anyone else got a similar problem and knows how to solve it?
 
Old 09-06-2011, 07:53 PM   #2
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
Hi

I've had similar problems but with PDF
I solved it by properly configuring CUPS, using http://localhost:631

Also, it took some try-error on the configurations from the printing itself
 
Old 09-07-2011, 08:14 PM   #3
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.2 Slackware 14.2, Slackware{32,64}-current
Posts: 857
Blog Entries: 9

Rep: Reputation: 322Reputation: 322Reputation: 322Reputation: 322
I ran into this after upgrading to the Libreoffice office package from SlackBuilds.org. The Fix is here: https://bbs.archlinux.org/viewtopic.php?id=120368

Essentially: "File - Printer Settings - Properties - Device" and change "Printer Language type" from "PDF" to "Postscript (Level from driver)" or the appropriate choice for your printer.

This setting changes back to PDF whenever you start LO and I haven't found the config locate for this yet.

Edit: If you select "Post Script Level 2" that setting sticks and allows landscape mode. You can set this via the "Printer Administration" utility as well. On my system, "Post Script Level 3" reverts to "Post Script Level 2"

Last edited by kingbeowulf; 09-07-2011 at 08:34 PM. Reason: Correction/add information
 
Old 09-08-2011, 07:07 AM   #4
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, CentOS, FreeBSD
Posts: 3,373

Original Poster
Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
Quote:
Originally Posted by kingbeowulf View Post
I ran into this after upgrading to the Libreoffice office package from SlackBuilds.org. The Fix is here: https://bbs.archlinux.org/viewtopic.php?id=120368

Essentially: "File - Printer Settings - Properties - Device" and change "Printer Language type" from "PDF" to "Postscript (Level from driver)" or the appropriate choice for your printer.

This setting changes back to PDF whenever you start LO and I haven't found the config locate for this yet.

Edit: If you select "Post Script Level 2" that setting sticks and allows landscape mode. You can set this via the "Printer Administration" utility as well. On my system, "Post Script Level 3" reverts to "Post Script Level 2"
After a few hours of searching and experimenting, I guess I solved the problem.

1) The printer only seems to work OK with the drivers provided by Brother.

2) Drivers are 32bit only, so I had to install some basic multilib packages (thanks Eric) to make them work.

3) LibreOffice documents print OK with the workaround detailed above (thanks Kingbeowulf).

Phew.
 
Old 04-24-2012, 04:55 AM   #5
herman.smartlion
LQ Newbie
 
Registered: Apr 2012
Posts: 5

Rep: Reputation: Disabled
I can do it in my fedora, i just download foxit reader in rpm package, it can print in landscape format.
 
Old 04-24-2012, 05:27 AM   #6
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, CentOS, FreeBSD
Posts: 3,373

Original Poster
Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
Unfortunately this single bug unnerved pretty much everyone - about fifty users in the network - so I replaced Slackware by Debian, where everything works OK, and some other pestering bugs - blank screen on logout in KDM, etc. - got solved also. Pity, because I preferred Slackware for purely sentimental reasons.
 
Old 02-16-2016, 04:49 PM   #7
mki
LQ Newbie
 
Registered: May 2012
Posts: 1

Rep: Reputation: Disabled
In OpenOffice, you can de-select pdf in the Options --> print form.
 
Old 02-16-2016, 05:59 PM   #8
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, CentOS, FreeBSD
Posts: 3,373

Original Poster
Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
Quote:
Originally Posted by mki View Post
In OpenOffice, you can de-select pdf in the Options --> print form.
You do notice that this thread is five years old? In the meantime, we're running Slackware 14.1 everywhere again. Occasional stints on Debian, CentOS and Ubuntu LTS were just that: stints. Everything works perfectly, and the landscape printing problem was due to Brother's crappy Linux driver. Printer was eventually replaced by a HP Laserjet, which works fine.

Cheers,

Niki
 
Old 02-17-2016, 06:59 AM   #9
MarcT
Member
 
Registered: Jan 2009
Location: UK
Distribution: Slackware 14.2
Posts: 110

Rep: Reputation: 47
Interesting! I've never been able to print PDFs in landscape properly via "okular" in Slackware 14.x to either a HP LaserJet 5 or a Xerox Phaser 8400.
I was led to believe it was a KDE bug:
https://bugs.kde.org/show_bug.cgi?id=181290


I'll have to try the "Printer Language Type" change suggested above.

Marc
 
Old 02-17-2016, 03:19 PM   #10
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,438

Rep: Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211Reputation: 3211
Quote:
Originally Posted by MarcT View Post
I was led to believe it was a KDE bug:
https://bugs.kde.org/show_bug.cgi?id=181290
It still could be, I believe most, if not all, of Niki's clients are running XFCE without KDE installed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to choose portrait/landscape format for a picture under openoffice writer 2.3.9? xpucto Linux - Software 9 08-05-2009 03:38 PM
failure to print landscape greek63 Linux - Desktop 2 03-29-2007 05:38 AM
Getting a networked HP printer to print landscape mikeybuk Linux - Newbie 1 01-25-2006 06:31 PM
CUPS prints only small landscape format geomatt Linux - Software 1 10-07-2005 01:41 PM
Print Landscape the Other Way Round dvergin Linux - Software 2 04-23-2003 07:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration