LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-09-2006, 12:36 AM   #1
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
-bash: ./configure: /bin/sh: bad interpreter: Permission denied


The title says it all.

While trying to configure apache 2.2, this is the only output I get.

Here is the result while after extracting and trying even as root (I know, but was thinking it's a permission error:
Code:
/part4/apache/httpd-2.2.3# ./configure --prefix=/usr
-bash: ./configure: /bin/sh: bad interpreter: Permission denied
Running -current

The directory is just my storage hdd

EDIT** First line of configure:
Code:
#! /bin/sh

Last edited by cwwilson721; 08-09-2006 at 12:39 AM.
 
Old 08-09-2006, 12:40 AM   #2
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
Remove the space between the ! and the /, so it should just be:

Code:
#!/bin/sh
 
Old 08-09-2006, 12:43 AM   #3
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649

Original Poster
Blog Entries: 1

Rep: Reputation: 66
Tried that, no good. So I recreated the /bin/sh link to /bin/bash, and it worked...
 
Old 08-09-2006, 01:10 AM   #4
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649

Original Poster
Blog Entries: 1

Rep: Reputation: 66
oops. Too soon. It worked on one machine, but not the one I need to configure/install it on.

Ideas?
 
Old 08-09-2006, 01:52 AM   #5
crazyjimbo
Member
 
Registered: Mar 2006
Location: Edinburgh
Distribution: Debian Etch, Gentoo
Posts: 90

Rep: Reputation: 16
I THINK this happens when the script is formatted in DOS formatting. *nix systems use a differant ASCII code for newlines than DOS and this causes problems if it is formatted in the DOS way. Which ever editor you are using should have an option for the file format to save in.
 
Old 08-09-2006, 01:54 AM   #6
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649

Original Poster
Blog Entries: 1

Rep: Reputation: 66
I haven't touched the script. It's from the Apache site, never modified by me.

If what you say IS the case, wouldn't this have shown up earlier by others trying to compile this?

Plus, it does configure on one machine, but not another...

Last edited by cwwilson721; 08-09-2006 at 01:55 AM.
 
Old 08-09-2006, 01:58 AM   #7
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
I'm not sure if you checked this or not, but I remember getting this error when I was building LFS. Turned out my configure script (and a few others) were not exacutable. This wasn't for apache though. Perhaps it might be the same for your situation? You might also want to check any other scripts that is run by configure since I seem to remember this to be a problem under the same program I was trying to compile (sorry I don't remember which one).

regards,
...drkstr

**edit**
Quote:
Plus, it does configure on one machine, but not another...
Hmm, my responce is probably not the answer then. Maybe try 'sh configure --prefix=/usr' just for testing purposes?

Last edited by drkstr; 08-09-2006 at 02:01 AM.
 
Old 08-09-2006, 02:01 AM   #8
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649

Original Poster
Blog Entries: 1

Rep: Reputation: 66
The machine it won't compile on compiles other sources with no problem.

And the script works, because it compiles on another machine after resetting the /bin/sh softlink.

So whats up?
 
Old 08-09-2006, 02:02 AM   #9
crazyjimbo
Member
 
Registered: Mar 2006
Location: Edinburgh
Distribution: Debian Etch, Gentoo
Posts: 90

Rep: Reputation: 16
Just did some testing, and a file in DOS formatting gives the error:

Code:
: bad interpreter: No such file or directory
so it probably isn't the cause. My apologies, I don't know what else to suggest.
 
Old 08-09-2006, 02:06 AM   #10
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649

Original Poster
Blog Entries: 1

Rep: Reputation: 66
On second look, it seems that it does NOT configure other sources...

What's up? Same error, different source.

How do i resolve this? Try to reinstall bash from the /slackware dir?
 
Old 08-09-2006, 02:09 AM   #11
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Quote:
Try to reinstall bash from the /slackware dir?
That would might do it for you. I've hadd to do an 'upgradepkg --reinstall a/*.tgz' a few times to get me out of a jam. You said it works on the other machine? Just out of curiosity, is their any diffrence in the bash versions? If you're running Slack-10.2, do you have the bash version from the patch directory or the regular a/ directory installed?

...drkstr
 
Old 08-09-2006, 02:11 AM   #12
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546
Can you try compiling through strace? Often that will provide a clue of the hurdle.
 
Old 08-09-2006, 02:31 AM   #13
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649

Original Poster
Blog Entries: 1

Rep: Reputation: 66
Both are running -current, the one I'm trying to compile to is about 2 wks newer...I'll check into it...
 
Old 08-09-2006, 06:19 AM   #14
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649

Original Poster
Blog Entries: 1

Rep: Reputation: 66
They are both running:
Code:
:~$ bash --version
GNU bash, version 3.1.17(2)-release (i486-slackware-linux-gnu)
Copyright (C) 2005 Free Software Foundation, Inc.
I reinstalled bash. No good. What else could be going on?
 
Old 08-09-2006, 06:40 AM   #15
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware64 14.2 and current, SlackwareARM current
Posts: 1,609

Rep: Reputation: 131Reputation: 131
Has the partition that stores the files set the exec permission? I had recently the same problem with a Slackbuild script I had started from an vfat partition, and that partition had the noexec attribute set in fstab (or not explicitly set the exec option).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/bin/sh: bad interpreter: Permission denied njbrain Slackware 10 04-26-2010 12:46 PM
/bin/bash: bad interpreter: Permission denied cap_ahab Linux - General 4 01-17-2006 09:11 AM
/bin/sh: bad interpreter: Permission denied itsaso Linux - Newbie 6 05-18-2005 11:00 AM
Selinux, ./INSTALL: /bin/sh: bad interpreter: Permission denied TomF Linux - Security 2 12-08-2004 12:36 PM
/bin/sh: bad interpreter: Permission denied linmix Linux - Software 12 08-16-2004 07:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration