LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   -bash: ./configure: /bin/sh: bad interpreter: Permission denied (https://www.linuxquestions.org/questions/slackware-14/bash-configure-bin-sh-bad-interpreter-permission-denied-472179/)

cwwilson721 08-08-2006 11:36 PM

-bash: ./configure: /bin/sh: bad interpreter: Permission denied
 
The title says it all.

While trying to configure apache 2.2, this is the only output I get.

Here is the result while after extracting and trying even as root (I know, but was thinking it's a permission error:
Code:

/part4/apache/httpd-2.2.3# ./configure --prefix=/usr
-bash: ./configure: /bin/sh: bad interpreter: Permission denied

Running -current

The directory is just my storage hdd

EDIT** First line of configure:
Code:

#! /bin/sh

liquidtenmilion 08-08-2006 11:40 PM

Remove the space between the ! and the /, so it should just be:

Code:

#!/bin/sh

cwwilson721 08-08-2006 11:43 PM

Tried that, no good. So I recreated the /bin/sh link to /bin/bash, and it worked...

cwwilson721 08-09-2006 12:10 AM

oops. Too soon. It worked on one machine, but not the one I need to configure/install it on.

Ideas?

crazyjimbo 08-09-2006 12:52 AM

I THINK this happens when the script is formatted in DOS formatting. *nix systems use a differant ASCII code for newlines than DOS and this causes problems if it is formatted in the DOS way. Which ever editor you are using should have an option for the file format to save in.

cwwilson721 08-09-2006 12:54 AM

I haven't touched the script. It's from the Apache site, never modified by me.

If what you say IS the case, wouldn't this have shown up earlier by others trying to compile this?

Plus, it does configure on one machine, but not another...

drkstr 08-09-2006 12:58 AM

I'm not sure if you checked this or not, but I remember getting this error when I was building LFS. Turned out my configure script (and a few others) were not exacutable. This wasn't for apache though. Perhaps it might be the same for your situation? You might also want to check any other scripts that is run by configure since I seem to remember this to be a problem under the same program I was trying to compile (sorry I don't remember which one).

regards,
...drkstr

**edit**
Quote:

Plus, it does configure on one machine, but not another...
Hmm, my responce is probably not the answer then. Maybe try 'sh configure --prefix=/usr' just for testing purposes?

cwwilson721 08-09-2006 01:01 AM

The machine it won't compile on compiles other sources with no problem.

And the script works, because it compiles on another machine after resetting the /bin/sh softlink.

So whats up?

crazyjimbo 08-09-2006 01:02 AM

Just did some testing, and a file in DOS formatting gives the error:

Code:

: bad interpreter: No such file or directory
so it probably isn't the cause. My apologies, I don't know what else to suggest.

cwwilson721 08-09-2006 01:06 AM

On second look, it seems that it does NOT configure other sources...

What's up? Same error, different source.

How do i resolve this? Try to reinstall bash from the /slackware dir?

drkstr 08-09-2006 01:09 AM

Quote:

Try to reinstall bash from the /slackware dir?
That would might do it for you. I've hadd to do an 'upgradepkg --reinstall a/*.tgz' a few times to get me out of a jam. You said it works on the other machine? Just out of curiosity, is their any diffrence in the bash versions? If you're running Slack-10.2, do you have the bash version from the patch directory or the regular a/ directory installed?

...drkstr

Woodsman 08-09-2006 01:11 AM

Can you try compiling through strace? Often that will provide a clue of the hurdle.

cwwilson721 08-09-2006 01:31 AM

Both are running -current, the one I'm trying to compile to is about 2 wks newer...I'll check into it...

cwwilson721 08-09-2006 05:19 AM

They are both running:
Code:

:~$ bash --version
GNU bash, version 3.1.17(2)-release (i486-slackware-linux-gnu)
Copyright (C) 2005 Free Software Foundation, Inc.

I reinstalled bash. No good. What else could be going on?

titopoquito 08-09-2006 05:40 AM

Has the partition that stores the files set the exec permission? I had recently the same problem with a Slackbuild script I had started from an vfat partition, and that partition had the noexec attribute set in fstab (or not explicitly set the exec option).


All times are GMT -5. The time now is 12:23 PM.