LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-17-2005, 10:37 PM   #1
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Rep: Reputation: 30
Alsa working under 2.6.10


I'm using the intel8x0 driver and after adding snd-intel8x0m to /etc/hotplug/blacklist it would work under 2.4.29.

I booted into the generic 2.6.10 kernel and the modules aren't loaded, so I looked into the kernel config and ALSA seems to be disabled for some reason.

So I believe my options are to:

Build the module from the kernel source, although I'm not sure the steps to do this without doing a whole kernel recompile.

Uninstall and reinstall the alsa packages from the CD.

Or download the source and install it.

I'd like to try installing the packages from the CD first, but do I have to reinstall every ALSA package? What about just removing the alsa-drivers package and reinstalling that? I'd hate to mess it up and lose sound under 2.4.29
 
Old 02-17-2005, 10:51 PM   #2
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
After I upgraded to 2.6.10 from 2.4 all I did was download the latest alsa, one package and installed it then got the alsa config and the other optional package, Installed them and then enabled sound in KDE, ran alsa config and alsa mixer to unmute everything and I had sound. I cannot remember what I did as far as loading the modules goes. , I had to enable hotplug for my sound to work but I think thats normal.
 
Old 02-17-2005, 10:54 PM   #3
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
I am going to do the same.

BajaNick. You enabled hotplug for ALSA to work? Ok, I'll try the same, thanks!

I've been having a hell of a time trying to configure ALSA to work.
 
Old 02-17-2005, 11:02 PM   #4
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
man compiling the kernel is such easy and you get used to it very easily..
just set everything in the ALSA tab to "m" (module) and if it is not possible to set "m", set "y"...
save

in the console, type:
make modules (to compile the modules)
make modules_install (to install the modules)

and reboot..
 
Old 02-17-2005, 11:07 PM   #5
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
That's what I did! Still I get no sound. I followed all the instructions and I even got sound to work when I installed the drivers from www.alsa-project.org. But once I reboot I lose sound again and the card is not detected.

I tried both the kernel sound module and the downloaded driver from alsa-project.

The kernel built-in compiled modules for ALSA did not work.
I'll try again with 2.6.10 though.
 
Old 02-17-2005, 11:08 PM   #6
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
Joanne, I think I remember reading being able to compile the module seperately under the /usr/src/linux directory without having to recompile the whole kernel. But I don't remember exactly how. Oh well, I probably need to do a kernel recompile anyway.
 
Old 02-17-2005, 11:10 PM   #7
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Harishankar
That's what I did! Still I get no sound. I followed all the instructions and I even got sound to work when I installed the drivers from www.alsa-project.org. But once I reboot I lose sound again and the card is not detected.

I tried both the kernel sound module and the downloaded driver from alsa-project.

The kernel built-in compiled modules for ALSA did not work.
I'll try again with 2.6.10 though.
Did you do this under 2.6.10 or 2.4.29?
 
Old 02-17-2005, 11:15 PM   #8
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
I did it under 2.6.7.
 
Old 02-17-2005, 11:21 PM   #9
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
there is indeed a way to compile it separately...

Harishankar

just some hints if you've not done this yet:
#run "alsaconf" for ALSA to detect your sound card (and make sure your kernel is set up to support it).
#run "alsamixer" to see and set up the volumes in general..
#run "alsactl store" to store you settings for next boots...

compiling the kernel will just create the environment for ALSA to work.
the configuration is up to you..
sorry if you've already run such commands. :-)

sharpie

I've gone with kernel recompilation with kernels 2.4.26, 2.4.29, and 2.6.10..
 
Old 02-17-2005, 11:23 PM   #10
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
and the most interesting thing is that I'm also running intel8x0 driver..
 
Old 02-17-2005, 11:25 PM   #11
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
I must have run alsaconf about a 100 times already

I ran alsamixer and got an error (you'll see the message in the other thread. I'm in my Debian box now).

I get a message
Code:
alsactl: load_state:1134: No soundcards found...
 
Old 02-17-2005, 11:28 PM   #12
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
I even recompiled the kernel without ALSA support, downloaded the alsa drivers from the alsa project site and installed them.

Sound worked. But once I rebooted sound was lost again! So you see... I have tried almost everything.
 
Old 02-17-2005, 11:36 PM   #13
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
looks like you've been fighting with Slack..
sorry if I couldn't help..
 
Old 02-17-2005, 11:39 PM   #14
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
No problem. You've all been very helpful. I just would like to try the hotplug though.

Not that I assume it'll work. I think I'd better install a fresh kernel and try again from scratch. It's easier than trying to figure out what went wrong where.

The best part is, I have a fully working and configured Linux system in Debian. I can take all the time I want to get Slackware to work fully.

Last edited by vharishankar; 02-17-2005 at 11:40 PM.
 
Old 02-18-2005, 05:34 AM   #15
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Rep: Reputation: 205Reputation: 205Reputation: 205
Let me just note that it is *not* necessary to compile your kernel or ALSA in Slackware 10.1 just to get sound working, although you may have reasons to do it anyway.

I can't tell anything regarding your specific hardware, but usually all you need to do is this:

As root:
(1) telinit 1
(2) mount CD 3 (or ISO image of it)
(3) cd /testing/packages/linux...2.6.10 (on CD 3)
(4) installpkg *.tgz
(This will install the new kernel and the matching ALSA packages)
(5) configure and run lilo (see README file for initrd in the same directory as the kernel binary)
(6) telinit 3 (or 4, if you like)
(7) alsaconf

As regular user:
(8) Log in.
(9) In an xterm or console: alsamixer (or some other mixer, like aumix). Unmute everything, pump up the volume.

As root:
(10) alsactl store

As regular user:
(11) Start KDE Kontrol center (even if you normally prefer Gnome!).
(12) Set up sound (for one or two options you must switch to sysadmin mode, but it's self-explanatory).

Good luck!

gargamel

Last edited by gargamel; 02-18-2005 at 05:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA not working bcf2 Mandriva 13 12-09-2004 10:32 AM
alsa not working ZaphyR Linux - Newbie 8 08-12-2004 03:05 PM
alsa 0.9.6/7 not working? Toker Mandriva 1 10-13-2003 06:55 PM
alsa not working Hampster Linux - Newbie 4 08-24-2003 02:35 AM
ALSA and EMU10K1 working and yet not working Nevernamed90 Linux - Newbie 1 01-09-2003 02:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration