LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-23-2005, 08:40 AM   #1
rgogada
LQ Newbie
 
Registered: Jun 2005
Location: India
Distribution: Slackware 10.1
Posts: 13

Rep: Reputation: 0
Slackware 10.1 snd-intel8x0 no sound


Hi, I am a newbee to linux. I have recently installed slackware 10.1. everything is fine but, there is no sound. I have integrated sound card with my intel 845gl mother board. I did run the alsa mixer and unmuted. I have black listed the snd-intel8x0m as adviced by some threads. still no luck. I could play my dvds with xine with out sound. when i run the lsmod and lspci the sound card did appear. please somebody help.

thanks in advance.
 
Old 06-23-2005, 08:57 AM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
did you run alsaconf?
 
Old 06-23-2005, 09:51 AM   #3
rgogada
LQ Newbie
 
Registered: Jun 2005
Location: India
Distribution: Slackware 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
yes. and it did show my sound card which I have selected and finished the remaining setup.
thanks for responding. Kindly tell me what should I do now??
 
Old 06-23-2005, 11:38 AM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
just to recap:

- you ran alsaconf
- you unmuted both master and pcm in alsamixer
- you checked lsmod and your snd module is listed

the basics seem to be covered. the hotplug blacklisting i'm a little iffy on. my sound modules are not in the blacklist and my sound works. maybe try it with and without. do you have sound running things as root?

another idea if you haven't done it yet would be to check your bios to make sure the integrated sound is enabled, and check your hardware, make sure volumes are up, speakers are on, cords are in the proper jack, etc. (don't laugh, it happened to me last week after adding a hard drive. ) have you ever had sound on that computer?
 
Old 06-24-2005, 05:18 AM   #5
rgogada
LQ Newbie
 
Registered: Jun 2005
Location: India
Distribution: Slackware 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the response and I completely agree on what you said. My speakers are very much on and working with windows xp. However I could not run the alsaconfig as a normal user. I could run alsamixer but couldn't store. so I did all that sa root. does that really matter??
 
Old 06-24-2005, 09:27 AM   #6
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
Quote:
Originally posted by rgogada
Thanks for the response and I completely agree on what you said. My speakers are very much on and working with windows xp. However I could not run the alsaconfig as a normal user. I could run alsamixer but couldn't store. so I did all that sa root. does that really matter??
you run alsaconf as root, and alsamixer as user. then you run alsactl store as root to store the settings.

why don't you post your kernel sound options and lsmod? it's possible you're missing something. i would think that would make alsa fail somewhere, but maybe not.
 
Old 06-25-2005, 09:06 AM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
As this is a Slackware problem this post is now in the Slackware forum
 
Old 06-26-2005, 10:36 PM   #8
speck
Member
 
Registered: Nov 2001
Location: US
Distribution: Slackware 14.2
Posts: 354

Rep: Reputation: 93
I have sound running on a Slackware 10.1 machine that also uses the intel8x0 ASLA drivers. It's a different motherboard (Asus), but maybe this output could serve as a reference.

/sbin/lsmod
Code:
snd-pcm-oss            38304   0
snd-mixer-oss          13688   0 [snd-pcm-oss]
snd-intel8x0           19808   0
snd-ac97-codec         66012   0 [snd-intel8x0]
snd-pcm                59208   0 [snd-pcm-oss snd-intel8x0 snd-ac97-codec]
snd-timer              14948   0 [snd-pcm]
snd                    34788   0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer]
soundcore               3652   4 [snd]
snd-page-alloc          4968   0 [snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd]
cat /etc/modules.conf
Code:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0

# ALSA module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
 
Old 06-26-2005, 11:15 PM   #9
unfunfofmpc
LQ Newbie
 
Registered: Jun 2005
Posts: 6

Rep: Reputation: 0
I have this exact same problem :\ I guess I will try enabling OSS.
 
Old 06-27-2005, 12:39 AM   #10
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
For me, i can only have sound when i have master, headphone and pcm all turned up and unmute. I dont know why i need to unmute headphone, but i must do it in order to get sound. maybe you have a strange pc like mine too, try it.
 
Old 06-27-2005, 04:24 AM   #11
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current, SlackwareARM-current
Posts: 780

Rep: Reputation: 66
In alsamixer, turn off (mute):
* Headphone Jack Sense
* Line Jack Sense
I'm almost sure that'll do the trick!

Cheers, Leon.
 
Old 06-27-2005, 01:35 PM   #12
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Quote:
Originally posted by LJSBrokken
In alsamixer, turn off (mute):
* Headphone Jack Sense
* Line Jack Sense
I'm almost sure that'll do the trick!

Cheers, Leon.
This always works for me.
 
Old 06-30-2005, 03:19 AM   #13
rgogada
LQ Newbie
 
Registered: Jun 2005
Location: India
Distribution: Slackware 10.1
Posts: 13

Original Poster
Rep: Reputation: 0
un believable. thanks Leon. it worked for me too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound won't work ! (snd-intel8x0) djib MEPIS 3 09-25-2005 04:37 PM
Slackware 10.1 Module snd-intel8x0, sound not working! naimslim89 Linux - Hardware 3 08-21-2005 04:13 AM
no sound with snd-intel8x0 rgogada Slackware 23 07-03-2005 11:00 AM
For those with snd-intel8x0 sound cards! evilstrike Linux - Laptop and Netbook 4 06-14-2005 01:06 PM
Can't locate module snd-intel8x0, no sound letdoit Slackware 12 05-25-2004 10:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration