LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices


Reply
  Search this Thread
Old 03-31-2020, 01:47 PM   #1
sudhirsharma02
LQ Newbie
 
Registered: Mar 2020
Posts: 1

Rep: Reputation: Disabled
MISSING REQUISITES: openssl.base 20.13.101.9999


Dear Team,

getting below error while installing OpenSSH_8.1.102.2000 in AIX 6.1.

MISS ING REQUISITES: The following filesets are required by one or more of the selected filesets listed above. They are not currently installed and could not be found on the installation media.

openssl.base 20.13.101.9999 # Fileset Update

when i run below command it says already installed.
-bash-4.3# lslpp -l openssl.base
Fileset Level State Description
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
openssl.base 20.13.101.500 COMMITTED Open Secure Socket Layer

Path: /etc/objrepos
openssl.base 20.13.101.500 COMMITTED Open Secure Socket Layer
-bash-4.3#

please help.

Regards,
Sudhir Sharma
 
Old 03-31-2020, 02:40 PM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,829
Blog Entries: 15

Rep: Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668
I'm not an AIX guy but it appears you have3 a different version than it is saying you need.

You say first: openssl.base 20.13.101.9999

But have: openssl.base 20.13.101.500

Unless 9999 is some sort of default mask for "any subversion" it would appear you'd need to upgrade from .500 to .9999
 
1 members found this post helpful.
Old 03-31-2020, 04:03 PM   #3
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,709

Rep: Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245Reputation: 6245
Quote:
Originally Posted by sudhirsharma02 View Post
Dear Team,
getting below error while installing OpenSSH_8.1.102.2000 in AIX 6.1.
Code:
MISSING REQUISITES:  The following filesets are required by one or more of the selected filesets listed above.  They are not currently installed and could not be found on the installation media.

    openssl.base 20.13.101.9999               # Fileset Update
when i run below command it says already installed.
Code:
-bash-4.3# lslpp -l openssl.base
  Fileset                      Level  State      Description
  ----------------------------------------------------------------------------
Path: /usr/lib/objrepos
  openssl.base         20.13.101.500  COMMITTED  Open Secure Socket Layer

Path: /etc/objrepos
  openssl.base         20.13.101.500  COMMITTED  Open Secure Socket Layer
-bash-4.3#
please help.

Regards,
Sudhir Sharma
We are not on your 'team', but we are volunteers who try to help folks. Aside from what MensaWater pointed out, there is a big issue I can see; you are using AIX 6.1...which was released *TWELVE YEARS AGO*, and hit end-of-life support three years ago. Why on EARTH are you using such an old OS? It is very, VERY far behind on security patches, updates, and bug fixes. You most likely WILL NOT be able to install current packages on that system, and honestly you should not even try. The microcode is probably similarly out of date, and cannot be patched either, and your entire system is vulnerable.

Putting a later version of openSSL on your system would be like putting a fresh coat of paint on a car that barely runs. You need to fix your underlying problems first, and since you're using AIX, have you contacted IBM support?
 
Old 04-02-2020, 02:21 AM   #4
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 4,035

Rep: Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461
If you got this package from some official [IBM] source, the dependencies should be also available there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MISSING REQUISITES : rsct.core.sensorrm 2.3.0.0 # Base Level Fileset Liquidx AIX 2 10-14-2007 01:30 AM
9999 numbers explained!! Hitboxx General 9 08-15-2007 01:33 PM
Problems with installation 9999 screen ebocchino Linux - Newbie 3 05-31-2006 12:25 AM
my linux doesnt boot ... (lilo) only appear 9999.... who knows what happend??? eder_michael11 General 1 03-07-2006 12:24 AM
Having problem booting up linux... get a 9999 Nosram Linux - General 4 02-04-2004 05:39 AM

LinuxQuestions.org > Forums > Other *NIX Forums > AIX

All times are GMT -5. The time now is 02:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration