LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 03-27-2007, 10:53 AM   #1
spikesnet
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Rep: Reputation: 0
rhel5 yum not working


I've installed rhel5 64bit and I'm trying to run 'yum list' but I get the following error:

~# yum list
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up repositories
Error: Cannot open/read repomd.xml file for repository: rhel-x86_64-server-5


My system is registered on RHN and I'm using a proxy so I have this in my /etc/yum.conf:

proxy=proxy_serverort


My /etc/yum.conf:

[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
proxy=proxy_serverort

My /etc/yum/pluginconf.d/rhnplugin.conf:

[main]
enabled = 1
gpgcheck = 1

Last edited by spikesnet; 03-27-2007 at 01:10 PM.
 
Old 03-27-2007, 10:54 AM   #2
spikesnet
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
BTW the proxy= line is correct in the conf file but I couln't post it here because it was my first post and first posts can not contain urls.
 
Old 07-31-2007, 04:29 PM   #3
GT3NE1
LQ Newbie
 
Registered: Aug 2004
Posts: 24

Rep: Reputation: 15
repomd.xml is stored in /var/cache/yum/rhel.....

I would start by check on the permissions of those directories and whether or not those files exist.
 
Old 08-01-2007, 07:33 AM   #4
spikesnet
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by GT3NE1
repomd.xml is stored in /var/cache/yum/rhel.....

I would start by check on the permissions of those directories and whether or not those files exist.

It turned out that Red Hat Network wasn't compatible with the proxy server (apache mod_proxy) that I was using. I switched to squid and all is working now.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
system-config-httpd in RHEL5 - cant start apache :( BigG Red Hat 13 01-31-2008 06:31 PM
Firefox 2.0 and Yum for RHEL5 vicky_me Red Hat 1 03-25-2007 08:20 AM
Is kdb rpm is available in RHEL5 release poornimasuresh Linux - Kernel 0 03-20-2007 07:03 AM
RHEL5 debug kernel unixhack Linux - Kernel 3 12-14-2006 09:27 AM
Anyone know whether RHEL5 will ship with PHP5? warning_uk Red Hat 8 09-10-2006 05:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 03:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration