LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > NuTyX
User Name
Password
NuTyX This forum is for the discussion of NuTyX.

Notices


Reply
  Search this Thread
Old 01-28-2018, 03:19 PM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,082

Rep: Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903
cool-retro-term flcards does not install deps along with it.


that is all I could copy off term...

using term and flcards, I just searched and installed what was missing. Should not this be installed long with cool-retro-term when that gets selected to be installed?

Just an FYI , just in case ...
yes it is now working....

Code:
x [ ~ ]$ cool-retro-term       [16:13 x86_64 4.14.13-NuTyX-lts userx@nutyx]
cool-retro-term: Relink `/usr/lib/libpng16.so.16' with `/lib/libpthread.so.0' for IFUNC symbol `longjmp'
cool-retro-term: Relink `/usr/lib/libfreetype.so.6' with `/lib/libpthread.so.0' for IFUNC symbol `longjmp'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-userx'
QQmlApplicationEngine failed to load component
qrc:/main.qml:23 module "QtQuick.Controls" is not installed
qrc:/main.qml:24 module "QtGraphicalEffects" is not installed
qrc:/main.qml:23 module "QtQuick.Controls" is not installed
qrc:/main.qml:24 module "QtGraphicalEffects" is not installed

Cannot load QML interface          [16:13 x86_64 4.14.13-NuTyX-lts userx@nutyx]
userx [ ~ ]$ cool-retro-term
cool-retro-term: Relink `/usr/lib/libpng16.so.16' with `/lib/libpthread.so.0' for IFUNC symbol `longjmp'
cool-retro-term: Relink `/usr/lib/libfreetype.so.6' with `/lib/libpthread.so.0' for IFUNC symbol `longjmp'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-userx'
QQmlApplicationEngine failed to load component
qrc:/main.qml:24 module "QtGraphicalEffects" is not installed

Cannot load QML interface
userx [ ~ ]$ cool-retro-term
cool-retro-term: Relink `/usr/lib/libpng16.so.16' with `/lib/libpthread.so.0' for IFUNC symbol `longjmp'           [16:13 x86_64 4.14.13-NuTyX-lts userx@nutyx]
cool-retro-term: Relink `/usr/lib/libfreetype.so.6' with `/lib/libpthread.so.0' for IFUNC symbol `longjmp'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-userx'
QQmlApplicationEngine failed to load component
qrc:/main.qml:135 Type TerminalContainer unavailable
qrc:/TerminalContainer.qml:37 Type PreprocessedTerminal unavailable
qrc:/PreprocessedTerminal.qml:24 module "QMLTermWidget" is not installed

Cannot load QML interface
 
Old 01-29-2018, 04:25 AM   #2
tnut
NuTyX Founder
 
Registered: May 2016
Location: Switzerland
Distribution: NuTyX
Posts: 107

Rep: Reputation: Disabled
So ?
What is the question now ?
 
Old 01-29-2018, 07:10 AM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,082

Original Poster
Rep: Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903
Quote:
Originally Posted by tnut View Post
So ?
What is the question now ?
That is what FYI means, For Your Information. I was just trying to help you out in informing you of a (possible) glitch.

it was a just letting you know it does not install deps along with it , and should not that be the default characteristics of a system to install all of the deps to any application that is being installed along with the application?

though I am using 9.x version which I just thought of this morning (just now), so it may not even be worth dealing with, because nutyx it now 10. and well I just read it cannot be upgraded to 10.x due to too many changes. So where does that leave me? wifi demands a password upon installing 10 and I do not use a password, and we've already covered that glitch, that is why I am using 9.x -


yet, I'd like to learn how to get through this chroot process to make apps for this Distro, to put into its repo, because if I got to figure all of that out just to get what I use in just windowmaker to work, wmsystemtray, blueman, and some dockapps for starters, and not necessary in that order, and I might as well submit it too, so others will have them as well. Along with whatever else...

so doing all of this on 9.x to me would be a waste of time to be applied to 10.x or no?
 
Old 01-29-2018, 01:48 PM   #4
tnut
NuTyX Founder
 
Registered: May 2016
Location: Switzerland
Distribution: NuTyX
Posts: 107

Rep: Reputation: Disabled
Your deps wasn't found because your config wasn't correct I guess. Check this and let me know
I'm building handbracke for your info as Rems did commit the package

Quote:
I am using 9.x -
9.x version is obsolet, you won't even be able to install anything on it.

Last edited by tnut; 01-29-2018 at 01:58 PM. Reason: 9.x version is obsolet
 
Old 01-29-2018, 02:53 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,082

Original Poster
Rep: Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903Reputation: 1903
Quote:
Originally Posted by tnut View Post
Your deps wasn't found because your config wasn't correct I guess. Check this and let me know
I'm building handbracke for your info as Rems did commit the package


9.x version is obsolete, you won't even be able to install anything on it.
I installed this one,it shows 9.93 I think it was, on the grub boot screen.
https://tronyx-world.tech/nutyx/?C=M;O=D
I'd surely appreciate and step by step how to chroot this thing. soI can get some hands on experience in this pkgmk thingy. as the chroots I've tried all come up no dir or missing files and will not complete the chroot, to move on with it.

-----
my pkgmk is default freshly installed because I reinstalled. I haven't gotten to redoing cool term yet. I've been trying to get a font.conf back again that list the long names for the fonts, that I found in terminus-font dir, it has a font.cont that i used to show tooltips in a dockapps, that is not there anymore on this fresh install. yes, I do not want to sound like a hey look at all of this stuff that is not working.. makes me feel like i am starting to be a bother.
-----
I did do a install 10 off a running distro, and I got 10 on the grub listing using a different distro ( solus) that controls the grub. but again no network to finish off with a gui, ( just playing round partitions)

as far as that pkgmk.conf I bet it was default install because I didn't mod anything on it. On the last install either. so it looks like their is a little bit of finagling left to do after installing to get it set up right and proper before installing what nots.

Last edited by BW-userx; 01-29-2018 at 03:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Window Maker Live: Cool Retro Look, Even Cooler Performance LXer Syndicated Linux News 0 08-29-2017 08:10 AM
LXer: Cool-Retro-Term : Terminal Emulator with Retro Style LXer Syndicated Linux News 0 10-10-2014 06:31 AM
Package manager wants to REMOVE a lot of stuff when trying to install Wine deps mike4ty4 Debian 1 06-29-2014 03:04 AM
Attempting to install xcb 1.4 and other AwesomeWM deps on Slack64 13 conartist6 Linux - Software 6 11-09-2009 09:25 PM
How to install Opera in Puppy 4.1.2 Retro otropogo Puppy 2 12-21-2008 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > NuTyX

All times are GMT -5. The time now is 12:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration