LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 01-31-2005, 09:47 AM   #1
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Rep: Reputation: 30
Porblems with eth0... Hangs on Boot


Recently, I switched to DSL. And during boot, the "Bringing up Interface eth0" hangs about 2 minutes.

I sure I cant disable the eth0 because its used for the DSL newtwork card. Is there an easy soltuion to this? I just switched to Mandrake.

I literally tried posting this but knowone knows.
 
Old 01-31-2005, 09:52 AM   #2
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
do you get your ip assigned dynamically by your ISP each time you start the compnuter?

Maybe that is what take the time.
Hamish
 
Old 01-31-2005, 09:52 AM   #3
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
is there a DHCP server on the network ?
i have 2 network cards, sometimes DSL spends aaages waiting for a DHCP responce on the unused card before giving up and continuing to boot.

if you ont have dhcp, set the card to have a static IP.
 
Old 01-31-2005, 09:54 AM   #4
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
See if this helps you:
http://www.comptechdoc.org/os/linux/manual1/dsl.html

- Peder
 
Old 01-31-2005, 10:21 AM   #5
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Its a Dynamic IP service with DHCP. I have only one NIC.

I cant beleive this, no ones knows how to fix this issue. I dont think there is a fix to this because I asked literally every forum I gone to.
 
Old 01-31-2005, 10:31 AM   #6
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
What happens if you run 'service network start' ? Do you get any errors
in /var/log/messages and 'dmesg' ? You can also do a 'ps ax' in another window
during the "service network start" and see if there are any processes that seems hung.

And with DSL, aren't you supposed to log in somewhere before getting an IP?

Did you check the link I provided?

We need all the info possible to be able to help.

- Peder
 
Old 01-31-2005, 08:23 PM   #7
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
...I also hear turning off the acpi on boot can help with that problem (I've seen it manifest itself differently on others)

another quick solution is to just turn off the eth0 deivce on boot and just turn it on with the ifup eth0 command as root.
 
Old 02-01-2005, 12:30 AM   #8
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Last night I just did that. I enable the "Start on Boot" or "Connect on Boot" option and it does not hang anymore.

But what if I do not want it to connect on boot? How will I solve this issue if I dont want to connect on boot?
 
Old 02-01-2005, 01:46 AM   #9
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
If you don't want your network to start on boot you should disable "Start On Boot"
You can the start it later by 'service network start' or 'ifup eth0' as root.

Note that not starting the network at boot might cause any other service that depends on
name resolving (like sendmail) to hang.

- Peder
 
Old 02-01-2005, 09:24 AM   #10
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
But with if I do not want to connect to the internet on boot? I how could I resolve this then? Nobody seems to know, I cant beleive it.
 
Old 02-01-2005, 10:37 AM   #11
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
I thought I answered that in my last post
Quote:
If you don't want your network to start on boot you should disable "Start On Boot"
Another way is to run 'chkconfig network off' in a terminal. This can possibly prevent
you from using X though.

- Peder
 
Old 02-01-2005, 01:02 PM   #12
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
I think I have the opposite. I have the Internet connection to start at boot and the Bringing up the eth0 Interface does not hang anymore.

But Im afraid to Uncheck it because because I will have the same issue again and I do not want the connection to start at bootup.
 
Old 02-02-2005, 01:14 AM   #13
bunnadik
Member
 
Registered: Jan 2005
Location: Ívik, Sweden
Distribution: MDK 10.1
Posts: 450

Rep: Reputation: 30
OK, so to sum things up:
You have "Start on Boot" enabled on the NIC, and you won't disable it for fear of hangs.
You won't disable the network on boot.

The only thing left as I see it is to unplug the network cord. That way you won't be connected
to the internet.

- Peder
 
Old 02-02-2005, 01:50 AM   #14
sgrayban
Member
 
Registered: Nov 2004
Location: Spokane, WA
Distribution: Debian 6.0
Posts: 369

Rep: Reputation: 30
as root type "chkconfig --del network"

network will never run again -- now i know this will make all your questions go away on this.

of course now anything needing the network wont work either like sendmail, apache and so on.

Last edited by sgrayban; 02-02-2005 at 01:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 freezes / hangs on boot after upgrade mandrake 10.1 to 10.2 Emmanuel_uk Mandriva 3 05-24-2005 07:26 AM
boot hangs at "Eth0" Help! I know this is an easy question!! skripx Linux - Newbie 3 12-26-2004 07:22 PM
Red Hat 7.1 eth0 hangs during boot Edicius Linux - Newbie 9 07-12-2004 07:28 PM
eth0 hangs on boot with mandrake 9.2 pls help!!!!! debloxie Mandriva 1 12-03-2003 03:15 PM
eth0 hangs on startup reichhorn Linux - Networking 1 06-19-2003 03:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 08:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration