LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Porblems with eth0... Hangs on Boot (https://www.linuxquestions.org/questions/mandriva-30/porblems-with-eth0-hangs-on-boot-284471/)

wardialer 01-31-2005 10:47 AM

Porblems with eth0... Hangs on Boot
 
Recently, I switched to DSL. And during boot, the "Bringing up Interface eth0" hangs about 2 minutes.

I sure I cant disable the eth0 because its used for the DSL newtwork card. Is there an easy soltuion to this? I just switched to Mandrake.

I literally tried posting this but knowone knows.

hamish 01-31-2005 10:52 AM

do you get your ip assigned dynamically by your ISP each time you start the compnuter?

Maybe that is what take the time.
Hamish

qwijibow 01-31-2005 10:52 AM

is there a DHCP server on the network ?
i have 2 network cards, sometimes DSL spends aaages waiting for a DHCP responce on the unused card before giving up and continuing to boot.

if you ont have dhcp, set the card to have a static IP.

bunnadik 01-31-2005 10:54 AM

See if this helps you:
http://www.comptechdoc.org/os/linux/manual1/dsl.html

- Peder

wardialer 01-31-2005 11:21 AM

Its a Dynamic IP service with DHCP. I have only one NIC.

I cant beleive this, no ones knows how to fix this issue. I dont think there is a fix to this because I asked literally every forum I gone to.

bunnadik 01-31-2005 11:31 AM

What happens if you run 'service network start' ? Do you get any errors
in /var/log/messages and 'dmesg' ? You can also do a 'ps ax' in another window
during the "service network start" and see if there are any processes that seems hung.

And with DSL, aren't you supposed to log in somewhere before getting an IP?

Did you check the link I provided?

We need all the info possible to be able to help.

- Peder

DeusExLinux 01-31-2005 09:23 PM

...I also hear turning off the acpi on boot can help with that problem (I've seen it manifest itself differently on others)

another quick solution is to just turn off the eth0 deivce on boot and just turn it on with the ifup eth0 command as root.

wardialer 02-01-2005 01:30 AM

Last night I just did that. I enable the "Start on Boot" or "Connect on Boot" option and it does not hang anymore.

But what if I do not want it to connect on boot? How will I solve this issue if I dont want to connect on boot?

bunnadik 02-01-2005 02:46 AM

If you don't want your network to start on boot you should disable "Start On Boot"
You can the start it later by 'service network start' or 'ifup eth0' as root.

Note that not starting the network at boot might cause any other service that depends on
name resolving (like sendmail) to hang.

- Peder

wardialer 02-01-2005 10:24 AM

But with if I do not want to connect to the internet on boot? I how could I resolve this then? Nobody seems to know, I cant beleive it.

bunnadik 02-01-2005 11:37 AM

I thought I answered that in my last post
Quote:

If you don't want your network to start on boot you should disable "Start On Boot"
Another way is to run 'chkconfig network off' in a terminal. This can possibly prevent
you from using X though.

- Peder

wardialer 02-01-2005 02:02 PM

I think I have the opposite. I have the Internet connection to start at boot and the Bringing up the eth0 Interface does not hang anymore.

But Im afraid to Uncheck it because because I will have the same issue again and I do not want the connection to start at bootup.

bunnadik 02-02-2005 02:14 AM

OK, so to sum things up:
You have "Start on Boot" enabled on the NIC, and you won't disable it for fear of hangs.
You won't disable the network on boot.

The only thing left as I see it is to unplug the network cord. That way you won't be connected
to the internet.

- Peder

sgrayban 02-02-2005 02:50 AM

as root type "chkconfig --del network"

network will never run again -- now i know this will make all your questions go away on this.

of course now anything needing the network wont work either like sendmail, apache and so on.


All times are GMT -5. The time now is 08:46 AM.