LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Installing .rpm and .tar.gz (https://www.linuxquestions.org/questions/mandriva-30/installing-rpm-and-tar-gz-203939/)

The_Messiah 07-11-2004 11:46 PM

Installing .rpm and .tar.gz
 
I was wondering how I go about installing .rpm and .tar.gz and .tgz files.

Any help is appreciated.

zulfilee 07-12-2004 12:26 AM

For RPM

rpm -ivh packagename -> TO install package

rpm -qip packagename ->To view package information before install

rpm -e packagename ->To uninstall package

rpm -q package ->To view if package is already inastalled




For tar.gz and tgz Both are same files with different extensions.

less filename ->TO view contents

tar -zxvf filename ->To untar the files

And if it has a READ me follow it for install[Normally ./configure , make and make
install is used .But see READme first before installing]


Cheers
Z

XavierP 07-12-2004 02:45 AM

http://www.linuxquestions.org/questi...threadid=45094 - Trickykid wrote a nice concise how to.

motub 07-12-2004 08:31 AM

Could someone explain to me why everybody answers a Mandrake's user's questions about installing software without even mentioning urpmi or RPMDrake? Not just here, either. Sorry, but this is a pet peeve of mine.

Anyway... Mandrake specific instructions:

Now in general, Mandrake has perfectly fine documentation, but I really have to give it a rasberry given that so many new users have no idea how to find the Mandrake repositories and use RPMDrake to install software from them. Since RPMDrake is one of the centerpiece jewels of the distro, I consider this a serious problem.

But OK. I will explain this again, because I'm on a (minor) mission to save Mandrake from itself . Other than this really unnecessary problem for new migrators, it's a fab distro.

--------------------------------------------------------------------------------

The 1-3 CDs you downloaded/got from a magazine/whatever contain the base Mandrake software and many extras. However, there are thousands of applications and games available that aren't on those CDs, and that you usually get from the Internet. A piece of software is in general known as a package, but a package may come in one of two forms: source packages, and binary packages.

Source packages have to be compiled by the user; binary packages are precompiled, so they only need to be installed. Wherever possible, you want to install binary packages for your distribution. Herein lies the rub. Mandrake is an RPM distribution, which means that precompiled binaries will end in the file extension *.rpm. However, Mandrake is not the only RPM distro (SuSE and RedHat/Fedora come to mind as examples of 2.5 others)-- and RPMs compiled for SuSE or RedHat are not compatible with Mandrake, and vice-versa.

This is why there are repositories. These are collections of packages, mirrored all over the world, for each distribution. The Mandrake repositories have thousands of packages (I mean thousands), all ready to download and install. But first, you have to know where they are, and then you have to tell Mandrake where they are.

The fastest, easiest way to deal with this is to add repositories to your Software Media Manager. Go to Kicker/Foot=>Configuration=>Configure your computer; or just click the Mandrake Control Center icon on your panel, then go to Software Management and you will see the Software Media Manager. Unfortunately, it only contains the CDs you installed from as sources for additional software. That is still necessary, and can be useful, but you want to add external sources from the Internet.

Here's how:

Go to Easy URPMI, and follow the instructions there to add external repositories to your Software Sources Manager. If you're on dial-up, make sure to check the "Use compressed index, much smaller than normal, with less informations" checkbox.

The instruction "Type this in a terminal as root" is performed as follows:

1) Open a terminal.

2) Type su and hit enter.

3) Type the root password at the Password: prompt and hit Enter. The password will not be echoed to the screen, even with stars, so type carefully.

4) If the password was correctly typed, the prompt should change from a "$" which indicates user access, to a "#" which indicates root access. All commands typed into this terminal window from this point on will be performed as if root had requested them. If this does not work (and you have correctly entered the root password), the problem is that the user is not a member of the wheel group; go to the Mandrake User Management tool in the Mandrake Control Center and add the user to that group, then try steps 2 and 3 again.

5) Select and copy one line of output from the Easy URPMI page (from urpmi.addmedia to hdlist.cz or synthesis.hdlist.cz depending on whether you checked the "use compressed index" box) and paste that line into the root terminal using CTRL+Shift+V (Ctrl+Shift+V is the "Paste" keybinding for gnome-terminal; it's Shift+Insert if you use Konsole, and middle mouse button-- or right and left buttons together if you don't have a middle button or wheel/button-- in an xterm). You should see the repository being added before you are returned to the prompt. Repeat for all repositiores listed in the Easy URPMI Step 3 output.

You should now be able to open RPMDrake (Mandrake Control Center=>Software Management=>RPMDrake (Install Software) and see a great deal of software available for download and installation. You will see even more if you change the filter at the top of the dialog from "Mandrake Choices" (the default) to "All Software by...." (I usually use "by group", but you can choose from several options). And of course, if you know what you want to install, you can just type the program name (or a partial name) in the Search box to filter the list.

To install any program, check its checkbox, and the program and all dependencies will be downloaded (or pulled off the CDs, which will be requested by Mandrake complete with ejection of your CD tray) and installed. Be warned that large programs with many dependencies will obviously take a long time for you to download if you're on dialup, so keep an eye on the details before clicking the "install" button.

You can also use urpmi <program_name> to install programs from the command line with full dependency resolution (RPMDrake is a GUI front-end for URPMI).

If you are using Mandrake 9.2 or lower, you may also get alarming-looking messages telling you that there was "no public GPG key found", and asking if you want to install anyway; if you are installing from Mandrake mirrors, you can safely install, and get the GPG keys later to stop this message even coming up.

GPG signatures are encryptions on the RPMs to ensure that the file has not been tampered with. The packager signs the final RPM with a private key and with a public key, then makes the public key available to the public (you and me). RPMDrake compares the key on the RPM with the key on your GPG keyring (the little keyring in your system tray when you run the Mandrake Control Center), and gives this error message if the two do not conform (in this case, because you don't have the key on your keyring at all, so RPMDrake has nothing to compare the RPM's key with).

Mandrake's public GPG keys can be found in the /base/ folder of the Mandrake mirror that EasyURPMI gave you as output for Step 3; if you put the url (without the "with synthesis.hdlist.cz" part) into a browser, and go up a level in the FTP site that will be displayed, you will see the /base/ folder. Go into that folder and you will see 3 "pubkey" files; select them and right-click to download them to a safe location. The public key for the PLF repository is right in the folder given in the Easy URPMI output, so you will see it if you type that address into a browser. Download that, too.

Once you have downloaded the keys, open a terminal, su to root (as above) and then use the cd command to browse to the folder that you saved the files to. Then do an ls to display the names of the files in that folder for easy reference for the next step.

Type gpg --import <keyfile_one_name> <keyfile_two_name> <keyfile_three_name> <keyfile_four_name> (that's why we displayed the file list; you should be able to type in the names correctly since you can just look on the terminal screen to see what they are), and hit Enter.

The keys should be added to your keyring, and you should get no more key-related errors when installing software (unless there's really something wrong with the key).

This should save you from "dependency hell", which is chasing individual RPMs over half the world to try to resolve dependencies in the program you're actually trying to install.

Hope this helps.

XavierP 07-12-2004 09:17 AM

Quote:

Originally posted by Motub
Could someone explain to me why everybody answers a Mandrake's user's questions about installing software without even mentioning urpmi or RPMDrake?
Because he asked abput rpms and tar.gzs. The question was about manually installing and we answered.

However, that said, good how to. :) Have you thought about submitting it, or something similar, to our Linux Tutorial section?

minrich 07-12-2004 09:45 AM

Nice work Motub.

How about adding to the LQwiki?

Hopefully, I can add to it, or preferably with your blessing copy parts of it, when I finally suceed in getting my KonicaMinolta 2300DL color laser internet printer working. I must admit that the foo2zjs driver requires (I believe) that Ghostscript be installed. I dutifully downloaded ghostscript-7.07.tar.gz, untarred into /usr/src and ran ./configure. However I got the following error:

Configure: error: I wasn't able to find a copy of the jpeg library. this is required for compiling ghostscript. Please download a copy of the scource, e.g. from http:/www/ijg.org/, unpack it at the top level of the gs source tree, and rename the directory to 'jpeg'.

Well, I downloaded as suggested but I have no clue where the 'top level of the gs source tree' is - Perhaps you can help?

I am using the 2.6.4 kernel on mandrake 10 bootable DVD from Linux Magazine running on VMware on my Tablet PC.

Thanks in advance for any pointers.

Richard

motub 07-12-2004 11:01 AM

Quote:

Originally posted by XavierP
Because he asked abput rpms and tar.gzs. The question was about manually installing and we answered.
But you see, that's just my point (and why this is a pet peeve of mine; nothing to do with you personally).

A new Linux user migrating from Windows is advised to download and install Mandrake as the easiest to use version for someone such as him/herself. Fine. Mandrake installs, and all these helpful hints and notes pop up, but none of them mention RPMDrake (or provide an intial setup of outside repositories), so unless the user has perhaps read a couple of reviews of Mandrake, or gone exploring in the MCC, the user does not know this tool (much less urpmi) exists.

This is already "not good" (the user should have some indication of what tools they have available, especially when they're as important as urpmi/RPMDrake). S/He reads some general Linux introductory material on his/her own, and s/he discovers that *.rpm exists, and that s/he is supposed to use those type of files to install software because s/he is using an RPM distro. The user still knows nothing about any of the rpm tools that resolve dependencies, but may have heard of dependency hell during the course of this reading.

So the user goes trawling the Internet for the homepages of various software s/he's heard about and wants to install (and which is not on the Mandrake CD's-- such as WINE, for example). Now, me, I'm already p.o.'d on behalf of this user, because s/he is already doing more work than is necessary (and this extra work is more likely to lead to failure than success). So the user finds on the homepage some RPMs and a source tarball. The RPMs are for SuSE, RedHat and "generic" and the source tarball is... a source tarball. None of these seem to be quite "right", but the user wants to install the program and at this moment does not know of any other way to acquire or install software.

So of course s/he asks here about "rpms and tar.gzs". S/he doesn't know what else to ask, and no one has told him/her that s/he's asking the wrong question!

Even on a dedicated Mandrake forum, where (presumably) everyone inclined to answer has some familiarity with URPMI/RPMDrake, no one says a word, and continues to provide the standard instructions of rpm -i and ./configure make makeinstall.

And two days later this user is going to be back complaining of dependency hell (because s/he was not told that if you intend to use rpm you have to find and install all the dependencies yourself beforehand, which is annoying enough in itself), or complaining that s/he can't compile the source (because Mandrake puts its libs or other dependent files in a custom location not referenced by the ./configure or Makefile of the developer of the program, so they are not found, and naturally this user does not have a clue how to fix such a problem. When was the last time you saw a README or INSTALL file in a source tarball that contained specific editing instructions for Mandrake, as opposed to, say Debian?). Assuming they haven't already decided that "Linux is s**t" and gone back to Windows, where "at least you can understand how to install a program".

The whole reason urpmi and RPMDrake exist is to avoid such problems. Mandrake didn't pre-compile thousands of binaries for their distribution and set up repositories all over the world just because they had time on their hands and needed something to do.

But these tools can't help us if we don't use them, and if Mandrake doesn't want to highlight them as they deserve, it seems to me that the job falls on the community. Which sucks, but if it didn't, it wouldn't be a "peeve" to me, would it?

minrich's problems are a perfect example of this; if minrich had installed ghostscript-blah.blah.mdk.rpm from a Mandrake repository (hint, hint, minrich), not only would the jpeg library needed be installed at the same time (if not included in the *.rpm itself), but one could also look in the RPM details in RPMDrake to see where all the files would be installed in the filetree (so if you still needed to know where the source of the g(host)s(cript) filetree was, you'd have a good idea).

I'll look into submitting this to the Tutes section and/or the Wiki (are they separate? I really haven't explored them much, though I did submit once to the HCL). Anything to help resolve this completely unnecessary issue (unneccessary because if Mandrake just put a blasted link to EasyURPMI in that First-Time Wizard or added a fairly small sub-wizard to include it, all users would know about RPMDrake from the git-go, and have external repositories set up already), especially when not using the included Mandrake tools and the available repositories so often gives such bad results.

XavierP 07-12-2004 01:04 PM

Actually, I agree with everything you said (especially the bit about the link to easyurpmi). I regularly use urpmi, I find it as easy, if not easier (less keypresses) to use than apt-get in whatever form. We simply answered the question that was asked - it may have been that the original threadstarter was tired of automatic installs/etc and wanted to dip into "doing it the hard way".

Anyway, the Tutorials are here and here is a how to on submitting one. The tutorials have a different function to the wiki, they are there to provide how tos on subjects which either come up regularly (like this thread) or on things which you have done and feel may be of use - like installing on an odd h/w setup. Have a read through the ones that are there to get a feel. The explanation behind the wiki is here and all contributions are welcome.

Phin666 07-21-2004 12:27 PM

lol, I love reading motub's replies. It's good to know she is also out here spreading the gospel. All hail the Diva of the litestep list and ls-stuff list. (oh yeah, and linux too.)

motub 07-21-2004 02:22 PM

Hi, there.... Paul? (Guessing from the "Ph", and the distro).

In any case, nice to see you here (even if you're somebody else I know)!

And I'm always the "diva"... there's usually no other contenders in the category :D . But it's always nice to have fans ;) .

Anyway, don't want to hijack the thread (even if it's dead, which it seems to be), but I can't PM, so... hello!

pongmaster 07-21-2004 06:29 PM

I'd just like to say thanks to motub for the really helpful info on RPMdrake.

I'm new to Mandrake, knew RPMdrake was there, but didn't know how to configure it to get software from anywhere else but the MDK CD's.

This 'tutorial' has been a real help to me.
Thanks again motub. :D :D :Pengy:

minrich 07-21-2004 07:56 PM

likewise, Dank u wel to Motub.

Your hint worked a dream and I am up and running, and I updated all my programs, after downloading a little script from my mirror of choice. Really cool. So now I am happily downloading sources of the latest and greatest Mysql, Php, and Apache and installing them as instructed in my copy of 'Beginning PHP, Apache, Mysql Web Development' - because unfortunately SUSe Pro 9.0 doesn't put the files in the same places as in the book. Otherwise the code that I can download from the publishers (wrox.com) won't work. I have learned more this week using Linux than I have using Windows in the last ten years - .conf files are so much more friendly than using regedit.

Phin666 07-21-2004 08:19 PM

Oh yeah...I forgot I have a different name on this forum Holly. It' s Paul. To everyone else, take everything she says to heart, I swear she should be teaching Mandrake usage. I never would have stuck with Linix if not for her advice.

OK, that was my last off topic post. I personally can uderstand the need to understand and everntually learn how to install the .rpm and .tar.gz and .tgz files. I would like to update my wine installation to the July build, but it is not in my repositories nor my disks. I have been patient, a few more months won't kill me. I hope.

motub 07-21-2004 10:09 PM

minrich... graag gedaan (especially if you don't actually speak Dutch, but looked up how to say "Thank you" very politely), and I'm glad you're getting on well with getting your system set up.

That's the thing about binary distros, though-- they are tweaked away from "standard" for whatever reason (UNIX-standard, or RedHat standard, take your pick), and that makes it difficult for new users (who are learning the"standard" from books or how-to's that can't know what SuSE or Mandrake or Fedora Core have changed) to find out what's what. Even Debian isn't "standard", exactly, but it changes so glacially slowly, and there are so many very experienced people using it, that there are plenty of resources to tell you how Debian deviates from whatever "standard" we might be talking about.

But if you really want the most bog-standard distro possible, where you will find things exactly where any general Linux book will tell you that they ought to be... you'd want Slackware. People may say it's "too hard for newbies" (which of course depends on the newbie in question), but after a while trying to figure out where your config files and libraries actually are under a binary distro (as opposed to where the newbie-level books will tell you they are supposed to be), Slack can be such a breath of fresh air that sheer relief will carry you through any rough waters.

:D

--------------------------------------------------------------------------------------------------

Paul, you can do one of 3 things to get the current version of Wine:

1) hop over to EasyURPMI and add the Coooker repositories to your SMM. You probably only need Cooker's "contrib", but get main as well. There's a good chance that Wine for July will be in there... just don't forget to uncheck those repositories in the SMM when you've got Wine. It's one of the relatively few programs in Cooker that is self-contained, so getting it from there won't install/upgrade any dependent libraries that might break your system, but you definitely wouldn't want to risk pulling anything big from Cooker, or using those repositories on a regular basis.

2) Go to the Wine homepage download page (or to the Wine project page on Sourceforge.net) and download and install the Mandrake RPM. Again, it's self-contained, so there should be no problem.

3) If you want to give WineX (now known as Cedega) a try, but don't want to a) buy a subscription, or b) learn to deal with downloading the CVS source and trying to compile it, Mandrake, RedHat and Fedora Core users have a friend at http://www003.portalis.it/115/winexx.html. The current "new" version of Cedega is 4.0-- that's the first release with the new name, the new website, and who knows whatever else is new about it; but a lot of games that were working under WineX 3.3.2 (the last with the WineX name, afaik) are no longer working under Cedega, if the Transgaming forums are to be believed. So there's a good reason to stick with WineX 3.3.1, which is the version offered on this site.

And no, it's not illegal... WineX, like Wine offer a free CVS source download that you have to compile... the site owner has just compiled it for you already, so it can be installed as a binary. You even have to agree to the same licenses Transgaming makes you accept before you can get to the download pages there. And he's legit, too-- you can say hi to him (Ivan) on either the Wine-users or Wine-devel mailing lists, as he's a Wine developer, listed as working on one of the projects on Wine's "To-Do" page.

And in fact, I must say, his RPMs were generally the best working version of Wine I used under Mandrake-- and I've used the Wine binaries, the daily builds formerly offered at http://wine.dataparty.no/ (which is now down, but perhaps will come back at some point), compiled WineX from scripts offered at http://ting.homeunix.org/cvs_wine/GetWineX.html (which are also pretty good), and compiled it myself from CVS, so I have a fair range of Wine installs to compare with. Ivan's CVS WineX RPMs are one of the things I actually miss about not being a Mandrake user, so definitely check them out.

You might also want to check out Frank's Corner for tips on installing Wine (as well as his configuration tool), as well as invaluable HOW-TOs for many popular programs. Also, both Ravage's installer site and Loki installers for linux gamers have a lot of Loki installers (Loki was a company that specialized in porting Windows games to Linux; we still mourn the day they went belly-up, but their installer survives to help us even now) for many popular games, some native and some which must be run under Wine(X), but for whatever reason don't install well via whatever means.

Good luck.

gp42 08-11-2004 12:20 PM

repositories for Mandrake 7.0?
 
Thanks to motub for explaining RPMDrake and repositories. I'm once again tinkering with Mandrake 7.0 which I installed and abandoned about 4 years ago after interminable problems. Are there any repositories for version 7.0? The listing generated at Easy URPMI doesn't work (and the header there warns that the listings for earlier versions are not valid). Is there anyplace I can point RPMDrake toward for version 7.0 and see some software repositories?

Version 7.0 only has RPMDrake, not Mandrake Control Center with the software management GUI and so one. Any general help in working with this version to download & install software would be appreciated, too. My ultimate goal is upgrading KDE.

motub 08-11-2004 04:46 PM

The best I see is for 7.2:

ftp://mirror.fis.unb.br/pub/linux/Mandrake-old/

ftp://mandrake.redbox.cz/Mandrake-old/

If you want to upgrade (somewhat, but not all the way to 10.0), these sites also have ISOs for 8.2-9.2 (but not 7.2, sadly, though there are some floppy images in the 7.2 folder. Don't know what you do with them, though. You might be able to do an "effective upgrade" to 7.2 by the simple expedient of upgrading the entire installed system from the repository, though).

Hope that helps somewhat.

keflavich 08-13-2004 02:24 PM

I don't mean to belabor a point, but that little tutorial was amazing. I knew RPMDrake existed, but I had no idea how to get it to find anything but the files that came on the Mandrake install CDs, which was particularly annoying since I didn't have the 4th.

My troubles installing various programs that I found searching around the internet were immense and I certainly would have given up on Linux entirely if I wasn't dedicated to wasting my time this summer. Knowing about RPMDrake's capabilities and how to use them would have saved me a lot of effort and grief... too bad I didn't find this post earlier.

But I actually do have a question to post. Since there's an easy way to acquire and install programs, is there a similar system for hardware drivers? Or hardware recognition? I have some USB external hard drives and an iPod plugged into a PCI firewire card in my computer. The iPod doesn't appear at all in HardDrake (I think that's what it's called), and the external HDs claim to be read only file systems when I mount them. I'm just assuming they have problems because I don't have the drivers, but I guess it could be something else.

I'm sure this was the wrong place to post, so sorry about that. But thanks for the info again.

gp42 08-15-2004 05:07 AM

upgrading an early urpmi
 
Well, I think I know why there aren't any repositories for 7.0 : urpmi wasn't
finished yet and didn't have commands like urpmi.addmedia or the search
commands that you use from the commandline. I tried getting the urpmi rpms from
version 7.2 and installing them with package manager, and after installing a lot
of libraries, rpm, and rpm-tools packages, it looked like everything was
upgraded without dependency-problem error messages. But urpmi won't run at
all now, and I get this error message:

Can't locate rpmtools.pm in @INC (@INC contains:
/usr/lib/perl5/5.00503/i386-linux /usr/lib/perl5/5.00503
/usr/lib/perl5/site_perl/5.005/i386-linux /usr/lib/perl5/site_perl/5.005) at
/usr/bin/urpmi line 20. BEGIN failed--compilation aborted at /usr/bin/urpmi
line 20.

There is no longer a man page for urpmi.

Thanks to anyone who can help me fix this.

motub 08-15-2004 12:55 PM

Well, you could try reinstalling Perl and all Perl modules (you'd probably have to do some research to find out what Perl modules you have or need), but what I would do is get one of those 8.2 or 9.2 ISOs and do an upgrade install.

Unless you have some deep need to run Mandrake 7.2, moving to a somewhat better-supported version would seem to be the thing to do.

Just my 0.02, fwiw.

gp42 08-15-2004 02:23 PM

Yes, that's what I'll do. I wanted to tinker around and learn how to do some things on this old install in the meantime. I'll try the perl suggestion and see what happens. Thanks again.

smiler 08-19-2004 06:08 AM

Quote:

Originally posted by motub


But OK. I will explain this again, because I'm on a (minor) mission to save Mandrake from itself . Other than this really unnecessary problem for new migrators, it's a fab distro.

...........

Hope this helps.

Agree - it does help a lot!

the urpm part should really be on the front page of the first startupscreen or at least on the front of the documentation page that appears when you start Mandrake the first time - it just saves so much time and annoyances.

And the part about the gpg keys was info that I didn't find before - and I have spent quite some time wondering and searching - Thanks

Then if you could add something more to this tutorial - I think it would be fab too:

I find some info about how to uprade mandrake via urpmi, but I find that it may not be so easy as it just appears at first sight.

Specifically there may be some issues when upgrading the kernel - there may be potential error in configuring lilo or other things that could make your box unbootable - or what?

motub 08-19-2004 08:03 AM

There should not be many, if any, issues when upgrading a same-series kernel to a higher revision of its own type-- meaning, upgrading 2.4-22 to 2.4-31 or 2.6.7-13 to 2.6.7-15, or even 2.6.7 to 2.6.8 (I just made those revisions up; so don't go looking for them ;) ). At least, as far as I know-- I don't remember having any problems with that, but the last version of Mandrake I used was 9.2, which only had 2.4 series kernels available.

You definitely have the potential for problems if attempting to upgrade a 2.4-series kernel directly to a 2.6-series kernel automatically (or even manually, at times).

The 2.6-series kernel has some radical differences from the 2.4-series, needs new tools to be built, and is in fact built with different commands than the 2.4 series (several of the kernel compilation commands used by the 2.4-series have been merged into one, so compiling a 2.6-series kernel only takes 3 commands, rather than the 6 or 7 required by the 2.4-series). While the 2.6 series is stable and works well, the initial transition from the 2.4-series can be (quite) bumpy.

A big clue is that all the major distributions (SuSE, Mandrake, Fedora) all released new versions to accommodate the 2.6-series kernels, and if you look in their repositories, you generally won't find a 2.6-series kernel for the previous release. The exception is Slackware, whose 9.1 version did accommodate the 2.6-series without upgrading (10.0 wasn't even available at the time, actually). One could obviously compile a 'vanilla' kernel from www.kernel.org, but given that distribution kernels are heavily patched and tweaked, I myself would not try this-- if the distribution can't successfully backport a newer kernel to an older release (which they clearly can't, or there would be such a precompiled kernel in the repositories of their old release), I certainly don't think I can. This is a point in the favor of just doing a clean install of the upgraded version (Mandrake 10.0, in this case). Just install the 2.6 kernel from the start rather than trying to migrate.

As for LiLO-- I admit I don't remember enough about how Mandrake upgrades their kernels to remember how they did lilo.conf-- it depends somewhat on whether they automatically replace the old kernel, or place it side-by-side with the previous kernel. And of course, one might be using GRUB, anyway, in which case all bets are off.

Naturally, if they replace the old kernel, and the new kernel is not bootable for whatever reason, you won't be able to boot, but that's not actually a LiLO problem.

I would assume-- in the absence of specific memory-- that Mandrake runs the "make install" command at the end of the kernel extraction, which "moves" the target of the /boot/vmlinuz symlink to point to the new kernel, and creates a new symlink (vmlinuz.old) which points to the previous kernel. Perhaps it additionally edits lilo.conf as well (or instructs you to do so), to add the new entry; whether it does or not, Mandrake surely runs /sbin/lilo (or instructs you to do so) at the end of the install. That's only basic common sense.

On the whole, it seems to me that LiLO is the most unlikely element to be an obstacle when upgrading a kernel automatically. There are so many more important obstacles before LiLO even becomes a factor.

As for upgrading the distribution as a whole using urpmi, well, it can be done, but as you say, it's often not as easy as it looks.Now that there is a stable upgrade release, it is certainly possible to point your SSM to the 10.0 repositories and then do an system-wide upgrade.

But there are two problems with this (leaving aside the kernel factor):

1) the programs in the new repository were compiled with different compilers and libraries than the ones currently resident in memory on your running system, so the new programs may not install properly (because they can't find the libraries they expect or need). Worse yet, many of the upgraded programs may appear to install correctly, while not actually doing so, and trust me, if you upgrade the whole system this way, when it's all over you will not be able to find the ultimate source of the brokenness, and will probably wind up having to reformat and reinstall;

2) you'd be in the position of trying to replace programs that are currently running, which many programs do not like. Upgrading RPMDrake while you're actually using RPMDrake to upgrade RPMDrake is a recipe for disaster. This is why it's better to just download the next release and do an upgrade install (if upgrading the kernel is not a factor) because then, you're running from the CD, not from your HDD, so the base functions can be replaced without damage. Plus, if you ever have to reformat and reinstall, you can just reinstall the current version, instead of having to upgrade the old version all over again.

Hope this helps answer your questions-- some of them, at least.

jterr02 09-14-2004 10:23 AM

Various replies.
As a relative Mandrake noob, I am easily annoyed by urpmi.
Its great when the friggin mirrors stay up but they often get bogged down or deny access for whatever reasons.

I'd rather use easy urpmi for only larger updates not individual files. If you are checking kde-look or other sites with user created relatively new files they won't be on rpm yet anyway. I use the tar commands because its also a little more useful tool across various platforms. I dont want to trap myself in just linux, much less only mandrake linux.

For the other stuff: Use man tar and you will get the options. The most common uses are detailed above anyway. Use the v for verbose so you see what the heck is going on. Use j for the bunzip files (bz)instead of the z for gunzipped ones(gz).

Make sure you su to root before running this stuff or you will have errors.

jterr02 09-14-2004 10:28 AM

Quote:

Originally posted by smiler
Agree - it does help a lot!

the urpm part should really be on the front page of the first startupscreen or at least on the front of the documentation page that appears when you start Mandrake the first time - it just saves so much time and annoyances.

And the part about the gpg keys was info that I didn't find before - and I have spent quite some time wondering and searching - Thanks

Then if you could add something more to this tutorial - I think it would be fab too:

I find some info about how to uprade mandrake via urpmi, but I find that it may not be so easy as it just appears at first sight.

Specifically there may be some issues when upgrading the kernel - there may be potential error in configuring lilo or other things that could make your box unbootable - or what?

Lilo will keep a failsafe mandrake boot of the older kernel.
My current Lilo shows 6 options including the dos/windows selection and 5 versions of mandrake including kernels 2.4 and 2.6.

Again my only complaint with urpmi is that the mirrors at times crap out. The one in my state was actually taken off the list it became so unreliable. FWIW the French mirrors are extremely reliable. Then again with an 8 hour TZ difference guess no competition for connections. lol.

KWTm 09-24-2004 09:53 PM

Quote:

As a relative Mandrake noob, I am easily annoyed by urpmi.
Its great when the friggin mirrors stay up but they often get bogged down or deny access for whatever reasons.
What I often do is get the RPM, usually a Mandrake specific RPM, and download it. (I find it with RPMseek, RPMfind, or RPMpbone.) Once it's on my hard drive, I can use

urpmi ~/downloaded_rpms/MyDownloadedRPM-3.4.7.2543.2-mdk325.rpm

or something like that, and urpmi will still automatically resolve dependencies.

Also, if you keep encountering a mirror not staying up, you are free to add more sites (see the EasyURPMI site for how to add sites, but since you already set up mirrors, you should already know how to do this) and if one mirror is down, urpmi will go to another mirror.

Incidentally --motub is female? I thought we scared all of those away! And a guru, too... we are not worthy ...

imagineaxion 10-15-2004 06:51 AM

First and foremost here is another thanks to motub
i had been using mandrake for a good few months before i stumbled across this thread. Makes me think how long it would have taken for me to find out otherwise.

ok anyway i have installed the mandrake 10 official cd 1-3 and do not have the 4th
when i used easy urpmi and added those links did it not add the rpms from the 4th cd?
if it did how do i get my machine to use the online rpms instead of asking me for the fourth cd the whole time?

do i need to remove one of the .cs files in /var/lib/urpmi
eg. the hdlist.Installation CD 4 (x86) (cdrom4).cz or
names.Installation CD 4 (x86) (cdrom4) or
synthesis.hdlist.Installation CD 4 (x86) (cdrom4).cz

or what must i do?

thanks
graham

motub 10-15-2004 07:34 AM

You should be able to edit the sources used via the Software Media Manager; just check and uncheck the sources you want to use.

Now, if some programs installed from external sources have dependencies which would be called from CD4, and those rpms are not on the mirrors (but only on CD4), then you would have a problem until you got CD4.

But since, iirc, CD 4 was the 'contrib' mirror, as long as you set up an external 'contrib' repository source, you should be able to get the packages needed without trouble. When you set up repositories via EasyURPMI, did you check the 'contrib' box to get a contrib mirror, or just 'main'? You really need both, especially if you have any PLF sources.

I'm not sure that I would go messing with /var/libs/urpmi, since urpmi is an automated process, and it is unknown whether changes to it directly will revert on reboot due to the SMM resetting them, or some other boot process resetting them (this happens a lot on SuSE, and Mandrake may be no different in that respect, given that both distributions are targeted for users who would not even know where to find internal configuration files such as urpmi's *.cs files, much less know how to edit them, and manual editing of most config files is discouraged anyway).

Hope this answers your question.

Oh, and you're welcome-- glad the other post helped. :)

imagineaxion 10-15-2004 10:00 AM

hi thanks for the prompt replay :)

i have added the contrib mirror i actually added all of them

it infact asked me for whichever cd it needed not just cd4.

i am trying this on my laptop at the mo and also have another machine i am using as a server. it worked perfict on the server

maybe i should dl the cd4 anyway cos i'm not always connected to the net

does mandrake ask for the cd if it cannot connect to the net?

motub 10-15-2004 12:13 PM

The reason it asks for the CDs is because it needs base libraries that are on the CDs, not necessarily because you are or are not connected to the 'Net. Generally, it probably asks for the closest source of the package it needs; if there is more than one source, and one of those sources is local (the CDs) it would ask for those first, and only move to external sources if no local sources were available.

If you really want to use no local sources whatsoever, you can uncheck all the CDs in the SMM. But if you're not always connected to the 'Net, this will mean that you won't be able to install anything at all when you are not... and even with the local sources enabled, you won't be able to install much other than what is on the CDs (because you aren't connected to the 'Net to retrieve external files).

I_wish 11-03-2004 04:39 AM

I have a problem and is kind of urgent, so i beg someone to answer. I've just installed Linux (today) and i need to install yahoo messenger. BUT, i don't know how. I loged in as root and i wrote the path (for example: rpm -i /home/alexe/desktop/rh9.ymessenger-1.0.4-1.i386.rpm >the file is placed on desktop<) but the message is: "no such file or directory". What should i do? [alexe@localhost alexe]$ someone told me that it should be there # not $. It's true? or it affects me in some way?

motub 11-03-2004 04:50 AM

If you are logged in as root, and you have put the file on the desktop (meaning root's desktop), then the path you are using is wrong (should be /root/desktop/rh9.messenger-1.0.4-1i386.rpm). What your advisor told you is true only if you are logged in as a user (because programs can only be installed by root-- a "$" prompt indicates a user-access terminal, and a "#" prompt indicates a root-access terminal).

Alternatively, you could actually look in your file manager, and find out just where the file is and use the correct path.

As another alternative, you could just install GAIM (if it is not installed), since that also connects to the Yahoo network (as well as ICQ, MSN, and others).

In future, please start a new thread, or search the forums for similar problems; I'm sure this is not the first time this has been asked, and hijacking threads is not good forum etiquette.

I've only answered this because of the 'urgency' of your problem and the fact that it is related in some degree to the title of this thread.

I_wish 11-03-2004 05:10 AM

I want to thank you so much!!! and i'm sorry for the inconvenience, but it's the first time when i post something on this forum, but i promise it will never happen again!! Thank you!!

xbaez 11-05-2004 12:57 PM

Hello

I am trying to install kdemultimedia3.2.3-14mdk package.

However it sais that I need other package in order to install that one

Therefore, I try to install the:
kdemultimedia-kaboodle-3.2.3-14mdk package, and then I see the following error:

"Sorry, the following package can't be selected.................... due to unsatisfied libkdemultimedia1-kaboodle[==1:3.2.3-14mdk]

However, when I try to install the libkdemultimedia1-kaboodle package, the only version that I have is the following:

Name: libkdemultimedia1-kaboodle-3.2.3-13mdk
Size: 0 kb


Did I downloaded the libkdemultimedia1-kaboodle-3.2.3-13mdk wrong?

or is there any other problem?
Regards

motub 11-05-2004 01:19 PM

Would you please go back to the first page of this thread, and read the instructions in the third post for how to set up URPMI on your system. A Mandrake user should never have to manually seek and download any Mandrake packages-- urpmi downloads and installs all packages with their dependencies automatically.

allforcarrie 11-08-2004 02:01 PM

I am in way over my head. I am reading this an it just doesnt click. I tryed to type these commands as root but nothing happens. I am trying to install "alsa-driver-1.0.6a.tar.bz2" to hopefully get my sound going.

thug_poet22 11-19-2004 01:15 AM

Hey, i tried installing gaim, and this is what i got



[thugpoet@ool-18b859d0 thugpoet]$ su
Password:
[root@ool-18b859d0 thugpoet]# rpm -ivh gaim-1.0.3-0mdk10.0.i586.rpm
error: open of gaim-1.0.3-0mdk10.0.i586.rpm failed: No such file or directory


If im not mistaken, you can change directory with cd, but i was unsure how to make it the directory that my current file is in. My file is located at

file:/home/thugpoet/Documents


I know this is such a newbie questions but i just need a little assitance. Thanks in advance.

imagineaxion 11-19-2004 03:59 AM

Quote:

If I'm not mistaken, you can change directory with cd, but i was unsure how to make it the directory that my current file is in.
you need to type:
Code:

[root@ool-18b859d0 thugpoet]#cd Documents
and then the command to install

or you can just use:
Code:

[root@ool-18b859d0 thugpoet]# rpm -ivh /Documents/gaim-1.0.3-0mdk10.0.i586.rpm

thug_poet22 11-19-2004 04:32 AM

Thanks a lot for you help, it really got me over that lil hump, but i've seemed to have run into another bump in the road. And i dont want to always be fed answers, so if u find threads on LQ that can help me... please direct me there. But im still trying to install Gaim and this is how far i've gotten.


[thugpoet@ool-18b859d0 thugpoet]$ su
Password:
[root@ool-18b859d0 thugpoet]# cd Documents
[root@ool-18b859d0 Documents]# rpm -ivh gaim-1.0.3-0mdk10.0.i586.rpm
warning: gaim-1.0.3-0mdk10.0.i586.rpm: V3 DSA signature: NOKEY, key ID 4c292fcc
error: Failed dependencies:
libgtkspell.so.0 is needed by gaim-1.0.3-0mdk10.0
[root@ool-18b859d0 Documents]#

How do i get past these dependencies? Thanks a lot.

imagineaxion 11-19-2004 05:43 AM

try using URPMI
there are instruction on how to do these further back in this thread.

but just to recap...

go to
http://easyurpmi.zarb.org/

follow the instruction and then copy and past the results in the terminal one at a time as root user (su)

then go to the MCC (mandrake control centre) -> software management or something and then install software.
you can do a search to find it in there.

this is the best way and using this method will solve the dependencies and install them for you.

if you go to the MCC there is a version in there already without having to add the urpmi lists. again this is mdk 10.1 and i'm not too sure about the previous versions.

also please specify which distro version etc you are using, this will help us help you :)

mostwanted 11-20-2004 12:06 AM

Quote:

Originally posted by imagineaxion
try using URPMI


go to
http://easyurpmi.zarb.org/

This site is not working for me

thug_poet22 11-20-2004 01:33 AM

nope that site does not work, but im gonna do more research and figure it out. Hey i installed Firefox (im sooooo happy, my first install, by myself, with the help of the board of course) But now im trying to figure out how to run it. Its not in the start menu where the other apps are. If anybody can help, it would be a pleasure.

I think i might have messed up one of my programs, installed Firefox, but i cant figure out how to run it.

fsman 11-20-2004 08:16 AM

easyurpmi.zarb.org
 
is there an alternative site/mirror to easyurpmi.zarb.org.
Looks like its out of actionhttp://images.linuxquestions.org/questions/images/icons/icon9.gif
Unhappy

imagineaxion 11-20-2004 10:48 AM

OK...

this is very strange (easyurpmi) i checked the url before i posted it - i have seen this before though. give it another try tomorrow or Monday


thug_poet22
i had this too when i installed it. you need to cd to the directory that firefox is in and then type ./firefox or you can browse to it in konqurer and click on the firefox icon to run it (but this is a pain in the a$$ to do everytime.

So to solve this i just made a copy of the mozilla icon in the quick launch part of the start panel (i remove some open office thing i think to make space) then i right clicked on it, selected properties and changed the path etc in there.
you can also change the icon by clicking on the icon in the properties window and browsing to the place where you installed firefox and there is an icons folder there :)

xbaez 11-21-2004 08:50 PM

which is a good ftp repository for downloading updated software for Mandrake, such as Gaim?

I want to use Yum in order to have my Mandrake system up2date :)

mostwanted 11-22-2004 10:38 PM

ok, I got the easy urpmi to download, but I have another problem.

I read the instructions for opening a tar file but I keep getting an error for a tar I am trying to uncompress. I havn't tried to untar anythig else yet tho. I have been trying to get macromedia flash player installed first so I can use more of the net first. Anyone have a problem with this? Should I start another thread for better visibility?

motub 11-23-2004 06:10 AM

Well, you are still ontopic, so you don't so much need to start another thread.

What would actually be useful in answering this question is to tell us:

1) What is the complete filename of the file you are trying to open (is it a tar, tar.gz or tar.bz2)

2) What is the exact command you used?

3) What is the text of the error you receive when running this command?

4) Also, what browser are you using... I was under the impression that current versions of many browsers install the Flash Plugin automatically under Mandrake to avoid this very problem, but I could be wrong about that.

mostwanted 11-23-2004 09:53 AM

1). install_flash_player_7_linux.tar.gz

2). tar -zxvf install_flash_player_7_linux.tar.gz

3). [cannot remember at this point, away from MDK machine. I post later]

4). mozzila

do you think that a newer version of mozzila (firefox) would have this program? I am using MDK 10.0

motub 11-23-2004 10:41 AM

Well, of course, we still don't know what the problem actually is ;) , but no, you probably don't need to install another version of mozilla (although you could type about:plugins in the address bar and see if the Flash plugin actually got installed).

But I can probably figure out what's going on here, having installed the Flash plugin often enough.

OK, starting from the beginning:

tar -zxvf install_flash_player_7_linux.tar.gz would be the correct command to unpack the tarball. If this fails, it's because you either do not have write permission to the directory where you are unpacking (which is unlikely if you are the same user who downloaded the file), or you are trying to unpack the file while in a different directory than the tarball (in which case you would need to do tar -zxvf /full/path/to/install_flash_player_7_linux.tar.gz to unpack it).

So we will assume that the unpacking went OK. This should result in a script being unpacked (plus possibly some other files, but I don't have time atm to actually download this tarball again and look at it). The first thing you would have to do is chmod +x the script file (whatever_it_is.sh), as scripts packed in tarballs are traditionally not set executable, so you won't be able to run it as-is.

Once you have the script set as executable, you most likely want to open a terminal (the Flash plugin install script must be run from a terminal, because you must accept the licence before it will install, and the licence is displayed in standard terminal output, not a cute popup GUI dialog), then su to root, cd to the directory containing the script, and run the script (./script_name.sh).

IIrc, I also had to create a directory-- /usr/lib/nsbrowser/plugins -- for the plugin to install. It's a bit behind the times, apparently; it seems that older versions of Mozilla/Firefox did create some shell Netscape directories, whether or not you had the Netscape browser installed, but current versions do not. However, the stupid Flash plugin is living in some past paradise where the standalone Netscape browser still is relevant. Don't ask me. In any case, this old version didn't seem to recognize /usr/lib/mozilla/plugins as a valid directory (much less /usr/lib/MozillaFirefox/plugins), so I gave it what it wanted. However, both Mozilla and Firefox have this folder set as a default plugin search path, so the plugin should be properly found once installed.

Hope this helps, despite not having the actual error output (though of course you are certainly welcome to provide it, if I've guessed wrong).

faada 12-01-2004 02:59 PM

motub, i read your second post on this thread and almost stood up and clapped :) I was completely frustrated after being told not to d/l and install tar.gz files, and to use the software manager instead.

I googled for software repositories forever and was about to give up when I had to ask a buddy of mine who knows linux.

I was shocked at the lack of info in these repositories on mandrake's sites.

What you said captured my frustrations so precisely.

Oh, and thank for hte how-to post as well :D :D

motub 12-01-2004 03:16 PM

:D

(You're welcome, glad to help.)


All times are GMT -5. The time now is 11:30 AM.