LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Installing .rpm and .tar.gz (https://www.linuxquestions.org/questions/mandriva-30/installing-rpm-and-tar-gz-203939/)

faada 12-01-2004 03:16 PM

I have a related question, I originally had 2 CD drives in my pc on the second controller, I removed the primary drive (hdc) and upon trying to install a piece of software I was prompted to insert mandrake cd2 into hdd, I did so but somehow the installation would not accept it.

I then shut down and switched the jumper to make the remaining cd drive primary, tried some stuff, including editing the installation CD2 URL in the software manager but had problems when I saved the changes.

I eventually set the jumper back to slave and used the drive as HDD tried to set the url for cd2 in software manager back to what it was before but i'm having no luck.

Currently the entries for cd2 (which is not working) are

URL: removable://mnt/cdrom/media/main2
Relative path...: ../../media/media_info/hdlist2.cz

for cd3, (which seems to be ok, i haven't touched this one)

URL: removable://mnt/cdrom/media/main3
Relative path...: ../../media/media_info/hdlist3.cz

Can anyone help here?

thanks much

motub 12-01-2004 03:22 PM

OK, as stupid as this sounds, have you checked the CD itself (i.e., is it perfectly clean)? If CD3 is OK when it uses exactly the same entry as CD2, that suggests that the CD itself is not readable, which suggests that it is physically dirty.

You'd be surprised how many such errors can be solved with a little warm water/dishwashing liquid+warm water/glass cleaner (just make sure you dry the CD completely before use).

faada 12-01-2004 09:01 PM

yep, checked it and it seems to be fine.

ben_build#2.1.0 12-02-2004 12:22 PM

time for me to jump in here. thank you for giving this tutorial, and I tried adding one server to my urpmi list. This went fine. I tried adding the /devel/10.1/ server, but the list file it downloads is 25 MB large. As some of you know, I am on dialup and it would take me 3.5 hours to download that list. Can anybody point me to a website where I can download the list on?

Also, can anybody tell me how I could transfer the list (from a USB flash drive to the Linux box)?

motub 12-02-2004 12:34 PM

Does the server you are trying to add not have a synthesis.hdlist.cz (in addition to the hdlist.cz)? The synthesis.hdlist.cz is the same info but a smaller file, suitable for dial-up users. If you're using Easy URPMI (which website can now be found at http://easyurpmi.zarb.org/ ), there is a checkbox to output the server commands using the synthesis list rather than the "full service" list.

Sorry, no USB drives, so I couldn't reliably help you with that.

I'll change the Easy URPMI link in the original post to avoid confusion.

Hope this helps.

ben_build#2.1.0 12-02-2004 12:43 PM

sweetness. Thanks. I will try using that option tonight.

(now we don't have to worry about transferring files to and from my USB flash drive


**update: thank you again. I'm currently installing gcc-c++ (which was missing in my devel isos. :) :) :) )


bmagnois 12-15-2004 12:16 AM

Need Help Mandrake 10.1 RPM install bind-9.3.0
 
Hi there,

Can you please help me why I am getting this error message on an RPM install? I have Linux Mandrake 10.1 running under VMWare version 4.5.2 and SSH Secure Shell version 3.2.9. My PC is running Windows XP/SP2 as main OS (virtual machine). Trying to install bind-9.3.0 via rpm or urpmi. Appreciate your help...

BobM
Here are details of my problem:

[root@localhost downloads]#
[root@localhost downloads]# ls -l
total 16812
-rw-r--r-- 1 bmagnois bmagnois 4341525 Dec 14 2004 bind-9.2.3-6mdk.i586.rpm
-rw-r--r-- 1 bmagnois bmagnois 3982775 Dec 14 2004 bind-9.3.0-3mdk.i586.rpm
-rw-r--r-- 1 root root 8854208 Dec 13 22:42 webmin-1.170-1.noarch.rpm
[root@localhost downloads]#
[root@localhost downloads]# urpmi bind-9.3.0-3mdk.i586.rpm
error: bind-9.3.0-3mdk.i586.rpm: MD5 digest: BAD Expected(4ebd7624d4cde29de38f8ed54bca1a3c) !=

(47d709684fd6ca4cec4cde254cb132a0)
unable to register rpm file
Everything already installed
[root@localhost downloads]#

reddazz 12-15-2004 12:21 AM

It means there is a bad checksum on your rpm. Try downloading it again or using an official Mandrake repository via urpmi. The instruction are available at the easyurpmi website.

bmagnois 12-15-2004 12:23 AM

Problem with RPM install in Mandrake 10.1
 
Please provide help if anyone has a solution to this error/problem (bind-9.3.0 rpm install under Mandrake 10.1):

[root@localhost downloads]#
[root@localhost downloads]# ls -l
total 16812
-rw-r--r-- 1 bmagnois bmagnois 4341525 Dec 14 2004 bind-9.2.3-6mdk.i586.rpm
-rw-r--r-- 1 bmagnois bmagnois 3982775 Dec 14 2004 bind-9.3.0-3mdk.i586.rpm
-rw-r--r-- 1 root root 8854208 Dec 13 22:42 webmin-1.170-1.noarch.rpm
[root@localhost downloads]#
[root@localhost downloads]# urpmi bind-9.3.0-3mdk.i586.rpm
error: bind-9.3.0-3mdk.i586.rpm: MD5 digest: BAD Expected(4ebd7624d4cde29de38f8ed54bca1a3c) !=

(47d709684fd6ca4cec4cde254cb132a0)
unable to register rpm file
Everything already installed
[root@localhost downloads]#

reddazz 12-15-2004 03:52 AM

Did you understand my post? Your rpm is somehow corrupt, hence the bad (checksum) so you need to download it again or try and install it using urpmi. Also to make sure that it's not already installed as your error report is implying, do

$rpm -qa | grep -i bind

This will print the version of bind thats currently installed on your system.

To forcefully install it (which I wouldn't recommend since it seems corrupt) you can do

$rpm -Uvh --force packagname.rpm

zulfilee 12-15-2004 04:27 AM

I remember posting at this thread when I was three posts old.
And its still going on.

But the thread had a lot of information to give.

One question though

Can I build packages in RPM for packages which need files to be preserved in the next upgrade/uninstall.

Ex : Using RPM I build Version 1 , Then I go to version 2 [upgrade].
When I uninstall Version 2 my Version 1 also gets uninstalled with it.

What can I do for this ?

Cheers
Z

Asificare 12-29-2004 06:25 PM

Update page
 
Hi, I cannot seem toget anywhere with this address, is it still available?

http://easyurpmi.zarb.org/

Cheers
Asif

Asificare 12-30-2004 02:21 PM

It doesn't matter, it seems to be offline,but Ihave found a mirror which may help others.

http://www.linuxfordummies.org/addmedia/

Cheers
Asif

kipper2258 01-09-2005 09:20 AM

:P

tomfrh 01-16-2005 01:07 AM

Thanks Motub
 
Your first few posts really saved me. I would have erased Mandrake, and any further inclination towards Linux, were it not for those posts.

Tom

LiberteToujours 01-17-2005 06:03 PM

motub, thanks a lot for the information you provided. I am one of those Windows to Mandrake to converts you talked about, and I too discovered "dependency hell" yesterday when I tried to install SuperKaramba by downloading the RPMs manually (I didn't have any of the X development packages installed). And yes, it was hell! Until someone on another forum (mandrakeusers.org) pointed out urpmi and how to get it configured using EasyUrpmi, and it's been smooth sailing since. I was getting very fed up until I discovered this tool! So I just wanted to say, continue to spread the word, because I agree with you that it's very important that people know about this feature if we want to keep any Windows converts.

rksprst 01-29-2005 11:27 PM

there is a sticky thread (just above this one ;) ) that has mirrors of urpmi setups, so for u guys who r having trouble finding a site that works check it out

http://www.linuxquestions.org/questi...22#post1435522

RobNyc 02-11-2005 09:40 AM

Nice

DMZeplin 02-17-2005 07:41 AM

Nice motub's for clarify with RPMDrake
 
I read the direct you gave us. It was very nice, and fianlly I can find easier install ways.... Also, I want ask a question, After I installed mozilla-firefox, I don't know where the software have been installed in folder since one website asked for need a flashplayer (macromedia). So, I clicked to download, but they unable to find /usr/lib/mozilla.

I tried to use "Find Files" but can't find it... Even though my mozilla-firefox is working... :study:

Thanks again!
:newbie:

DMZeplin 02-17-2005 07:54 AM

Problem with install Mplayer via RPMDrake...
 
When I tried to install MPlayer from RPMDrake, but the message appeared:

The following packages have bad signatures:
fribidi-0.10.4-4mdk.i586.rpm: invalide Key ID ((sha1)dsa shal
md5 gpg GPG#26752624 OK) libenca0-1.5.2mdk.i586.rpm:
Invalid Key ID ((sha1) dsa sha1 md5 gpg GPG#26752624 OK)
liblirc0-0.6.6-7mdk.i586.rpm:invalid Key ID ((sha1 dsa sha1
md5.gpg GPG#26752624 OK) liblzo1-1.08-4mdk.i586.rpm:
Invalid Key ID ((sha1 dsa sha1 md5 gpg GPG#26752624 OK)
Do you want to continue installation?

So, I clicked "no" for now until I get some feedback before screw up the harddrive... Thanks again!

David Zeplin

wrangler 03-18-2005 12:10 AM

Hi folks,
I dont intend to hijack the post but I feel its not totally out of context.
My question is- If I want to download software, the preferred means as discussed here is through urpmi but I dont have an internet connection at home and I would like to download software for mandrake(10.1) from my office(which runs windows only) and install them later at home. can anyone please suggest which is the best way to do this??

thanks for your help.

dianat100 03-18-2005 06:44 AM

Great tutorial, motub! I wish there were more users like you on the forum willing to spell it out to the noobs the way you did, i.e. if they ask a wrong question, correct it in the first place instead of giving useless tips which won't work in the long run because of the obstacles that they sooner or later will bump into. It seems to me some assume the noobs (however noob they are) are supposed to know what e.g. compiling, repositories, rpm, urpmi, tar, gzip are since it's so easy it can't get any easier than that. Well.... false!
If there was a real step by step manual that would explain this stuff (especially for those who migrated from Win) a lot of problems would be avoided. How on earth do you expect a person who's just migrated from WIn to know that they need to setup easy urpmi and that's it's vital if they want to encounter less "I don't know why it doesn't wanna work/install itself" situations.
True, you can spend zillions upon zillions hours of browsing this site and reading all the tips/suggestions, searching for each and every single little command to type in the console, but that's kinda wrong isn't it.

Astrotrain 03-25-2005 05:11 PM

Thank you so much! I'm not as afraid as Linux as I was a few minutes ago.

bhawmik 03-25-2005 05:22 PM

Trying to install Wine
 
When I try to install Wine using RpmDrake (aka Software Manager Install in Mandrake 10.1), It asks me to load the cd2 and cd3 but then compains that it can't read from the media /dev/hdb.

I have updated the media (using easyurpmi) and still it tries to loadfrom the CD. Can I force it to read from the mirrors?

Thanks
Sudipta

philosophe 04-01-2005 04:22 PM

jpackage and plf?
 
I'm about to try Holly's tutorial on easy urpmi but am wondering about the distinction on that page between jpackage and plf (free and nonfree). I don't think that's mentioned in her tutorial. Does it make a difference which I choose?

sgrayban 04-04-2005 05:50 AM

jpackage is java developement stuff like ant. Only needed if your going to compile any java programs/source.


And why plf went to some crazy split between free and non-free is beyond me. You can still download from both.

Linux4Life 04-06-2005 02:26 PM

Thanks for a great description on installing both .rpm and tar.gz. I think I will find this info very useful to put into practise for a long long time.

joff 04-12-2005 10:57 AM

Hi.
Hope this is the correct thread (as this is my first posting, as a complete newbie to Linux).
As an expert Windows user (and therefore MS hater), I decided to try MandrakeLinux 10.0.
My first impressions were mixed - impressed with user friendliness and possibilites, but dissapointed that my trusty laser printer is catagorised as 'paper weight'!
I totally agree with motub's posting about lack of info on RPMDrake and software installation generally, and was therefore well chuffed to find those instructions.
And thus to my problem: I followed the instructions, but after pasting the line from Easy URPMI, get the following error...

ftp://mandrake.lcpe.uni-sofia.bg/plf...sis.hdlist2.cz
...retrieving failed: curl: (7) Connect failed

I checked the security level (standard), and firewall (not turned on - I know, bad idea ;-) ).
I have an ADSL connection, and can surf without problems.
Any suggestions greatly appreciated.
Thanks in advance.

Waerner 05-11-2005 05:48 AM

Hey Motub, thanks alot for that guide!
But I have one question, a small one.
When selecting what Mandrake distro I have, there's no alternative for Mandrake 10.2.
I've downloaded my from Sunet, and everything I know about it is that it 10.2(rc).
Is it possible to use the 10.1 alternative? Or perhaps the 2005?

Cheers

motub 05-11-2005 08:52 AM

As far as I know, there is no Mandrake/Mandriva 10.2. 2005LE is what was going to be 10.2 before Mandrake bought Connectiva and changed its name, and at that time the release changed its name as well (from "Mandrake 10.2" to "Mandriva 2005 Limited Edition").

So using 2005 should be the correct thing to do.

Oh, and, "you're welcome" :)

Waerner 05-11-2005 10:16 AM

Thanks alot mate, downloading everything I can now!
I hope I won't get to many error-messages again...

But, so long, so good, and I'm planning to keep it this way :)

Cheers

Edit:
So long, so far? My english really sucks... So far, so good? :P

anuro 05-23-2005 11:51 AM

I have allready tryed Red Hat and Mepis but the best for me is Mandrak ( Mandriva). I Am beginer and I don't understand all. So pls help me. I installed realplayer and helix but I don't find the file to run the programs. Somebody know how to to find them. Thank you !
anuro

motub 05-23-2005 02:07 PM

Have you looked in your menu ? Under "Multimedia"?

:)

The alternative would be to open a terminal and type "RealPlayer" or "helix" (without the quotes) and hit the Enter key. If you do it this way, the program will close when you close the terminal. If you want to close the terminal (or use it for other commands without closing the program), type

"RealPlayer &"

or

"helix &"

again without the quotes around them.

Hope this helps,

anuro 05-23-2005 05:00 PM

There is what I did on the terminal. As you can see it I did not found the program...

[admin@localhost admin]$ realplayer&
[1] 17059
[admin@localhost admin]$ bash: realplayer: command not found
realplayer
bash: realplayer: command not found
[1]+ Exit 127 realplayer
[admin@localhost admin]$ realplayer &
bash: realplayer: command not found
[1] 17112
[1] Exit 127 realplayer
[admin@localhost admin]$ helix
bash: helix: command not found
[admin@localhost admin]$
___________________________________________
anuro

motub 05-23-2005 05:54 PM

I've checked both my Gentoo system (where I have RealPlayer installed), as well as the contents of the RPM available on the real.com site, and the binary name appears to be

realplay

rather than

realplayer

Try that instead.

anuro 05-23-2005 08:47 PM

Thank you very much motub ! I got it. It was realplay and not realplayer. I found the path to ( I did chortcuts...) ; / usr/bin/realplay and helix run on terminal with "hxplay" and the path was the same.

Thank's again motub.
anuro

motub 05-24-2005 05:11 AM

Glad to hear it-- and glad you found Helix; I don't have it installed, so I wouldn't know the binary name.

That kind of stinks, though-- if the Helix developers are going to have a 'non-intuitive' binary name like "hxplay" (I certainly wouldn't have guessed that), they really should take some care that the application appears on the main KDE or GNOME menu after installation. It's hard to maintain a good impression of a program that immediately disappears into the bowels of your system (and without even leaving a trail of breadcrumbs) after you've taken the time to install it.

But I hope that the program(s) works well enough for you to overcome the first impression. :)

Trio3b 05-29-2005 02:16 AM

back to newbs and urpmi
 
motub,

Just want to let you know that I agree with the philosophy of "demanding" that the linux community be more responsible and forthcoming in its help to newbies.
Recalling my mechanical engineering days in college, I can tell you that scientific and engineering people may be brilliant in their fields, but most of them are HORRIBLE communicators. I knew a guy that could NOT describe an automotive engine piston for the life of him, but could describe all the angular momentums and vector differentials in blistering detail. Anyway......the same goes for most "computer" documentation and I'm afraid that the linux community has a tendency to fall into that trap occasionally.

Example......being new to linux, I expected it to take several days to get a modem installed and internet connected. Wrong.......I still was not online after A MONTH. At first I thought it was due to lack of brain cells on my part, but after googling and being online for three weeks, I realized that nowhere on ANY of the "OFFICIAL" linux modem sites (which shall remain nameless) was there any mention that:
1. AOL required a special dialer
2. The best method for dialup is an external serial hdwr modem
3. That Kppp could be used to configure the modem (I was directed to use minicom!!)
4. There was TONS and TONS and TONS of info about software vs. hdwr modems but NOT ONE tutorial on how to dwnload and install the drivers.
5. I could not find in ANY tutorial on how, why, when, or where the kernel sources were, how to get them, how to load them and why they were needed before loading the drivers.
6. .........on and on and on............

Obviously, this information was out there, but it took an inordinate amount of time to locate, usually stumbling across it in a post somewhere.
It should have been IN YOUR FACE, up front, plain to see........ in a tutorial. To this day, I don't think I have seen a tutorial, with screenshots that explains how to fill in the Kppp interface and how to setup the modem init strings.

More importantly, much of the advice that is given, is done so with absolutely no clue as to the CONTEXT of the command.............consequently the newbie DOES NOT LEARN Linux in a big picture sense, but merely stumbles thru, only learning the specific "heiroglyphic" for that specific function on that specific day.

Considering that the internet is one of the best ways, and in many cases, the only way to promote and spread linux around the planet, it is I-N-C-R-E-D-U-L-O-U-S to me that there are practically no distro specific tutorials, with screenshots, about internet connection, PLASTERED all over EVERY SINGLE linux forum known to mankind!!!!

Well........that's just me.


Thanks for the tips

motub 05-29-2005 07:46 AM

Well said, Trio3b... but here's another aspect of my "philosophy" that I hope you will agree with:

If one cares enough to rant about an issue, one cares enough to pitch in to solve it-- and it's in fact hypocritical not to pitch in and help, but rather to continue to rant for "someone else" to solve the problem.

Not that I'm accusing you personally of being hypocritical-- no such thing. This is a symptom of the major mindset change that "must" occur for one to successfully migrate from Windows use to being a member of the Linux community, and a necessity as big as changing your mind often takes time to be recognized (both in this area, and in life in general).

The keyword here is self-reliance-- something that Windows use actively drills out of you, and Linux use actively encourages.

In the Linux community, things get done because some community member saw a need for something to get done, and cared enough to expend the effort to do it. URPMI is, afaik, a community-created resource, generated by one person, not a Mandrake-sponsored one. Essential informational resources ranging from the LQ Wiki, Tutorials, and HCL, to the HOW-TOs on the TLDP, LinuxNovice.org, and TuxFiles.org, not to mention DistroWatch, as well as such special-interest resources as the Wine application Database, the new Wine Wiki, Frank's Corner, linmodems.org, linuxprinting.org, and even rute, which contains answers to pretty much any question you might ever ask about Linux (it's a book, both literally and figuratively)-- all exist because somebody took the time to publish what they know.

Some of us know a lot about everything (like Paul Shear, author of rute). Some of us know a lot about just one area (printing, linmodems). Some of us know about just one piece of hardware and how to get it working under just one distribution (because we succeeded in doing so on our own box). Some of us don't know about any of this, but know how to read and understand the technobabble that many find so objectionable, and translate it into understandable form for the less-technologically minded.

But the beauty of the Linux community is that it doesn't matter how much or how little you know. If you know something-- almost anything at all that you see people here and on other forums or mailing lists asking about, or if you have the skill to explain some "geeky" previous response to a first-time poster so that they understand what the Guru said-- then your contribution is valuable, and it is the 'duty' of a good and responsible community member to make that contribution.

This is the glue that makes us a community, and not just a loose collection of users, as we were in the Windows world. We build our habitat ourselves; we don't just live in what someone else built for us (and pay for the privilege).

The point being (in case you haven't guessed ;) ):

If you can create such a tutorial-- with screenshots :D -- for even one distro, then do it. Put it up on your personal webspace, and use a lot of keywords so Google or Google Linux will find it. Make friends with somebody with a domain and let them host it for you. Put the link in your sig so people see it. Send an email to the maintainer of (for example) Linmodems.org, so they can put it on their links page (if they have one; I don't have a modem, so I'm not that familiar with the site). Send an article to DesktopLinux.com, a tutorial to Tuxfiles.org, and/or an article to TUX Magazine-- this would be right up their alley, being an online magazine for new Linux users.

Get the screenshots up on LinuxBeta.com. Write a how-to and post it on the TLDP, LinuxLookup.com, LinuxNovice.org, JustLinux, and of course LQ Tutorials, and the LQ Wiki.

Talk to users of other distributions (via mailing lists, forums, LUGs) who know how to do the same for their distro, and add their tutorials to yours for a more rounded approach.

Heck, you could even run an entire Mandrake newbie site; all of my links to same (MandrakeXperience, Desktop Mandrake, MUO) are dead (OK, the MUO isn't exactly dead, but doesn't seem to be an actively updated resource), and it certainly seems needful if even a little HOW-TO like mine is still generating responses after almost a year (which I will use as my excuse why I still haven't added the text to the Wiki or Tutes page; the thread keeps coming up to the top of the heap, so thus far there has been no danger of it disappearing. Yes, I know that's thin. I've been busy).

Anyway, you've had your rant (everybody gets one free rant with membership :) ), and now "you" (generic you) have to back it up, or you (still generic) look like a whiner instead of a productive member of the community. And no one wants that; it's like being chum in shark-infested waters. Whiners will be eaten alive (and are, on a daily basis). So don't whine, work :) .

motub 05-29-2005 09:42 AM

Well, at least I buckled down and submitted the HOW-To, anyway. Last thing I'd want to be accused of is "do as I say, not as I do" ;) .

Trio3b 05-30-2005 12:01 AM

pitching in
 
Point taken.......

Not sure I'm organized enough yet to write a tutorial that:

1. is inclusive enough to cover all (or most) possible variations
2. teaches as it informs
3. does NOT overwhelm the newb while it is doing its job, but.............

I do take weekends to browse linux forums and look for those having trouble with dialup on linux. I did post rather profusely for a while about Kppp, serial modems and how to install internal PCI modems with Intel 536ep chipset.

Have been asked to setup a small office network and am currently busy with that. Am experiencing similar situation in that I spent weeks with all the networking "bibles" with no luck until someone "spoke english" and just had me type "sftp://192.168.0.1" into Konqueror. How hard was that? Well.........hard enough that it took several weeks to stumble across that info.

I will look into writing a tutorial when I get my s**t together.
Thanks

motub 05-30-2005 06:43 AM

I hear that, but on the other hand, it doesn't have to be "perfect" out-of-the-box-- this is, after all, Linux :) . Something imperfect is often better than nothing at all.

But here's an idea for you: when you make extensive posts on a subject, save the text!!! I have a folder of text clipped out from my posts on complex subjects-- my URPMI post in this thread was a modified version of one of them, actually (which is lucky because the forum I originally wrote it for upgraded and had to delete all their old posts, so it's gone from there).

It saves you having to take the time to write something complex all over again, gives you a fast template in case you need to post it again, and a base for a web page, if you want-- it can just be "collected notes" or some such-- and last but not least, preserves the information in case the forum you originally posted to goes belly-up for whatever reason.

I know I'm kind of a believer in the idea of "deathless prose" (even when it's not, really), but still, it's even worth going back to any given forum and editing your post (without actually changing anything) so that you can copy the text with the UBB formatting and embedded links and paste it to text. Especially if you spent an hour writing it the first time. $DEITY knows, just the time spent makes it worth 'backing up'.

And it really makes it easier to help others, at least on the subjects that you know enough about to talk about a lot.

:)

Trio3b 05-31-2005 12:29 AM

saving text
 
Yes, I have a file that I paste into posts.

Thanks

setlec_seta 06-21-2005 03:18 PM

errr iknow but i'm still a kind of noob but why i can't force an installation with rpm or urpmi on the Mandriva LE 2005 dvd??? it says in the ternimal "only used for instalation, updates, rmsource (...) could be forced."

is this a modification applied by mandriva or a product of the fusion MDK-conectiva distrib?

motub 06-21-2005 04:02 PM

Sorry, I don't get what you're saying. What exactly are you trying to force-install, what command are you using to do so, and what is "only used for installation, updates and the like"?

As far as I know, the 2005 release is not modified by the acquisition of Connectiva as yet; it's pretty much what 10.2 was going to be, just under a new name. The integration of Connectiva technology (and presumably now Lycoris technology as well), is not supposed to happen until the 2006 release.

phoneix 06-22-2005 08:06 PM

Quote:

Originally posted by motub
But you see, that's just my point (and why this is a pet peeve of mine; nothing to do with you personally).

A new Linux user migrating from Windows is advised to download and install Mandrake as the easiest to use version for someone such as him/herself. Fine. Mandrake installs, and all these helpful hints and notes pop up, but none of them mention RPMDrake (or provide an intial setup of outside repositories), so unless the user has perhaps read a couple of reviews of Mandrake, or gone exploring in the MCC, the user does not know this tool (much less urpmi) exists.

This is already "not good" (the user should have some indication of what tools they have available, especially when they're as important as urpmi/RPMDrake). S/He reads some general Linux introductory material on his/her own, and s/he discovers that *.rpm exists, and that s/he is supposed to use those type of files to install software because s/he is using an RPM distro. The user still knows nothing about any of the rpm tools that resolve dependencies, but may have heard of dependency hell during the course of this reading.

So the user goes trawling the Internet for the homepages of various software s/he's heard about and wants to install (and which is not on the Mandrake CD's-- such as WINE, for example). Now, me, I'm already p.o.'d on behalf of this user, because s/he is already doing more work than is necessary (and this extra work is more likely to lead to failure than success). So the user finds on the homepage some RPMs and a source tarball. The RPMs are for SuSE, RedHat and "generic" and the source tarball is... a source tarball. None of these seem to be quite "right", but the user wants to install the program and at this moment does not know of any other way to acquire or install software.

So of course s/he asks here about "rpms and tar.gzs". S/he doesn't know what else to ask, and no one has told him/her that s/he's asking the wrong question!

Even on a dedicated Mandrake forum, where (presumably) everyone inclined to answer has some familiarity with URPMI/RPMDrake, no one says a word, and continues to provide the standard instructions of rpm -i and ./configure make makeinstall.

And two days later this user is going to be back complaining of dependency hell (because s/he was not told that if you intend to use rpm you have to find and install all the dependencies yourself beforehand, which is annoying enough in itself), or complaining that s/he can't compile the source (because Mandrake puts its libs or other dependent files in a custom location not referenced by the ./configure or Makefile of the developer of the program, so they are not found, and naturally this user does not have a clue how to fix such a problem. When was the last time you saw a README or INSTALL file in a source tarball that contained specific editing instructions for Mandrake, as opposed to, say Debian?). Assuming they haven't already decided that "Linux is s**t" and gone back to Windows, where "at least you can understand how to install a program".

Get out of my head. You just summed up everything that i was thinking. HOWEVER, i am never using M$ as my primary OS, only for games. BUT my head is spinning about this installing stuff. I stumbled across your posts and its like an osais. THANK YOU for your input. It has helped me greatly and i am now learning more. My fustration is easing greatly.

floppywhopper 06-28-2005 02:04 AM

Just something to throw into all this
I dont believe this site has been mentioned

http://www.howtoforge.com/

if you are looking for a site to host your how-to
this is another worth looking at

Thanks to motub for your contribution
I have been frustrated by easyurpmi
because of the size of the download
being on dial-up
but will try again with those instructions for a smaller download

floppy

ChillyWillie 07-18-2005 07:55 PM

Just to add to floppywhopper's post, I discovered the linux documentation project in my early linux days and it was a goldmine of howto information. Admittedly, much of the documentation is easily dated, but nevertheless a good place to browse.

www.tldp.org

Happy hacking

-J

frazelle09 07-22-2005 02:38 PM

Another Three Cheers for Motub
 
Dear Sir:

THANK YOU! Have spent the last three days and over 8 hours trying to figure out how to locate and then download and install the most recent version of Postgresql for Mandriva. After finding out about URPMI from your How-To, was able to do it on the morning of the third day.
As you have noted, is there any reason for someone to have to go through this type of hassle? Would it be so much of a problem for Mandriva or whoever to make this automatic? Do they understand "automatic", as in "behind-the-scenes", just "let-me-get-on-with-my-work". If these distros of Linux are meant as Learning Linux the Hard Way, i.e. without proper courses, etc., then they should be advertised as such. i personally feel that sometimes there is a "well if you aren't willing to learn this, then i'm not going to help you" sort of attitude -- very condescending. i'm not a programmer and don't expect everyone to do what i do or to be like i am. We wouldn't have a functioning society if this were the case. i'm not even an Access programmer but need something fast as accessible in order to set up a simple db under Linux, but to have to learn not only Postgresql but to have to figure out a new operating system as well is like going back, for me anyway, some 20 years.
i guess i got off the track of my main issue. Sorry. Thanks again for understanding those of us who would like to switch as painlessly as possible from the "other" operating system and for taking the time and energy to do something about it.

jtravnick 08-15-2005 08:00 AM

OK this might be a dumb question but how does one know if they can use URPMI to get what they need or if they have to download a tar.gz file? For instance I still do not have flash installed on here yet since now I'm not sure if I was right in downloading the file or if I should use URPMI or RPMDRAKE. That and the instructions for using URPMI really are not to clear I went to the site picked some servers but down at the bottom of the page it says" to type this in" but does not say what to type in.

Jim


All times are GMT -5. The time now is 07:52 PM.