LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-29-2008, 12:38 PM   #1
stash1071
Member
 
Registered: Mar 2006
Distribution: Kubuntu 5.10
Posts: 35

Rep: Reputation: 15
Wireless gone after kill switch touched


I recently purchased a XPS M1330 with Ubuntu pre-installed. Wireless was working great, but the other day I bumped the switch to turn wi-fi off, and wireless went away after my next reboot. I put the switch back to the on position but wireless is still gone after a reboot.

The drivers appear to load fine, but a connection cannot be found. How can I get Ubuntu to act like a never touched the switch? Thanks in advance

Code:
$ lsmod | grep ipw
ipw3945               119840  0 
ieee80211              35656  1 ipw3945

$ sudo /sbin/ipw3945d-2.6.22-15-generic 
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.22
2008-06-29 13:25:29: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
 
Old 06-29-2008, 02:36 PM   #2
stash1071
Member
 
Registered: Mar 2006
Distribution: Kubuntu 5.10
Posts: 35

Original Poster
Rep: Reputation: 15
I was able to get a wireless connection back in the network manager, but am unable to detect any networks, so some progress at least.

I followed the instructions here (even though my problem was not LED related):
https://bugs.launchpad.net/ubuntu/+s...22/+bug/176090

I upgraded to Ubuntu 8.04 then:

Code:
$ sudo apt-get install linux-backports-modules-hardy
$ sudo rmmod iwl3945
$ sudo modprobe iwl3945
$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...                                   [ OK ] 
prystasj@dell-desktop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

eth1      IEEE 802.11a  ESSID:""  Nickname:""
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 
Old 08-08-2008, 01:24 PM   #3
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 291

Rep: Reputation: 75
I see that when you ran the iwconfig command you received the following output.
Code:
prystasj@dell-desktop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

eth1      IEEE 802.11a  ESSID:""  Nickname:""
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
You have both the wmaster0 interface and the eth1 interface. The wmaster0 interface belongs to the iwl3945 driver but is not the interface used to connect to the internet. The eth1 interface is most likely the ipw3945 driver. This is telling me that you have both the iwl3945 and the ipw3945 driver loaded, assuming that you don't have any other wireless cards connected to your computer. These two drivers may be conflicting with each other and so you are not able to use network manager to get online. Try running the following command and post the output. The following is my output with some slight modifications.
Code:
# ifconfig -a
eth0      Link encap:Ethernet  HWaddr BB:CC:CC:CC:CC:CC
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:18

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1275 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1275 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1093164 (1.0 MiB)  TX bytes:1093164 (1.0 MiB)

wlan0     Link encap:Ethernet  HWaddr AA:AA:AA:AA:AA:AA
          inet addr:192.168.1.138  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:738103 errors:0 dropped:43534 overruns:0 frame:0
          TX packets:628520 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:704800191 (672.1 MiB)  TX bytes:114162989 (108.8 MiB)
          Interrupt:17 Base address:0xe000 Memory:88000000-88000fff
By running the previous command you should now see that a new interface has shown up called wlan0. wlan0 is the interface used to connect to the internet for the iwl3945 driver. In my case I'm using the 2.6.26.1 custom kernel with the now deprecated ipw3945 drivers. I'm only using the older drivers because I've noticed a 10x decrease in my upload data transfers via FTP on the new iwl3945 drivers. I will try them out again if I upgrade to a new kernel and see better performance.
Also, just for the sake of getting more info you might want to try running the following commands to see if there are any output.
Code:
# lsmod | grep ipw3945
Code:
# lsmod | grep iwl3945
If either of those commands show any output then the modules are loaded. If no data shows up then the module is not loaded.
 
Old 08-12-2008, 07:55 PM   #4
stash1071
Member
 
Registered: Mar 2006
Distribution: Kubuntu 5.10
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks for the thorough reply. My biggest mistake was confusing which position on the wireless switch was "on". But it wasn't until I did a few more updates that wireless began working. Potentially, the conflict was resolved?

Code:
[prystasj] ~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1d:09:5d:a6:4c  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 

eth1      Link encap:Ethernet  HWaddr 00:1f:3c:7c:39:86  
          inet addr:192.168.1.70  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:3cff:fe7c:3986/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12968 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10043 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13226417 (12.6 MB)  TX bytes:1809838 (1.7 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2980 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2980 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:150900 (147.3 KB)  TX bytes:150900 (147.3 KB)

wmaster0  Link encap:UNSPEC  HWaddr 00-1F-3C-7C-39-86-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
I only get something for iwl3945:

Code:
[prystasj] ~$ lsmod | grep ipw3945
[prystasj] ~$ lsmod | grep iwl3945
iwl3945                93940  0 
iwlwifi_mac80211      219108  1 iwl3945
led_class               6020  1 iwl3945
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enable the RF kill switch for ipw2200 Asuran Mandriva 9 11-28-2007 08:54 AM
acer 4100lmi wireless kill switch problem zalis Linux - Laptop and Netbook 18 11-21-2007 03:57 AM
Problem with Radio Kill Switch ppr:kut Linux - Wireless Networking 0 03-06-2007 02:08 AM
How I solved the wireless 'ipw2200 kill switch' problem mixtr Slackware 4 11-21-2006 09:41 AM
Can't turn off RF Kill switch on Asus Z33A with Intel 2200BG wireless kmierle Linux - Laptop and Netbook 2 09-22-2005 10:11 PM


All times are GMT -5. The time now is 04:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration