LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-18-2007, 11:34 PM   #1
Asuran
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0
Thumbs down enable the RF kill switch for ipw2200


Hi all,

I'm using Mandriva 2008 with Intel Pro/Wireless 2200BG Card.
Does anyone know how to enable the RF kill switch. Mandriva is telling me my wireless card is disabled. Please enable the wireless switch (RF kill switch) first.


Regards
 
Old 10-20-2007, 04:11 AM   #2
Philosopher
Member
 
Registered: May 2005
Posts: 101

Rep: Reputation: 15
Same problem here (Mandriva 2008 Free). The device seems to be installed correctly, but just not (hardware)activated. Unnecessary to say, that the actual switch on my laptop doesn't work

When I do
Code:
# cat /sys/bus/pci/drivers/ipw2200/000*rf_kill
# 2
Which means, the wlan-card is hardware based switched off (see http://ipw2200.sourceforge.net/README.ipw2200)

When I try
Code:
# echo 0 > /sys/bus/pci/drivers/ipw2200/000*rf_kill
# 2
the result stays the same, so it looks like this is only the software based switch.

I also tried acerhk, but that didn't work on my laptop (Acer Aspire 3628).
The funny part is, that when I boot from Mandriva One (Gnome) it works just fine. So if all else fails, reinstallation should fix it (which is not my main goal, ofcourse )

So anybody any suggestions?
 
Old 11-08-2007, 10:51 AM   #3
srinivas.ap
LQ Newbie
 
Registered: Nov 2007
Posts: 8

Rep: Reputation: 0
Talking

Quote:
Originally Posted by Asuran View Post
Hi all,

I'm using Mandriva 2008 with Intel Pro/Wireless 2200BG Card.
Does anyone know how to enable the RF kill switch. Mandriva is telling me my wireless card is disabled. Please enable the wireless switch (RF kill switch) first.


Regards
THis problem seems to be more with Acer laptops.

I have after reading ubuntu forums, mandriva forums, tried this on my acer lap top

Press the function key and the wireless switch, it gets activated

Good luck
gif
srinivas.ap
 
Old 11-08-2007, 10:53 AM   #4
srinivas.ap
LQ Newbie
 
Registered: Nov 2007
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by Philosopher View Post
Same problem here (Mandriva 2008 Free). The device seems to be installed correctly, but just not (hardware)activated. Unnecessary to say, that the actual switch on my laptop doesn't work

When I do
Code:
# cat /sys/bus/pci/drivers/ipw2200/000*rf_kill
# 2
Which means, the wlan-card is hardware based switched off (see http://ipw2200.sourceforge.net/README.ipw2200)

When I try
Code:
# echo 0 > /sys/bus/pci/drivers/ipw2200/000*rf_kill
# 2
the result stays the same, so it looks like this is only the software based switch.

I also tried acerhk, but that didn't work on my laptop (Acer Aspire 3628).
The funny part is, that when I boot from Mandriva One (Gnome) it works just fine. So if all else fails, reinstallation should fix it (which is not my main goal, ofcourse )

So anybody any suggestions?
Dear

Try pressing the function key and the wireless switch.

It works.

Good luck.

srinivas.ap
 
Old 11-08-2007, 12:08 PM   #5
Philosopher
Member
 
Registered: May 2005
Posts: 101

Rep: Reputation: 15
Thanks for your suggestion, but unfortunately that doesn't work either. I tried it before, during and after booting but no change.

I also read that with some Laptops you have to activate the wlan card via BIOS, but again I don't have any similar option.
 
Old 11-11-2007, 02:48 AM   #6
srinivas.ap
LQ Newbie
 
Registered: Nov 2007
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by srinivas.ap View Post
Dear

Try pressing the function key and the wireless switch.

It works.

Good luck.

srinivas.ap
I would also like to add something more to the suggestion posted.

su as root

then type ipw and then the tab bar

if you have ipw2100 then you get the ipw2100 start stop commands
ipw3945
for my ipw3945 i got ipw3945d-start ipw3945d-stop commands

first i entered ipw3945-stop
then ipw3945d-start

after this pressed function key and the wireless switch works after this.

Try again
 
Old 11-14-2007, 05:59 PM   #7
Philosopher
Member
 
Registered: May 2005
Posts: 101

Rep: Reputation: 15
I tried what you suggested, but still no difference.

Btw, in meantime I also did a reinstall via Mandriva One. As I posted earlier, the wlan card works great when I boot from the Live-CD, so I thought this way I could solve the problem. But unfortunately after the installation process had finished, it has been the exact same problem

I'm just happy, that I'm not depended on wireless network, otherwise I'd be forced to switch back to Mandriva 2007.1, though it'd be nice to have ofcourse.
 
Old 11-15-2007, 12:33 AM   #8
srinivas.ap
LQ Newbie
 
Registered: Nov 2007
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by Philosopher View Post
I tried what you suggested, but still no difference.

Btw, in meantime I also did a reinstall via Mandriva One. As I posted earlier, the wlan card works great when I boot from the Live-CD, so I thought this way I could solve the problem. But unfortunately after the installation process had finished, it has been the exact same problem

I'm just happy, that I'm not depended on wireless network, otherwise I'd be forced to switch back to Mandriva 2007.1, though it'd be nice to have ofcourse.
Dear Philosopher,

I am using an Acer laptop, which has a separate wireless switch. It does not get activated automatically, the procedure was suggested as I could do it. For me wireless works,

su as root
ipw...stop
ipw...start
press function key and wireless switch

However, I suggest you to download any missing drivers from mandriva website for ipw.

Also install wifi kernel support for wireless, laptop-mdv. in the "Configure your computer" enable updates for official and all distribution sources.

then type wifi, laptop, ipw(your number) to get all the updates.

You should be successful with the above.

Try and check again.

Thanks
 
Old 11-28-2007, 05:18 AM   #9
Jakosa
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Try set rf_kill to 0

I have been trying to fix my wifes ACer and have run into the same rf switch problem. She will NOT be able to log in as SU.

Anyways. I read the sourceforge.net/README.ipw2200 and under: 1.4.2 Device Level Sysfs Helper Files I found something about the rf switch.:

rf_kill
read -
0 = RF kill not enabled (radio on)
1 = SW based RF kill active (radio off)
2 = HW based RF kill active (radio off)
3 = Both HW and SW RF kill active (radio off)
write -
0 = If SW based RF kill active, turn the radio back on
1 = If radio is on, activate SW based RF kill


In the following link (on my computer) /sys/bus/pci/driver/ipw3945/0000:05:00:0 I found the file called rf_kill

It had the value 2. As root I changed it to 0 and now the whole thing works. Also after a reboot.
 
Old 11-28-2007, 08:54 AM   #10
valyo_bg
Member
 
Registered: Jul 2005
Location: Bulgaria
Distribution: Mandriva 2011
Posts: 49

Rep: Reputation: 15
Dear Asuran,
I'm also with Mandriva 2008 now and same wireless card, and to enable RF switch I change my configuration files in /etc

So try to add these lines:

in /etc/modprobe.conf:

options ipw2200 led=1 bt_coexist=1
options acerhk poll=1 autowlan=1
alias eth1 ipw2200 # change eth1 to corresponding value

in /etc/modprobe.preload: (this will enable module acerhk)

acerhk poll=1 autowlan=1


Reboot PC. You shut have module acerhk installed in your kernel. On my laptop RF switch work fine with settings on the top.
Regards,
Valentin

Last edited by valyo_bg; 11-29-2007 at 03:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
acer 4100lmi wireless kill switch problem zalis Linux - Laptop and Netbook 18 11-21-2007 03:57 AM
Problem with Radio Kill Switch ppr:kut Linux - Wireless Networking 0 03-06-2007 02:08 AM
How I solved the wireless 'ipw2200 kill switch' problem mixtr Slackware 4 11-21-2006 09:41 AM
Is Microsoft about to release a Windows "kill switch"? rkelsen General 29 07-06-2006 10:18 PM
Can't turn off RF Kill switch on Asus Z33A with Intel 2200BG wireless kmierle Linux - Laptop and Netbook 2 09-22-2005 10:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration