LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 06-16-2005, 01:21 AM   #1
sien
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Rep: Reputation: 1
Lightbulb Got wpc54g (no version) with redhat enterprise 3 kernel 2.4.21 to work...


To get linksys wireless WPC54G (NOT VERSION 4 OR OTHERS)
working on Red Hat Enterprise Linux 3
kernel 2.4.21_4 (may work on 2.4.21 XX)
NEEDED ndiswrapper vrsion 9 since I had old kernel and new
ndiswrapper won't work with 2.4* kernel.

Many thanks to this forum to put all this together from various sources.
Also take a look at:

http://www.wasab.dk/morten/blog/arch...d-redhat-linux


1) Need to d/l the following (both can be found on sourceforge.net):

WPC54G_driver_utility_1.3.1.zip
ndiswrapper-0.9.tar.gz
R76521na.EXE (see below for WEP/WPA authentication)

except from sourceforge.net:

[

Card: Linksys WPC54G, 54mbps -- link here
Chipset: Broadcom BCM94306
Driver: ftp ftp.linksys.com/pub/network/WPC54G_driver_utility_1.3.1.zip
pciid: 14E4:4320


Other: Works with WEP and WPA with either CCMP/AES or TKIP ciphers. Scott says: Unzip the EXE file, and use the driver in the AR directory. Random cases of not being able to probe the IRQ, see the card, connect, etc. may be fixed by adding "acpi=noirq" to kernel params. This card works great on Gentoo 2004.2 with a 2.6.9 kernel and ndiswrapper 0.11. Card also works fine with SuSE 9.1 pro and ndiswrapper 0.12.


2)
a) unzip WPC54G_driver_utility_1.3.1.zip
b) After uzipping and untarring ndiswrapper tar ball (0.9 version),
cd to ndiswrapper directory,
make install

To install windows driver, get the inf file first (step 2a)
ndiswrapper -i AR/brmwl5a.inf (-e filename to remove driver)
ndiswrapper -i lsbcmnds (from WP*utility)
ndiswrapper -l (to list drivers installed)

Load module,
modprobe ndiswrapper

Check dmesg to see that drivers installed.
Plug in driver, do
lspci -v
You should see linksys WPC54G

3)Reboot with card connected.
3a) for some reason, you have unload the ndiswrapper and reload it
enter: rmmod ndiswrapper
3b) Then enter: modprobe ndiswrapper
Got this from author Kersten78 on linuxquestions.org..
Check out the thread on the author if you want for possibe fix, see last
step after you get things working.

4)I used system tools network device control Graphical interface
to configure wlan0.
a)Create a new profile,
b)select wireless connection for device type.
Hopefully you will see ndiswrapper wlan0, select that.
c)Then enter the fields correctly, i.e your SSID,RATE.
For WEP, use mode managed, change the channel setting to what your
router is, and enter the key, for hex, don't forget to put 0x in
front of the key. You may not be able to change the channel, so you
might have to do it by manually by editting /etc/syconfig/networking/profiles/default/ifcfg-wlan0 and add CHANNEL=yourchannelid line to the file.
First save then try to "activate" the card.. see if it activates.
If not do the hand mods and go back to step 3 till successful activation

5)Do iwconfig, you should see correct settings
if not, keep going back to step 3 and try to fix the settings

6) do ifconfig to see if a valid ip address comes up. By this
point you should hopefully have internet connection.

7) Got this from link above, i.e. waasb.dk....
to stop having to do rmmod, then modprobe, you need to change how
things get intiialized started up... See below.

except: from link with annotations to make it more detailed.

"the networking is set to start up before the PCMCIA interface is initialized. To overcome this problem, I changed the chkconfig parameters for three of the startup scripts (the NFS script failed to work properly if not started after the network): START UP SCRIPT ARE IN /etc/init.d.
You will see files pcmcia, network and nfslock. You need to change the number so that
pcmcia starts first, then network, then nfslock... example below shows order to be 21, 22, 23.


* pcmcia: 21 96
* network: 22 90
* nfslock: 23 86

After that, I issued the following commands to reset the sequence:

chkconfig pcmcia reset
chkconfig network reset
chkconfig nfslock reset

The only thing missing was to make sure the PCMCIA and NdisWrapper drivers were loaded on startup, by simulating a card insert event – if necessary – and forcing the drivers to load:

rmmod ndiswrapper 2>/dev/null
cardctl status | grep "no card" > /dev/null && cardctl insert
modprobe ndiswrapper

That’s it, running /etc/init.d/network restart should bring up the wireless interface, after which I could turn off the ethernet connection by setting ONBOOT=no in
/etc/sysconfig/network-scripts/ifcfg-eth0."

One other way to ensure you do rmmod, modprobe is to put this in the /etc/rc.local file.
this will make sure these steps execute after all inits are done.. but if above is done, you shouldn't
have to do this.. you can as extra insurance..
/etc/rc.local: add below
rmmod ndiswrapper
modload ndiswraper


////////////////////////////////////////
Addl info:
/////////////////////////////////////////


lspci -v ( to list all cards found)

To see essids..

iwlist wlan0 scan

If you want to try iwconfig to create icfg-wlan0
(gets created in /etc/sysconfig/networking-scripts),
instead of system device control you can by doing iwconfig
manually to set controls. I haven't tried this in detail
as I got the other way to work..

iwconfig

iwconfig interface [essid {NN|on|off}]
[nwid {NN|on|off}]
[mode {managed|ad-hoc|...}
[freq N.NNNN[k|M|G]]
[channel N]
[sens N]
[nick N]
[rate {N|auto|fixed}]
[rts {N|auto|fixed|off}]
[frag {N|auto|fixed|off}]
[enc {NNNN-NNNN|off}]
[power {period N|timeout N}]
[txpower N {mW|dBm}]
[commit]
Check man pages for more details.

From
inuxquestions.org/questions/answers.php?action=viewarticle&artid=217


iwconfig wlan0 mode managed
iwconfig wlan0 key restricted
iwconfig wlan0 essid (ssid)

/usr/local/sbin/dhcpcd wlan0 (must be root?)

Last edited by sien; 06-16-2005 at 08:25 PM.
 
Old 06-16-2005, 03:10 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Excellent. Have you thought about submitting this as a Tutorial?
 
Old 06-30-2005, 04:27 PM   #3
languido
LQ Newbie
 
Registered: Jun 2005
Location: Near Milan, Italy
Distribution: Fedora Core 4
Posts: 1

Rep: Reputation: 0
Thank your for your very useful document!
I followed your instructions and....
WPC54G V1.2 working on Fedora Core 4!


Notes:
1 - No custom kernel build required. (uname -a
Linux neotokyo3 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 athlon i386 GNU/Linux)
As you can see OriginalTM Fedora.redhat.com kernel.

2 - NDIS wrapper version 1.2 from sourceforge.

3 - I added "alias wlan0 ndiswrapper" in /etc/modprobe.conf as someone suggested.

4 - My kernel is not enabled for the "4K option" needed by ndisdriver (I see a warning during compilation). Anyway, it looks to work pretty good.

5 - I edited ifcfg-wlan0 manually (see below) otherwise I am not able to see the device in "Kmenu/System Settings/Network/New" and I can't initialize it.

Some notes:
MODE=Auto
ESSID=
HWADDR=
DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=dhcp
USERCTL=yes
PEERDNS=yes
TYPE=Wireless
RATE=Auto
IPV6INIT=no
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
GATEWAY=
CHANNEL=1
6 - It looks like only bottom cardbus in my Sony Vaio FX804 can be used (I think this is a specific problem of my notebook).

-Guido
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard doesn't work in RedHat Enterprise AS V4 uther@lit.net Red Hat 3 07-17-2005 07:41 PM
Why doesn't CrossOver Office work on Fedora and RedHat Enterprise Linux 3 tlawlessrr Linux - Software 2 04-28-2004 09:36 PM
nForce drivers for RedHat Enterprise WS version 3 roiboy Red Hat 3 04-27-2004 04:31 PM
redhat fedora gcc version (compiled for 2.4.20) doesn't match kernel version 2.4.22 start1000 Linux - Software 0 03-16-2004 08:17 PM
Kernel version smp or enterprise redhat_zephyr Linux - Newbie 1 01-04-2004 10:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 08:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration