LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-29-2006, 09:15 AM   #1
DaveRad
LQ Newbie
 
Registered: Aug 2006
Posts: 2

Rep: Reputation: 0
X.org Dual Head PC104 and Intel i810 not working


Hello!

I've been attempting to use dual-headed monitors on a custom pc with a design based on this:
diversifiedtechnology.com/products/etx/etxlx15.html

We have added a second video card:
pc104plus.com/products/pc104plus/ppmfpvga.html

X works fine with the onboard intel card, until the second card is placed on the system. The pc104 video card becomes the primary card for the system (with no way to change this that I have found).
I get the following errors from the kernel:

PCI: Transparent bridge - 0000:00:1e.0
PCI: Using IRQ router default [8086/24cc] at 0000:00:1f.0
PCI: Cannot allocate resource region 0 of device 0000:00:02.0
PCI: Cannot allocate resource region 1 of device 0000:00:02.0

lspci -vvv produces this (most output removed, only video card information was left in)

00:02.0 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Interrupt: pin A routed to IRQ 0
Region 0: Memory at 40000000 (32-bit, prefetchable) [disabled] [size=128M]
Region 1: Memory at 48300000 (32-bit, non-prefetchable) [disabled] [size=512K]
Region 2: I/O ports at fff8 [disabled] [size=8]
Capabilities: [d0] Power Management version 1
Flags: PMEClk- DSI+ D1+ D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

02:05.0 VGA compatible controller: Chips and Technologies F69000 HiQVideo (rev 64) (prog-if 00 [VGA])
Subsystem: Chips and Technologies F69000 HiQVideo
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR+ FastB2B-
Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Interrupt: pin A routed to IRQ 11
Region 0: Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Expansion ROM at 48200000 [disabled] [size=256K]


X then produces this:

(==) I810(1): Depth 16, (==) framebuffer bpp 16
(==) I810(1): RGB weight 565
(==) I810(1): Default visual is TrueColor
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.so
(II) I810(1): initializing int10
(EE) I810(1): Cannot read V_BIOS
(EE) I810(1): VBE initialization failed.
(II) UnloadModule: "i810"
(II) UnloadModule: "int10"
(II) UnloadModule: "vgahw"
(II) UnloadModule: "vbe"
(II) UnloadModule: "int10"
(II) do I need RAC? No, I don't.



X will run on the primary card, but will not start on the intel card.
I have tried the ubuntu patched .deb files referenced here:

launchpad.net/distros/ubuntu/+source/xorg-server/+bug/36461

I have also attempted to use the SuSE patched rpms. Both resulted in hard locked machines.

I have verified that dual head will work on this sytem, as it does work after I have installed windows XP, the intel drivers, and then the drivers found for the PC104 card.


If any other files might be helpful, please feel free to ask, I can post them.
Thanks,

Dave

Note:
I have omitted the full posting of files as they are about 88k worth of text. If you want them, I can post them later.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i810 dual head kg4ysy Linux - Hardware 0 05-26-2006 12:09 PM
Dual-Head Debian w/ XFree86Config-4 usin i810 integrated and ati all in wonder VE pci thetictacaddict Linux - Hardware 4 06-06-2005 08:53 AM
Help getting vid card working (i810 intel) edman007 Linux - Software 3 01-24-2005 10:46 AM
Intel 915 and dual head display tribble Linux - Hardware 1 10-13-2004 02:36 AM
intel i810 i815 driver no longer working in 2.6.* pele_smk Linux - General 2 01-15-2004 04:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration