LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-26-2006, 09:06 PM   #1
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Rep: Reputation: 30
why clamav keep prompting me to update when its already updated


Dear friends,

The freshclam.log at my mail server is showing the following logs:

WARNING: Your ClamAV installation is OUTDATED - please update immediately!
WARNING: Local version: 0.80 Recommended version: 0.82
main.cvd is up to date (version:29, sigs: 29086. f-level: 3. builder: tomek)
Error: Can't connect to port 80 of host database.clamav.net (61.8.0.16)
daily.cvd updated (version: 705.sigs:1650, f-level: 4, builder: trog)
WARNING: Your ClamAV installation is OUTDATED - please update immediately!
WARNING: Current functionality level = 3, required = 4
Database updated (30736 signatures) from database.clamav.net(129.250.169.81).
Clamd successfully notified about the update.

I have the following clam packages installed:
clamd-0.88-1.1.el3.rf
clamav-db-0.88-1.1.el3.rf
clamav-0.88-1.1.el3.rf
clamav-devel-0.88-1.1.el3.rf

At dag wieers, these are the latest rpm packages i can get.
Also, why it says my versions is 0.80 and need 0.82? Isn't my version 0.88?

confused....and I actually have a carbon copy of a test mail server installed at my lap top, and i have exactly the same rpm clam packages installed there, that server doesn't show this message, it doesn't prompt me to update and runs ok.

Any idea what's wrong? I can't just ignore it because its a production mail server...and the packages is already the latest from dag wieer....what should i do?
please help....thanks for taking time reading my thread...thanks a lot,

Regards
Y
 
Old 04-27-2006, 01:44 AM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
well there are 2 things to be updated

the clamav antivirus definations and the clamav antivirus engine

you have the definations updated not the antivirus engine so u get this warning

regards
 
Old 04-27-2006, 01:52 AM   #3
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi there,

The engine is updated. As i mentioned there, i have the installation with the following packages:

clamd-0.88-1.1.el3.rf
clamav-db-0.88-1.1.el3.rf
clamav-0.88-1.1.el3.rf
clamav-devel-0.88-1.1.el3.rf

which is the latest I can find at dag wieers. And also the error says I have 0.80 installed and need to upgrade to 0.82, doesn't make sense because i have 0.88 not 0.80 installed.

thanks.
 
Old 04-27-2006, 02:14 AM   #4
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Why are you using el3 packages on an FC2 installation?
 
Old 04-27-2006, 02:23 AM   #5
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi,

Sorry, I forgot to mention. FC2 is my personal office computer. The mail server is using rhel3. I use fc2 for my office computer. My company's mail server is running on rhel3. My home laptop for experiementation on mail server is also rhel3.

sorry...

regards
y
 
Old 04-27-2006, 02:50 AM   #6
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Which repositories do you have set up for yum, or if you aren't using yum did you download your old packages from an incompatible repository (eg livna.org, fedora.us)?
 
Old 04-27-2006, 02:56 AM   #7
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi,

Since we first started the mail server, we always use the rpm packages from dag wieers. Never from anywhere else.

I am wondering its showing the wrong message, because my experimental lap top mail server is exactly a carbon copy of the production mail server, it is using exactly the same clam packages i,e 0.88.1, but there is no such error for my lap top. (however there is no throughput for my lap top)......

Thanks for your help,

Regards
Y
 
Old 04-27-2006, 04:02 AM   #8
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
Since you are saying that u have the 0.88.1 version installed then run clamd from the shell and there must be a handle to get the version( maybe -h or --help) and check for yourself that version you are running

regards
 
Old 04-27-2006, 04:08 AM   #9
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi ,

It says 0.88 too.

following shows:

# clamd -V
ClamAV 0.88/1426/Thu Apr 27 02:03:01 2006

Regards
Y
 
Old 04-27-2006, 04:18 AM   #10
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
and version for

clamd ??
 
Old 04-27-2006, 04:35 AM   #11
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi,

The clamd version is clamd-0.88-1.1.el3.rf.

if i do:
# clamd --help

Clam AntiVirus Daemon 0.88
(C) 2002 - 2005 ClamAV Team - http://www.clamav.net/team.html

--help -h Show this help.
--version -V Show version number.
--debug Enable debug mode.
--config-file=FILE -c FILE Read configuration from FILE.


If I do:
# clamd --version
ClamAV 0.88/1426/Thu Apr 27 02:03:01 2006

The package I used for clamd is clamd-0.88-1.1.el3.rf

thanks for your help,

Regards
Y
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
clamav users: virusdbase update help ic_torres Linux - Software 2 01-16-2006 12:07 AM
cannot update clamAV izquierdista Linux - Security 3 06-10-2005 09:34 AM
path in services wrong for clamav updated frm 0.75 to 0.80 usr/bin vs usr/local/bin Emmanuel_uk Linux - Newbie 3 04-22-2005 02:02 AM
firefox always prompting me for update thekowgomoo Mandriva 2 03-23-2005 12:02 AM
ClamAV wont update m3kgt Linux - Software 3 07-19-2004 03:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration