LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-16-2015, 02:28 PM   #1
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 515

Rep: Reputation: 34
Webmin Not Starting on Firefox ESR 38.3


Greeting, Newbie here. (STILL)

I installed Webmin a while ago and haven't use CentOS linux for a while. Tried to started it using the following command in my browser (Firefox) and got the following messages.

Don't know where to go from here to get it working and I sure would appreciate some help here.

Using CentOS 6.7

https://192.168.1.90:10000 ->> command use to start.

Message Firefix returned:

Secure Connection Failed

An error occurred during a connection to 192.168.1.90:10000. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

Thank you for any help.
 
Old 10-16-2015, 03:25 PM   #2
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,453

Rep: Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627
Is webmin running? Open a terminal, and run the command 'ps aux | grep webmin' ( without the quotes ) and post the results. Here is what I see on my Slackware 14.1 system:

Quote:
ps aux | grep webmin
root 1263 0.0 0.7 67936 23276 ? Ss 06:11 0:00 /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
root 6918 0.0 0.7 67928 22500 ? S 15:15 0:00 \_ /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
root 6956 0.0 0.7 67928 22508 ? S 15:15 0:00 \_ /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
root 7124 0.0 0.7 67928 22516 ? S 15:15 0:00 \_ /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
root 7125 0.0 0.7 67928 22516 ? S 15:15 0:00 \_ /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
cliff 7131 0.0 0.0 5088 800 pts/0 S+ 15:15 0:00 | | | \_ grep webmi
If you get just one line, then webmin is not running. I don't use centos, so I can not tell you how to start it. You will have to look at the docs for that.

This is not starting webmin "https://192.168.1.90:10000" you are asking firefox to connect to port 10000 on address 192.168.1.90, once webmin has been started, and it needs to be secured; because of the 's' in https. Webmin can be configured for a secure connection, if it is not, the connection will fail.

The command to start webmin in Slackware is '/etc/rc.d/rc.webmin start'. That will work when the execute bit is set for rc.webmin. Look at your docs for centos to see how to start a background task.
 
Old 10-16-2015, 03:29 PM   #3
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 515

Original Poster
Rep: Reputation: 34
Thanks, I'll get the information requested and post it here.
 
Old 10-16-2015, 09:29 PM   #4
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 515

Original Poster
Rep: Reputation: 34
As requested:

[root@centos hrifkind]# ps aux | grep webmin
root 3412 0.0 0.2 96276 2964 ? Ss 21:04 0:00 /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
root 4781 14.2 2.6 110296 27032 ? S 21:26 0:00 /usr/libexec/webmin/webmincron/webmincron.pl
root 4804 0.0 0.0 103308 904 pts/1 S+ 21:27 0:00 grep webmin
[root@centos hrifkind]# service webmin status
Webmin (pid 3412) is running
 
Old 10-17-2015, 06:23 AM   #5
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,453

Rep: Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627
Quote:
192.168.1.90
Is this running on your system, locally, or is this another system somewhere else?

If it is your local system, what happens if in FF you type in the location bar,

'localhost:10000' ( without the quotes ) ?

If this is another system, somewhere else, can you ping the system form yours?

I re-read your original post. Try to connect with http; not https and see if it connects.

Last edited by camorri; 10-17-2015 at 07:27 AM. Reason: Added information
 
Old 10-17-2015, 07:06 PM   #6
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
"ssl_error_rx_record_too_long" > http://192.168.1.90:10000/
 
Old 10-18-2015, 07:11 AM   #7
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,453

Rep: Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627
Did a little searching, based on the error Habitual pointed out. There are several threads dealing with this error message. I would suggest the OP have look to this one:

-->https://www.suse.com/support/kb/doc.php?id=7012859

There are others that deal with SSL certificates. Since the OP has not give us a lot of information, configuration, is the OP running on a virtual machine etc, It makes sense to ask for more information on the what the OP has configured. That may lead us to a solution.

SSL certificates are beyond my experience. I invite anyone with more knowledge to help.
 
Old 11-11-2015, 08:21 PM   #8
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 515

Original Poster
Rep: Reputation: 34
Greetings:

I apologize for taking so much time in getting back to this thread as I was out of commission for a while.

I have resolved the issue described in this thread using Webmin/Usermin and Firefox.

Below you will find the steps which I used to resolve this problem.

Sometimes there just is too much security in an applications and that goes with current versions of Firefox. However the steps described below will resolve the issue and then you can use Webmin with Firefox:

1. Open a browser which comes along with the destro you are using. Im using CentOS and it comes with the default browser Konqueror.
2. Open Konqueror and enter something like this in the URL address area as an example of course after Webmin/Usermin has been downloaded and installed:
HTTPS://192.168.1.40:10000
3. When Webmin comes up, in the left panel, click Webmin Configuration.
Now move over to the right pane and down to the SSL Configuration icon, click on it. At the top of the page you should see a tab for filing out a Self Signed Certificate. Fill in the details and at the bottom click Create Certificate.


Thats it. The same procedure can be used for Usermin. Restart Firefox and test.

Thanks again for everyones help.
 
Old 11-11-2015, 08:50 PM   #9
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Glad it worked out!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Firefox ESR 24.x support dropped? kfritz Slackware 46 11-10-2014 08:58 AM
Is FireFox ESR working well for you? Zwergele Slackware 28 07-11-2014 08:33 PM
[SOLVED] no firefox 24 esr? Stuferus Mageia 4 09-21-2013 02:52 PM
Firefox ESR on 13.37 won't sync kfritz Slackware 1 06-30-2013 10:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration