Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 11-05-2003, 12:49 PM   #1
LQ Guru
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
VERY annoying bug's / behavior !

hey guys and girls.

i have redhat 9 (2.4.20-8) defaulted to run-level 3.
with startx at the end of my bash_profile.

icewmbg &
exex icewm
in my .xinitrc.

there are 2 VERY annoying bugs i cant get out of linux,
it's always happende on every install.

the first is xlock the thing icewm uses to lock the screen.
it rejects both my user password and root password.

just telling me ive entered an invalid password, (when i have entered the correct pasword) meaning i have to hit the reset switch !!!!!

and secod of all, every now and then, X freeses or whatever and i need to re-start the X server.

so i hit ctrl-alt-del, im taken to a the command line interface (x is shut-down) as expected. then.. my homitor shuts down, my hard disks shut down, and the pc goes into sleep mode !!!

when my monotor is told to shut down, it dsiplays a nitice, "going to power saving mode"
if a accidently move the mouse or hut the keypad dureing this time, the pc comes back to life, but leaves the monitor OFF, i cannot get it back on, meaining i have to hit the RESET button...

this is driving me INSANE.....
and i can find o1 else suffering the same problem.
Old 11-05-2003, 01:06 PM   #2
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
Don't know about xlock, however, why not CTRL=ALT-BACKSPACE instead of 'DEL'. That will just kill X.

You aren't locking the screen as a regular user, then trying to unlock as root are you. If you are, then

-/+allowroot Allows the root password to unlock the server as well as the user who started the xlock command.

You may want to see what options are passed into xlock when started.
Old 11-05-2003, 01:07 PM   #3
Registered: Jun 2003
Location: Long Island, NY
Distribution: Gentoo Unstable (what a misnomer)
Posts: 380

Rep: Reputation: 30
to "zap" X it's ctrl-alt-backspace not del
ctrl-alt-del is the hotkey sequence to REBOOT your computer

I don't use xlock, so for that one I can't help you.
Old 11-05-2003, 01:14 PM   #4
LQ Guru
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
oops, yeah, i meant to say ctrl-alt-backspace... thats what i use, and thats what causing the sleep problem.

i type xlock at console (regular user)

then i hit a key, trpy my regular user password, and it rejects it !


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Annoying Firefox/Laptop touchpad behavior DJOtaku Linux - Laptop and Netbook 8 12-04-2005 02:58 PM
annoying vim behavior pauloco Linux - Software 0 09-27-2005 12:10 PM
annoying behavior with DCHP-discover Burgin Debian 3 02-27-2005 05:42 PM
ls -l behavior vjl323 Mandriva 3 11-05-2003 07:30 AM
Really annoying Bigun Linux - General 6 09-15-2002 05:31 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:48 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration