LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-17-2006, 05:46 PM   #1
Riddick
Member
 
Registered: May 2004
Location: Rome, Italy
Distribution: slackware-current
Posts: 454

Rep: Reputation: 30
Unwanted screen blanking


Dear all,
I have a Toshiba M100 with Slackware 10.2 and KDE 3.5.4.
After a couple of minutes my screen displays a black screen,
although I can still see the cursor - so the screen is not
powered off.

I would like my laptop's display never to be blanked like this
and never to power off.

I have disabled all powersaving in KDE and all screensavers.

What could be causing this?

Thanks,
Riddick
 
Old 08-18-2006, 10:56 AM   #2
soggycornflake
Member
 
Registered: May 2006
Location: England
Distribution: Slackware 10.2, Slamd64
Posts: 249

Rep: Reputation: 31
Try

Code:
xset s off
Chuck it in /etc/X11/xinit/xinitrc.kde (anywhere before the startkde line, of course) to make it permanent.

edit: To be on the safe side, you might also want:

Code:
xset -dpms

Last edited by soggycornflake; 08-18-2006 at 11:05 AM.
 
Old 08-18-2006, 07:48 PM   #3
Riddick
Member
 
Registered: May 2004
Location: Rome, Italy
Distribution: slackware-current
Posts: 454

Original Poster
Rep: Reputation: 30
I THINK that solved it! Thanks very much for your help!
 
Old 08-19-2006, 02:52 PM   #4
Riddick
Member
 
Registered: May 2004
Location: Rome, Italy
Distribution: slackware-current
Posts: 454

Original Poster
Rep: Reputation: 30
errm, well not quite. With a bit more testing the issue seems to have gone until
I lock the screen (which activates the screensaver). Once I unlock the screen,
The behaviour above returns.

Any further ideas?

Riddick
 
Old 08-22-2006, 04:48 PM   #5
soggycornflake
Member
 
Registered: May 2006
Location: England
Distribution: Slackware 10.2, Slamd64
Posts: 249

Rep: Reputation: 31
Hmm, looks like locking the screen is reactivating screen blanking. I don't know if you can disable that directly, but you could always wrap it in a script, i.e.

Code:
#!/bin/sh
xlock # or whatever app you use to lock the screen
xset -s off
xet -dpms
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 12:50 PM
rh 9.0 screen blanking corrupter Linux - General 1 06-04-2003 04:16 PM
RH 9.0 screen blanking corrupter Linux - Distributions 0 06-04-2003 09:11 AM
Screen Blanking/non-X ldieter Linux - General 0 03-11-2002 09:05 PM
Screen Blanking bretthoward Linux - General 7 03-19-2001 05:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration