Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 01-20-2011, 03:58 AM   #1
LQ Newbie
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
Touchpad disable/enable typing.

Hello, i'm relatively new to Ubuntu Linux and in need of some help here.

Due to a poor design on my computer i constantly clip the touchpad as i type resulting in letters going where they shouldn't. I know i can select an option to disable the touchpad while typing, which is great for when i am typing something out, but becomes quite incontinent while attempting to play a game.

What i'd like to do is able to create a small button on the panel to disable/enable this feature. If that isn't possible i was wondering if there was a terminal command to do so. Anyone able to help me out here?
Old 01-20-2011, 04:11 AM   #2
LQ Guru
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello and Welcome to LinuxQuestions,

Glad to have you here and looking forward to your participation.

If you're using the synaptics driver for your touchpad you can use the syndaemon command to disable the touchpad. Another way is to remove the psmouse module (until next reboot). Or if you're like me and always have a mouse connected (wired or wireless), just blacklist the module in /etc/modprobe.d/blacklist.conf with:
blacklist psmouse
The last option is the one I use, since neither disabling while typing, nor the syndaemon worked satisfactory for me. The syndaemon came back on after a while and I got tired disabling again, so I just blacklisted the thing and am a happy laptop user now.

Have fun using Linux.

Kind regards,

Old 01-21-2011, 08:42 AM   #3
LQ Newbie
Registered: Jul 2007
Posts: 10

Rep: Reputation: 1
If you are referring to the Lenovo touchpad found in their new consumer market\home
business line (X series, Thinkpad Edge), the touchpad is not defective. It works fine
in Windows 7 and the problem is the scrolling feature is too sensitive for current Linux
distro drivers. I had forum text boxes disappear, entire phrases jump into different
lines, etc, etc

I found the "disable touchpad when typing" doesn't do the trick for the new touchpad because.
it isn't the problem. I shut off scrolling and that solved the unbearable typing input
problem. My touchpad is still fully functional


Last edited by BruisedQuasar07; 01-21-2011 at 08:50 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Making a hotkey to enable/disable the touchpad - possible? NeXuS_2006 Linux - Software 3 09-05-2010 01:31 PM
Touchpad disable button permanently disables touchpad until reboot William (Dthdealer) Linux - Hardware 12 08-01-2009 10:51 PM
Enable typing in Hebrew on Centos5 kukimuki Linux - Newbie 1 02-08-2009 05:38 AM
Disabling Touchpad while typing. nardz Linux - Desktop 4 01-24-2008 04:33 AM
How to disable touchpad? jimbo Linux - Laptop and Netbook 3 04-04-2004 09:06 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:56 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration