-   Linux - Software (
-   -   Touchpad disable/enable typing. (

zuriel45 01-20-2011 04:58 AM

Touchpad disable/enable typing.
Hello, i'm relatively new to Ubuntu Linux and in need of some help here.

Due to a poor design on my computer i constantly clip the touchpad as i type resulting in letters going where they shouldn't. I know i can select an option to disable the touchpad while typing, which is great for when i am typing something out, but becomes quite incontinent while attempting to play a game.

What i'd like to do is able to create a small button on the panel to disable/enable this feature. If that isn't possible i was wondering if there was a terminal command to do so. Anyone able to help me out here?

EricTRA 01-20-2011 05:11 AM

Hello and Welcome to LinuxQuestions,

Glad to have you here and looking forward to your participation.

If you're using the synaptics driver for your touchpad you can use the syndaemon command to disable the touchpad. Another way is to remove the psmouse module (until next reboot). Or if you're like me and always have a mouse connected (wired or wireless), just blacklist the module in /etc/modprobe.d/blacklist.conf with:

blacklist psmouse
The last option is the one I use, since neither disabling while typing, nor the syndaemon worked satisfactory for me. The syndaemon came back on after a while and I got tired disabling again, so I just blacklisted the thing and am a happy laptop user now.

Have fun using Linux.

Kind regards,


BruisedQuasar07 01-21-2011 09:42 AM

If you are referring to the Lenovo touchpad found in their new consumer market\home
business line (X series, Thinkpad Edge), the touchpad is not defective. It works fine
in Windows 7 and the problem is the scrolling feature is too sensitive for current Linux
distro drivers. I had forum text boxes disappear, entire phrases jump into different
lines, etc, etc

I found the "disable touchpad when typing" doesn't do the trick for the new touchpad because.
it isn't the problem. I shut off scrolling and that solved the unbearable typing input
problem. My touchpad is still fully functional


All times are GMT -5. The time now is 02:11 AM.