LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-10-2016, 01:23 PM   #1
newbiesforever
Senior Member
 
Registered: Apr 2006
Distribution: not disclosing my distro
Posts: 2,303

Rep: Reputation: Disabled
Thunar: turning off auto-open for auto-mount


I want my file manager, Thunar, to auto-mount any drives or media (as it's already doing) but not open a new window. How do I turn off the auto-open without turning off auto-mount? I haven't found any information with an internet search or LQ search yet; all the information I found concerns auto-mounting.

[please see attached screenshot] I can change it with this, can't I?--The auto-open options in the thunar-volman channel in the xfconf settings editor? But I'm playing with the settings, and so far I haven't succeeded in making Thunar stop opening a new window for every auto-mount. I'm not an expert in Boolean logic, but I thought changing the value to "false" would make the auto-open stop. It hasn't. Do I need to log out and in for the change to kick in?

I am eager to solve this, because my laptop has a dongle USB hub with a loose-fitting plug (and, I suspect, at least one failing USB port). Every so often, the system auto-mounts media that are plugged into the hub (possibly because the plug got jostled), and interrupts me with a new Thunar window that I didn't bring up.
Attached Thumbnails
Click image for larger version

Name:	Screenshot.png
Views:	122
Size:	69.1 KB
ID:	21444  

Last edited by newbiesforever; 04-10-2016 at 04:48 PM.
 
Old 04-11-2016, 02:58 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 18,434
Blog Entries: 12

Rep: Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627Reputation: 5627
i don't think you need to use the *conf editor for that.
in thunar's preferences, advanced tab, Configure the management of removable devices => UNcheck "Browse when inserted".
should help?
screenshot
 
Old 04-11-2016, 12:42 PM   #3
newbiesforever
Senior Member
 
Registered: Apr 2006
Distribution: not disclosing my distro
Posts: 2,303

Original Poster
Rep: Reputation: Disabled
Thanks, that solved the problem. I just hadn't found that option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I auto mount SD card with Thunar instead of Shotwell by default in Xfce? linustalman Linux - General 8 06-12-2013 03:23 AM
Thunar, FluxBox & auto mount CopyrightPhilly Linux - Software 1 05-14-2009 02:06 PM
Auto-mount windows share on boot - manual OK, auto not ok! erskie Linux - Newbie 2 02-12-2008 07:42 PM
Turning off Auto Updates GreenJelly Fedora 2 07-16-2007 08:02 PM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 01:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration