LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-15-2014, 02:24 AM   #1
yogesh_attarde
Member
 
Registered: Jan 2010
Posts: 82

Rep: Reputation: 1
Remote Desktop connecting though I am disabling it in CentOS6.4


Hi All,

I am used to connect my Linux machine by enabling "System -> Preferences -> Remote Desktop" on CentOS 6.4 and vncviewer on Windows machine.

But since few days before I found that though I am disabling Remote Desktop on CentOS I am able to connect it with vncviewer from my Windows box.

Does any one face this issue ever.

I am attaching the screen shot of Remote Desktop panel.

Any help will be much appreciated.


Regards,
Yogesh
Attached Thumbnails
Click image for larger version

Name:	Remote_Desktop.png
Views:	55
Size:	37.7 KB
ID:	15501  
 
Old 05-15-2014, 02:37 AM   #2
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware64-15.0
Posts: 6,408

Rep: Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775Reputation: 2775
Remote Desktop uses port 3389 by default while VNC uses ports 5800 and 5900 by default. Disabling the Remote Desktop connection does not disable VNC, as you have observed.
 
Old 05-15-2014, 04:42 AM   #3
yogesh_attarde
Member
 
Registered: Jan 2010
Posts: 82

Original Poster
Rep: Reputation: 1
Thanks Allen,

When I enabled Remote Desktop its not showing port 3389 in use. #netstat -tulpn| grep 3389 gives me no result, but when I do #netstat -tulpn| grep 5900 it gave me below output.

Quote:
[root@support Desktop]# netstat -tulpn| grep 5900
tcp 0 0 :::5900 :::* LISTEN 8899/vino-server
Also When I do grep 3389 /etc/services, I got below output.

Quote:
[root@support Desktop]# grep 3389 /etc/services
ms-wbt-server 3389/tcp # MS WBT Server
ms-wbt-server 3389/udp # MS WBT Server
Could you please clean me on this?


Regards,
Yogesh
 
Old 05-15-2014, 04:52 AM   #4
pan64
LQ Addict
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 22,247

Rep: Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419
you need to stop vnc server to disable vnc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Iptables preventing me from connecting to virtualbox using remote desktop NotionCommotion Linux - Newbie 1 11-22-2013 02:39 AM
Connecting to Puppy Linux 5.4 from Windows remote desktop KentuckyFred Linux - Newbie 1 01-14-2013 03:43 PM
Remote Desktop - Connecting to Linux from Windows XP JamboUK Ubuntu 2 05-17-2006 02:36 PM
Connecting to windows netmeeting remote desktop sharing from linux jacobselvin Linux - Software 5 12-12-2005 03:32 PM
remote desktop connecting (fedora 2) true_atlantis Linux - Software 6 09-28-2004 05:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration