LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-22-2009, 09:33 AM   #1
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
problem updating python2.5


On a routine update on my Debian Squeeze system I get the following:
Quote:
running python rtupdate hooks for python2.5...
file does not exist: /usr/lib/python2.5/site-packages/_spe/plugins/kiki
file does not exist: /usr/lib/python2.5/site-packages/_spe/plugins/wxGlade
pycentral: pycentral updatedefault: error byte-compiling files (221)
pycentral updatedefault: error byte-compiling files (221)
error running python rtupdate hook pycentral
Updating *.pc symlinks for python-gtk2-dev...
dpkg: error processing python (--configure):
subprocess installed post-installation script returned error exit status 4
I see both the kiki and the wxGlade scripts in the folder where rtupdate is looking for them but both files are empty (0 bytes).
Any ideas on how to fix this?
Thanks,
jdk
 
Old 09-24-2009, 06:27 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Problem solved. It turned out that the culprit was Stani's Python Editor (the spe package). I removed the package and it took the other two culprits, kiki and wxGlade with it. Then everything unjammed and all my python packages configured properly and all is well. I can't even remember why I wanted SPE. I don't recall every having used it.
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Python2.5-devel is unable to find installed Python2.5 Setya SUSE / openSUSE 1 06-08-2007 01:35 AM
Can't satisfy wxpython python2.4 dependencies - rpm database problem? mfurnanz Linux - Newbie 3 01-17-2007 03:46 AM
Problem when install Red Had Linux (Fedora core 1); ...python2.2: relocation error... timetldco Linux - Newbie 1 04-19-2006 06:47 AM
Python2.4 sanu Linux - Newbie 1 04-01-2005 07:31 AM
python2.2 is not available? darrylneufeld Fedora 4 06-01-2004 08:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration