LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-09-2010, 03:54 AM   #1
sandhya_it17m
LQ Newbie
 
Registered: Jan 2010
Posts: 13
Blog Entries: 1

Rep: Reputation: 0
Problem installing NS2


i have installed ns2 in centos5
root@localhost ~]# ns
ns: error while loading shared libraries: libotcl.so: cannot open shared object file: No such file or directory

if i do the make install now then
[root@it-sdl019 ns-2.34]# make install
for d in /usr/local/man/man1; do \
if [ ! -d $d ]; then \
mkdir -p $d ;\
fi;\
done
/usr/bin/install -c -m 755 ns /usr/local/bin
/usr/bin/install: cannot stat `ns': No such file or directory
make: *** [install-ns] Error 1
 
Old 01-09-2010, 08:08 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
ns: error while loading shared libraries: libotcl.so: cannot open shared object file: No such file or directory
--- so install the missing library. If the lib is installed, then add the path to it to LD_LIBRARY_PATH.

Last edited by Simon Bridge; 01-09-2010 at 08:09 AM. Reason: speling mistak!
 
Old 01-09-2010, 08:28 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,439

Rep: Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624
Sorry .. browser hickup ..



.....

Last edited by knudfl; 01-09-2010 at 08:44 AM.
 
Old 01-09-2010, 08:28 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,439

Rep: Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624
ns-2.34 or ns-allinone-2.34 : Please verify.
Quote:
I have installed ns2 in centos5
Not yet, it seems. ? ? You may have to run it over one more time
to make sure the executable 'ns' is present in ns-2.34/ ?
Quote:
root@localhost ~]# ns
Please do not do that. 'ns' is to be run as ordinary user !

About ' libotcl.so ' : 1) cd otcl-1.13/
2) ./configure --prefix=/usr/ --enable-shared
3) # make install

Explanation :
'ns' is hard coded to look for libotcl.so in /usr/lib/ only.
.....

Installing 'ns' to /usr/local/bin/ : Perfect, that's the place for 'ns'.
.....

Last edited by knudfl; 01-09-2010 at 08:53 AM.
 
Old 01-10-2010, 10:12 PM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Moved: This thread is more suitable in Linux-Software and has been moved accordingly to help your question get the exposure it deserves.

Also, please title your thread describing the problem. I edited the title so other users can tell whether your thread is something they can help with.
 
Old 01-11-2010, 04:53 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,439

Rep: Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624
Sorry .. the following may not work ( post # 4 ) :
Quote:
2) ./configure --prefix=/usr/ --enable-shared
Please use this instead for otcl-1.13 :

./configure --prefix=/usr --enable-devel --enable-release

.....

Last edited by knudfl; 01-11-2010 at 06:58 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] problem in installing ns2.33 in ubuntu 8.10 neeraj.dwivedi Linux - Newbie 18 09-12-2009 09:00 AM
Problem in installing NS2 in fedora 5 arunram Linux - Software 6 03-14-2009 08:49 AM
Installing NS2 on red hat9 Liz Mwaniki Linux - Newbie 3 01-26-2009 04:21 AM
Problem Installing NS2 in Ubuntu 7.10 smetya Linux - Software 5 04-27-2008 09:27 AM
Encountering problem when installing NS2 on Debian MichaelYoung Debian 1 05-12-2007 08:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration