LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-25-2014, 11:06 PM   #1
marktv88
LQ Newbie
 
Registered: Sep 2014
Posts: 2

Rep: Reputation: Disabled
Perl4 Core Libs Install Help


Hi all. I'm pretty new to linux but I'm using at uni to sequence genomes now and I've come across an issue I can't seem to solve. When I run an assembly pipeline that we use (the A5 assembly pipeline) I get an error message telling me that 'getopts.pl' can't be found in @INC. Now as I understand it that is because that's part of a set of libraries that Perl no longer uses but they can be force installed using CPAN in order to help older scripts work. The only problem is I can't seem to work out how to use CPAN to do this. I've installed CPAN and downloaded the libraries (Perl4-CoreLibs) for CPAN but I need someone to point me in the direction of a guide or similar to help me finally sort this out.

Thanks in advance!

Further details: currently running the latest version of Ubuntu through VirtualBox on a 64 bit system. 3GB RAM assigned to it while it runs but have a total of 8GB RAM if more is needed.
 
Old 09-26-2014, 02:39 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,516

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Welcome to LQ.

May be /usr/share/perl5/ or /usr/share/perl/5.18.2/ aren't in @INC ?
Please try : $ locate getopts.pl

"getopts.pl" is provided by 'perl-modules' and 'libperl4-corelibs-perl' :
$ sudo apt-get install perl-modules libperl4-corelibs-perl

'perl-modules' provides /usr/share/perl/5.14.2/getopts.pl
and 'libperl4-corelibs-perl' provides /usr/share/perl5/getopts.pl

-
 
Old 09-26-2014, 08:22 AM   #3
marktv88
LQ Newbie
 
Registered: Sep 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
That worked a treat! Thank you so much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Deception | Part I. Gnome Core Libs Progress LXer Syndicated Linux News 0 08-28-2012 07:00 PM
how to install libs full sheller Slackware 7 07-18-2010 10:11 PM
link-time libs need to be run0time libs says curl's make install UniquelyAm Linux - Software 0 06-09-2007 01:40 AM
Old libs in Fedora Core 3 Saur2004 Linux - Software 7 02-21-2005 11:36 PM
Updating Core 2 broke denendencies on xorg-libs sdo Fedora 0 07-13-2004 10:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration