LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-02-2004, 11:21 PM   #1
WetWired
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
nVidia Drivers. 2.6 on 10.1


I'm having major problems installing nVidia's latest drivers on Mandrake 10.1 with the 2.6 kernel. When I try to install them, it first complains about not having a precompiled kernel interface installed... I assume that means it wants me to install the kernel-source package, so I did. Still got the same error, even specifying the location of it. Next, it complains about the rivafb module being used with my kernel, and how it conflicts with the nVidia drivers.

It then tries to build the driver, and fails. That's about as far as I get. Has anyone else been having this problem? If so, how did you fix it?
 
Old 11-02-2004, 11:56 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,981

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
This is well known problem and there is an excellent tutorial giving the solution on this website that says it a lot better than I can:

http://ariejan.net/content/view/85/32/
 
Old 11-03-2004, 12:30 AM   #3
WetWired
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the reply, but that still doesn't help my problem of it not being able to detect that I have installed kernel-source-2.6.
 
Old 11-03-2004, 05:09 AM   #4
Mito_Mandrake
LQ Newbie
 
Registered: Nov 2004
Distribution: Mandrake 10
Posts: 2

Rep: Reputation: 0
Hi,

If you have a look around there are two problems. One requires changing the code as mentioned in that tutorial. The other one is just to follow what I posted at www.linuxquestions.org/questions/history/232459 . This is the second common problem, and is quite easy to fix. Hope this helps.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing nvidia drivers from nvidia website on mepis 3.3 xbennyboy Linux - Hardware 4 04-23-2005 10:19 AM
Proprietary nvidia drivers vs. generic intel sound and ethernet drivers vharishankar Linux - Hardware 2 02-22-2005 06:32 AM
Nvidia Drivers Graphics and motherboard drivers help sithyoda Linux - Newbie 4 10-01-2004 07:32 PM
mandrake 10 nvidia drivers and winmodem drivers mikeymouse Mandriva 6 08-28-2004 08:57 AM
nvidia drivers / nv vs nvidia & TNT2 trekk Fedora 0 01-26-2004 02:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration