LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-31-2013, 03:23 AM   #1
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,191

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
No quotes or accented characters in LibreOffice


I have installed Wheezy and dist-upgraded when Wheezy was released. The packages libreoffice and libreoffice-kde are installed.

Libreoffice is version 3.5.4.2 Build ID: 350m1(Build:2)
KDE is version 4.8.4

I have installed a English keyboard on KDE System Settings. Layout is US English with dead keys.

I cannot create accented characters like "" in LibreOffice. Neither can I write the dead key itself like " (double quote) while pressing shift-quote space. Nothing appears in the document.

In various other applications, I can write both accented characters and the dead keys themselves. Icedove, Kwrite, web browsers (like this post) produce them correctly.

Bash shell in Konsole produces dead keys, but not accented characters. Vi in a console produces dead keys and accented characters. Which is according to expectation.

I can copy/paste the quotes and accented characters in LibreOffice, so it is not a font problem.

Am I missing something, or is this a bug? Unfortunately googling yields a zillions hit on how it should work.

jlinkels
 
Old 07-31-2013, 03:51 AM   #2
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 343Reputation: 343Reputation: 343Reputation: 343
Hi there,

Quote:
Originally Posted by jlinkels View Post
I have installed Wheezy and dist-upgraded when Wheezy was released. The packages libreoffice and libreoffice-kde are installed.

Libreoffice is version 3.5.4.2 Build ID: 350m1(Build:2)
KDE is version 4.8.4

I have installed a English keyboard on KDE System Settings. Layout is US English with dead keys.

I cannot create accented characters like "" in LibreOffice. Neither can I write the dead key itself like " (double quote) while pressing shift-quote space. Nothing appears in the document.

In various other applications, I can write both accented characters and the dead keys themselves. Icedove, Kwrite, web browsers (like this post) produce them correctly.
as the effect seems to be tied to LibreOffice, my first strike would be at LibreOffice's settings.
I found one thing that might have to do with keyboard settings as well: Go to Tools/Options/Language Settings/Language in LibreOffice. Check if Locale Setting is set to "Default".

Quote:
Originally Posted by jlinkels View Post
Bash shell in Konsole produces dead keys, but not accented characters. Vi in a console produces dead keys and accented characters. Which is according to expectation.
The shortcoming in bash isn't according to my expectation, because I'm used to having dead keys and accented letters available there. However, this is not KDE, but Gnome/MATE. But keyboard handling is in fact a bit special in the console. For instance, on my system, the usual "paste" shortcut (Shift-Ins) doesn't reliably paste the clipboard contents, but sometimes an apparently random text fragment.

Quote:
Originally Posted by jlinkels View Post
I can copy/paste the quotes and accented characters in LibreOffice, so it is not a font problem.
Good point, but that's exactly what I'd expected. Indeed, it doesn't seem to be a font problem, but rather a keyboard problem. And an application-specific one at that.

Hope the LibreOffice settings can get you anywhere.

[X] Doc CPU
 
Old 07-31-2013, 09:46 AM   #3
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,191

Original Poster
Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
No, it doesn't help.

What I tried so far:
  • Threw away the .kde directory and recreated
  • Threw away the .config/libreoffice directory and recreated
  • Created a new user and logged in as this user
  • Uninstalled and purged LibreOffice and reinstalled
  • Installed LXDE and set keyboard type thru setxkbmap
  • Installed Linux Mint 14 Debian version and ran in VBox
  • Installed Debian 7.0 Live KDE version VBox
Only the last 2 attempts produced a LibreOffice with correct dead keys. Without any additional configuration except for setting the keyboard to US Intl. The LibreOffice version and build is identical to mine.

I cannot draw any other conclusion than that some bug has been left behind from the testing phase when I initially installed the machine. That leaves pretty much no choice as a fresh installation, isn't it? Yikes, just like Windows: the system so complicated and closed that one best starts from scratch.

jlinkels

Last edited by jlinkels; 07-31-2013 at 09:54 AM.
 
Old 07-31-2013, 11:20 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
A number of points:
1. You version is a bit old. Can you try the current version: 4.0.4.2?
2. Can you insert an accented character using the "Special Character..." item found in the "Insert" menu? In the Latin Extended-A subsection you can try lots of accented characters.
3. What font are you using? Try Dejavu Serif which has a full range of characters of every sort.
jdk
 
Old 07-31-2013, 12:55 PM   #5
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 343Reputation: 343Reputation: 343Reputation: 343
Hi there,

Quote:
Originally Posted by jdkaye View Post
1. You version is a bit old. Can you try the current version: 4.0.4.2?
depending on what distro you're using, LibreOffice 3.5.x may not be old at all. The distro I'm currently using (Mint 13) still has 3.5.7 as the currently recommend version in its repository, and Mint 12 even features LibreOffice 3.4.4 as its "current" version.

Quote:
Originally Posted by jdkaye View Post
2. Can you insert an accented character using the "Special Character..." item found in the "Insert" menu? In the Latin Extended-A subsection you can try lots of accented characters.
3. What font are you using? Try Dejavu Serif which has a full range of characters of every sort.
If you don't mind looking a few posts up again, you'll see that jlinkels said he/she could paste text containing these letters into a LibreOffice document and it displays correctly. That renders your question 3. irrelevant, and implies the answer "yes" to your question 2.

[X] Doc CPU
 
Old 07-31-2013, 02:02 PM   #6
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,191

Original Poster
Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
Quote:
Originally Posted by jdkaye View Post
A number of points:
1. You version is a bit old. Can you try the current version: 4.0.4.2?
I have considered that. There exists a Debian package. Not sure what dependencies that triggers. I might try just before reinstall.
Quote:
Originally Posted by jdkaye View Post
2. Can you insert an accented character using the "Special Character..." item found in the "Insert" menu? In the Latin Extended-A subsection you can try lots of accented characters.
Yes I can.
Quote:
Originally Posted by jdkaye View Post
3. What font are you using? Try Dejavu Serif which has a full range of characters of every sort.
jdk
I tried various fonts including Dejavu.

By trying various live distros, including Debian 7, I have the feeling it is not in Office, or I should say not just in Office, but a combination of Office and something else unknown.

jlinkels
 
Old 07-31-2013, 10:10 PM   #7
timl
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Fedora,CentOS
Posts: 683

Rep: Reputation: 151Reputation: 151
Quote:
I cannot create accented characters like "" in LibreOffice
Quote:
Quote:
Originally Posted by jdkaye View Post
2. Can you insert an accented character using the "Special Character..." item found in the "Insert" menu? In the Latin Extended-A subsection you can try lots of accented characters.
Yes I can.
Does "create" not equal "insert"
 
Old 08-01-2013, 01:05 AM   #8
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by Doc CPU View Post
Hi there,
depending on what distro you're using, LibreOffice 3.5.x may not be old at all. The distro I'm currently using (Mint 13) still has 3.5.7 as the currently recommend version in its repository, and Mint 12 even features LibreOffice 3.4.4 as its "current" version.
Hmm. Different system. I get reminders from Libreoffice itself when I open my copy and there's a notice telling me to "click here" to update my Libreoffice.



Code:
If you don't mind looking a few posts up again, you'll see that jlinkels said he/she could paste text containing these letters into a LibreOffice document and it displays correctly.
I'm afraid I'll have to disagree with you on this one. Perhaps you're not terribly familiar with Libreoffice because using the "Insert Special Character" function" does not involve cutting and pasting, possibly from a different document, at least not on the part of the user. The procedure is entirely internal to Libreoffice and terminates with the user clicking the OK button which then inserts the selected character or characters into the current document. This may or may not be identical to the ctl-c/ctl-v copying and pasting procedure which would mean if one were possible then the other would be as a logical necessity. I have not looked at LO's source code so I don't know how the "Insert Special Character" function works. It does allow you to compose characters consisting of "Combining Diacritical Marks". I was not aware that the ctl-c/ctl-v operation had this function.
Quote:
[]That renders your question 3. irrelevant, and implies the answer "yes" to your question 2.
As you can see your claim is far from obvious. Often the solution to a given problem involves the "leaving no stone unturned".

Thank you for your attention.
jdk

Last edited by jdkaye; 08-01-2013 at 01:07 AM.
 
Old 08-01-2013, 01:43 AM   #9
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Can you post the output of the locale command that you entered in a terminal.
jdk
 
Old 08-01-2013, 04:09 AM   #10
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 343Reputation: 343Reputation: 343Reputation: 343
Hi there,

Quote:
Originally Posted by jdkaye View Post
I get reminders from Libreoffice itself when I open my copy and there's a notice telling me to "click here" to update my Libreoffice.
I know that from the Windows version of LibreOffice. However, under Linux I leave all updating to the system's central update manager. I'm very much into system stability, and that's why I rely on what versions the maintainers of a distro see fit for their distro. In years of using Windows, I've seen too often that upgrading to or installing the most recent version of a software bears the risk of breaking the system. That's why I'd rather rely on configurations that have been tested and found trouble-free.

Quote:
Originally Posted by jdkaye View Post
I'm afraid I'll have to disagree with you on this one. Perhaps you're not terribly familiar with Libreoffice because using the "Insert Special Character" function" does not involve cutting and pasting
In fact, I simply misunderstood that suggestion of yours. I read it very cursory and thought of opening the character map, selecting certain characters from there and copy/paste them into the document, because that's the way I do it. I know the Insert/Special Character feature, but always use the character map as a separate application. For me, it seems friendlier and has more information.

Quote:
Originally Posted by jdkaye View Post
I have not looked at LO's source code so I don't know how the "Insert Special Character" function works. It does allow you to compose characters consisting of "Combining Diacritical Marks".
Then this feature is well-hidden. I can't see or figure out how that is supposed to work. I've only got the matrix of characters, two dropown lists for font and Unicode subrange, and four buttons labeled "OK", "Cancel", Help and "Delete". I couldn't imagine at first what the Delete button is supposed to do, but I found it out by playing and trying. Help doesn't mention anything about combining, either.

Quote:
Originally Posted by jdkaye View Post
As you can see your claim is far from obvious. Often the solution to a given problem involves the "leaving no stone unturned".
We were assuming different things. Apart from that, I agree.
I still keep up my claim about the font, though. If LibreOffice can display a character, it's not a font issue. Whether it composes a character from its basic building block and a combining diacritic mark, or uses the correspondig single-code character - this must not affect the way the character is rendered on the screen.

[X] Doc CPU

Last edited by Doc CPU; 08-01-2013 at 04:42 PM.
 
Old 08-02-2013, 12:39 AM   #11
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
I'm glad to see our views converging. Now what about that pesky problem raised by the OP? I'd still like to see his/her locale settings. I'm curious if they contain the UTF-8 versions. Here are mine:
Code:
:~$ locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME=it_IT.UTF8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
I have 4 keyboard layouts installed: British English, Spanish, Italian and Slovenian (useful for ć, č, š, etc.). If I am typing in non-English it's handy to use one or the other of those layouts.

@OP Can you show us the output of the "locale" command? Have you tried using a different keyboard layout (you can easily switch back and forth between different layouts).
Ciao,
jdk (not java)

Last edited by jdkaye; 08-02-2013 at 12:42 AM.
 
1 members found this post helpful.
Old 08-02-2013, 09:17 AM   #12
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,191

Original Poster
Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
Locale showed POSIX for all LC_*.

Setting locale to "en_US.UTF8" in /etc/default and rebooting solved the problem.

No idea as why the default locale was set to POSIX. I should have checked on that of course.

Too bad one never knows which applications act in which way to certain locale and regional settings. LibreOffice was unique in this aspect as far as I know. And then, I really don't see a relationship between keyboard input of a US-intl keyboard and a locale on the application level. If I send a "'+a" to the application I expect it is shown as because the keyboard driver dictates that.

Thanks all who contributed to the discussion.

jlinkels

Last edited by jlinkels; 08-02-2013 at 09:22 AM.
 
Old 08-02-2013, 09:27 AM   #13
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
First off, you're quite welcome. Secondly, have fun!
ciao,
jdk
 
Old 02-24-2016, 02:55 PM   #14
frenezulo
LQ Newbie
 
Registered: Aug 2010
Posts: 3

Rep: Reputation: 0
An additional note about LANG setting for LibreOffice

Hi,

I know this thread is a bit old, but I just wanted to add in a summary of what I found by debugging this exact problem on my Debian system. As a note, my system language defaults to eo.UTF-8 and I use a Canadian Multilingual keyboard layout.

If you start LibreOffice from the command line, like this:
Code:
~$ libreoffice
and you get a result similar to this:
Code:
I18N: X Window System doesn't support locale "eo.UTF-8"
(or whatever locale)
then LibreOffice is guaranteed to experience deadkey issues.

The solution is to set your LANG value to any UTF-8 locale that is supported by Xlib. In my case, setting my locale to fr_CA.UTF-8 or en_CA.UTF-8.

Unfortunately, I have to do this every time I start LibreOffice, but I can fix it by creating a wrapper script around /usr/lib/libreoffice/program/soffice. Unfortunately, I have no idea whether a future update of LibreOffice will clobber my fix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
accented characters rendered as Cyrillic jdkaye Linux - Software 2 12-15-2012 01:58 AM
captioning of accented characters vientito Linux - Software 4 03-14-2011 03:39 PM
[SOLVED] Accented characters in a minimal desktop? agi93 Slackware 7 04-13-2010 07:41 PM
Quanta accented characters spaniard Linux - Software 4 11-04-2005 01:08 AM
Accented characters in C Orkie Programming 2 05-17-2005 01:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration