LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-19-2009, 03:54 PM   #1
okorkie
Member
 
Registered: Mar 2007
Posts: 47

Rep: Reputation: 0
Libdnet error message


Hello, I have just installed tcpreplay on our server (centos 5) and when I try to replay a pcap or cap file (Wireshark) I receive the following error message.

tcpreplay: error while loading shared libraries: libdnet.1: cannot open shared object file: No such file or directory

When I check to see if libdnet is installed, here is what I get:

rpm -qa | grep libdnet
libdnet-1.11-1.2.el5.rf

I have no idea how to correct this, or what the problem is after searching online for help.

Thanks in advance

Last edited by okorkie; 03-19-2009 at 03:58 PM. Reason: Incorrect title
 
Old 03-20-2009, 08:10 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Quote:
libdnet.1
If this is, what 'tcpreplay' is really asking for, it is a bug
in the 'tcpreplay' ( script or executable.)

You can either fix it, or do 'cd /usr/lib/' , 'su' ,
# 'ln -s libdnet.so.1 libdnet.1'
.....

Last edited by knudfl; 03-20-2009 at 08:59 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MPlayer Error Message - Error Opening/Initializing Video Out Device Harpo Linux - Newbie 12 12-29-2009 11:26 PM
Strange Repeating Error message in /var/log/message lucktsm Linux - Security 2 10-27-2006 08:29 AM
Error message received from system Error while reading filter description for true Steel_J Linux - Software 2 03-04-2006 06:10 PM
QMAIL error:554 Transaction failed: message format error mpk25 Linux - Software 1 10-15-2004 12:53 PM
tcpreplay help: raynet11 Linux - Networking 0 05-14-2004 09:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration