LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-14-2008, 02:07 AM   #1
leupi
Member
 
Registered: Mar 2004
Location: Annapolis, Maryland, USA
Distribution: Ubuntu 11.04, Mint 11.11, Xubuntu 11.11
Posts: 458

Rep: Reputation: 30
Keep losing keyboard in GIMP


I am having a rather strange problem with GIMP. Every so often I lose the ability to use my keyboard with GIMP. It works fine with every other application that I have, OpenOffice, gedit, etc, it is just in GIMP that I cannot type anything; I have to shut GIMP down and restart it, I might have the keyboard for an hour, or maybe just 2 mins, it varies. I have uninstalled and reinstalled GIMP but the issue has not been resolved. I have a Dell D600 laptop running Ubuntu 7.10. Any thoughts as to what the issue may be? This is really making GIMP hard to use...

Thanks,
Todd
 
Old 01-14-2008, 08:43 AM   #2
hansalfredche
Member
 
Registered: Jun 2005
Posts: 445

Rep: Reputation: 31
Maybe delete the hidden .gimp folder containing your user settings in your home directory? All your custom settings will be lost.
 
Old 01-14-2008, 01:05 PM   #3
leupi
Member
 
Registered: Mar 2004
Location: Annapolis, Maryland, USA
Distribution: Ubuntu 11.04, Mint 11.11, Xubuntu 11.11
Posts: 458

Original Poster
Rep: Reputation: 30
I gave that a shot, unfortunately, it did not do the trick. I am still losing the keyboard every so often. It is making Gimp almost unusable. I am having some other issues as well, not sure if it is me doing something wrong ( I am not very experienced with graphics software ) or if it is something else. Gimp is the only application that I am having the keyboard issue with; I think that it is a safe bet to assume that that one is not 'user error'. I would hate to have to reinstall Ubuntu just for the Gimp issue, but I am not sure what else to try. I appreciate the suggestion though.

Thanks,
Todd
 
Old 09-11-2014, 03:06 PM   #4
hehe2
LQ Newbie
 
Registered: Sep 2014
Posts: 3

Rep: Reputation: Disabled
Question

Hi, I have the same exact problem and I find it really cumbersome...

Hopefully, I use to save everything really often so I can close / re-open and I'm using a SSD so it's not that long to be up and working again but it's so frustrating...

It happens mostly when I want to rename layers, most of the time it will lose the keyboard input for this specific task or any other new window one where it's required to enter some text. I still can "alt-f" to select any menu from an already opened window... that's sooo weird... sometimes, if I really need to save something with a given name (not the default name) I have to "touch myfile.png" for example then using the mouse only find this file and overwrite it...

What a damned bug ! How comes there's not any fix yet ???

I'm running Kubuntu 14.04 with standard repository (I might have some specific ones but nothing special there...).

It's also happening on my laptop running lubuntu 14.04 too :'(

So I guess this REALLY is a GIMP bug (I never had this bug using Blender which I use *a lot* for video editting...)

Regards
 
Old 09-11-2014, 03:45 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,455

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
I would say it is a Ubuntu issue and not a gimp one


how did you install gimp?
as in is it the default installed version or one you built
 
Old 09-11-2014, 06:59 PM   #6
hehe2
LQ Newbie
 
Registered: Sep 2014
Posts: 3

Rep: Reputation: Disabled
The one from the Ubuntu default repository.

I could try to build it from the sources but I guess that will take time...
 
Old 10-01-2014, 06:31 AM   #7
hehe2
LQ Newbie
 
Registered: Sep 2014
Posts: 3

Rep: Reputation: Disabled
Lightbulb

Hi, I found at least a workaround to this issue !

I noticed I had the small "iBus" icon in my taskbar (to switch keyboard region mapping).

Well, next time I had an issue in gimp (well, the 100% way of having it is just by renaming a layer and selecting it's name and use CTRL+C, it will lock any other layer renaming possibility, the keyboard won't work in gimp anymore in new text boxes, but you'll still be able to alt-letter the menus... so weird).

Just either kill ibus (right click on the icon then quit) => you won't be able to use some french characters like but it will work in gimp

OR you also can right click in the gimp text box and select the input style and choose X11 (you won't have any special character access anymore).

The other workaround is to NEVER use CTRL+C in a text box in gimp, but that kinda sux...

And you also can restart gimp but that's a pain in the ass...

I think gimp developers should fix this issue because there must be some incompatibility between ibus and gimp.

Regards

---------- Post added 2014-10-01 at 12:32 ----------

Hi, I found at least a workaround to this issue !

I noticed I had the small "iBus" icon in my taskbar (to switch keyboard region mapping).

Well, next time I had an issue in gimp (well, the 100% way of having it is just by renaming a layer and selecting it's name and use CTRL+C, it will lock any other layer renaming possibility, the keyboard won't work in gimp anymore in new text boxes, but you'll still be able to alt-letter the menus... so weird).

Just either kill ibus (right click on the icon then quit) => you won't be able to use some french characters like but it will work in gimp

OR you also can right click in the gimp text box and select the input style and choose X11 (you won't have any special character access anymore).

The other workaround is to NEVER use CTRL+C in a text box in gimp, but that kinda sux...

And you also can restart gimp but that's a pain in the ass...

I think gimp developers should fix this issue because there must be some incompatibility between ibus and gimp.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Bring Out the GIMP Part 1: GIMP Basics LXer Syndicated Linux News 0 06-30-2007 06:16 PM
printing on HP PhotoSmart from Gimp 2.2, gimp-print drivers needed? pearman Debian 2 08-05-2005 05:19 AM
gimp / gutenprint prob: gimp does not print bitpicker Linux - Software 0 04-08-2005 08:38 AM
gimp 2 freezes keyboard tardigrade Linux - Software 0 11-10-2004 02:22 PM
Can I load GIMP in english ? (only gimp) Dark Carnival Linux - Software 4 09-17-2003 06:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration