LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-05-2005, 02:16 AM   #1
Dralnu
Member
 
Registered: Jul 2005
Posts: 335

Rep: Reputation: Disabled
Post KDE start-up errors


I have a few small errors when KDE starts up:


X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: SuSE Linux [ELF] SuSE
Current Operating System: Linux linux 2.6.11.4-21.9-default #1 Fri Aug 19 11:58:59 UTC 2005 i686
Build Date: 22 March 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 5 01:06:23 2005
(==) Using config file: "/etc/X11/xorg.conf"
(WW) I810(0): Failed to set up write-combining range (0xe0000000,0x8000000)
Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!
/etc/X11/xim: Checking wether an input method should be started.
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
xset: bad font path element (#63), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
startkde: Starting up...
kbuildsycoca running...
kdecore (KLibLoader): WARNING: KLibrary: /opt/kde3/lib/kde3/kcm_kdnssd.so: undefined symbol: init_kdnssd
SetClientVersion: 0 8
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/ide_1_0
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/computer
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 1205 : Error sending msg: No property volume.disc.has_audio on device with id /org/freedesktop/Hal/devices/block_3_3
libhal.c 1205 : Error sending msg: No property volume.disc.has_audio on device with id /org/freedesktop/Hal/devices/block_3_5
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/ide_0_0
ALSA lib confmisc.c:560snd_determine_driver) could not open control for card 0
ALSA lib conf.c:3479_snd_config_evaluate) function snd_func_card_driver returned error: Permission denied
ALSA lib confmisc.c:392snd_func_concat) error evaluating strings
ALSA lib conf.c:3479_snd_config_evaluate) function snd_func_concat returned error: Permission denied
ALSA lib confmisc.c:955snd_func_refer) error evaluating name
ALSA lib conf.c:3479_snd_config_evaluate) function snd_func_refer returned error: Permission denied
ALSA lib conf.c:3948snd_config_expand) Evaluate error: Permission denied
ALSA lib pcm.c:2090snd_pcm_open_noupdate) Unknown PCM default

** (nautilus:5639): WARNING **: destroyed file still being monitored

** (nautilus:5639): WARNING **: destroyed file still being monitored

** (nautilus:5639): WARNING **: destroyed file still being monitored

** (nautilus:5639): WARNING **: destroyed file still being monitored
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x1c00005
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x1c00005
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x1e0008c
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x1e0008c
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x2000011
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x2000011
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x1800005
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x1800005
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x2200005
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x2200005
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x24000dc
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x24000dc
ksmserver: WARNING: SmsDie timeout, client (10e4696e75000112590400100000056180013)
startkde: Shutting down...
klauncher: Exiting on signal 1
KWrited - Listening on Device /dev/pts/0
startkde: Running shutdown scripts...
startkde: Done.
soffice.bin: Fatal IO error: client killed

waiting for X server to shut down


That is the file that was created via [I]startx > text_start_kde[I]

To me, this is like stairing into the human brain. Anyone know how to fix some of the errors in there?
 
Old 09-29-2005, 07:58 AM   #2
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Rep: Reputation: 15
I know how to fix some of them

They are manyyyyyyyyy errs.

two of the font dirs are empty , check them !:

Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!

That's why it removes them every time.

in the cfg file /etc/X11/xorg.conf you have to comment them.

About the other errs i don't know.

Your problem with xset:
----------------------------------------------------------
xset: bad font path element (#63), possible causes are: |
Directory does not exist or has wrong permissions |
Directory missing fonts.dir |
-----------------------------------------------------------

I have also a problem with xset but it is #58:

xset: bad font path element (#58), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax

*****************************************
If everyone have idea and could help us , please write here.
 
Old 09-29-2005, 09:59 AM   #3
otchie1
Registered User
 
Registered: Apr 2004
Posts: 560

Rep: Reputation: 30
you have a permissions problem within alsa.

There is a chmod step included in all ALSA instructions...you'll have to look it up though as I can't remember what it is that needs to be changed

You also have no inputs defined (no keyboard or mouse set up).

Maybe just delete your /etc/X11/xorg.conf and start again with a xorgconfig using vesa...at least it'll start.
 
Old 09-30-2005, 05:07 AM   #4
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Rep: Reputation: 15
Yes

He obviously have problems with ALSA, but what is my problem ? I don't think the problem is in KDE, that's why i tryed Xorg 6.8.1 && 6.7.0 but the problem remans. I Also tried XFree86 but it is incompatible with KDE 3.4.2 and KDE don't connects to the xserver.

I am wandering what to edit in my xorg.conf to work my touchpad scroll.
Here are some lines from my xorg.conf:

# Option "Device" "/dev/mouse"
Option "Device" "/dev/psaux"
# Option "Device" "/dev/ttyS0"
# Option "Device" "/dev/ttyS1"

Option "Protocol" "imps/2"

Option "ZAxisMapping" "4 5"


That's are lines manually written by me as it is said in a manual.

Thnx
 
Old 09-30-2005, 05:14 PM   #5
otchie1
Registered User
 
Registered: Apr 2004
Posts: 560

Rep: Reputation: 30
Code:
option "buttons" "5"
may help you but it might be that IMPS call...my non-scroll laptop touch pad is IMPS but I dual run a USB scroll mouse so it's no bother. Is it really IMPS2 complaint in all rspects? Try a few other protocols and see what happens.
 
Old 10-01-2005, 05:15 AM   #6
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Rep: Reputation: 15
Talking Aha

I have installed the synaptics driver pack & ksynaptics lib from linuxpackages.net

And edit again the xorg.conf i make it to run the synaptics module and wrote all the options & params and everthing is ok now

When i want to reconfigure the params of the touchpad i run # kcmshell ksynaptics and the library - ksynaptics loads as stand alone program and i edit my settings like sensitivity and so on
 
Old 10-02-2005, 06:51 PM   #7
otchie1
Registered User
 
Registered: Apr 2004
Posts: 560

Rep: Reputation: 30
lol...kinda figured you were running the module for your hardware already lol.

Congrats & thanks for your solution.
 
Old 10-09-2005, 06:42 AM   #8
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Rep: Reputation: 15
Cool I have figured it out a long time ago

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
some errors when start Acrobat Reader 7.0 numen Linux - Software 1 12-02-2005 01:40 AM
can not start eclipse many errors GhostBox Linux - Software 3 11-03-2005 01:59 PM
kde and gnome: how to start both without errors punt Linux - Software 7 07-31-2005 10:22 PM
KDE 3.3 fails to start (libstdc++.so.6 errors) JimDog Linux - Software 6 10-15-2004 05:44 PM
Cannot start X, inet6 errors and more, please help! DiZASTiX Linux - General 2 07-22-2004 10:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration