LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-01-2005, 05:54 AM   #1
edison
LQ Newbie
 
Registered: Feb 2005
Posts: 7

Rep: Reputation: 0
installing mplayer in Slackware 10


Hi folks,

I have installed slackware 10.0 but I haven't installed anything related to X, KDE or GNOME (including GTK and QT). And I want to install mplayer, but it prompted the following during compilation.
make[1]: *** No rle to make target `vf_hue.o`, needed by `libmpcodecs.a`. Stop.

How can I get this `vf_hue.o`, do I need to recompile my kernel or make some of the modules?

Thx,
Ed
 
Old 03-01-2005, 12:14 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
May I ask two things?

1 - Why would you need to install mplayer without anything related to X?. You won't be able to play videos, you know . However, if it's to play mp3's, install mpg123 or mpg321, or some of the command line players. I'm sure Slackware has one of those packages ready to install and use.

2 - What does ./configure say when you try to compile mplayer? The ./configure errors are the good ones, so we know exactly which packages your are missing

Regards!
 
Old 03-01-2005, 01:52 PM   #3
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,535

Rep: Reputation: 100Reputation: 100
As far as I know you can't do that - MPlayer absolutely HAS to have X and related libraries available, as well as the GTK libraries. It should stop already somewhere in the configure phase and complain that it misses a library.

You have got to install X and all development libraries as well as GTK in order to compile MPlayer.
 
Old 03-01-2005, 02:03 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 255Reputation: 255Reputation: 255
Actually mplayer does require the development libraries in the X packages and such but it is possible to have mplayer play and run on the console using framebuffering without ever running or starting X.
 
Old 03-01-2005, 08:10 PM   #5
edison
LQ Newbie
 
Registered: Feb 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Hi all,

I have read mplayer site and I found it is great that it can play mpeg in console mode with framebuffer. This is very good to me as I have a very limited space. Refer to the build process, I have no exception during ./configure and I can start building mplayer. However in the middle, error prompted saying vf_hue.o missing. I wonder what option will enable me to build vf_hue.o.

p.s. During the installation of slackware 10, I have installed all lib.
Below is my config.mak

Thx

# -------- Generated by configure -----------

LANG = C
MAN_LANG = en
TARGET_OS = Linux
DESTDIR =
prefix = $(DESTDIR)/usr/local
BINDIR = $(DESTDIR)/usr/local/bin
DATADIR = $(DESTDIR)/usr/local/share/mplayer
MANDIR = $(DESTDIR)/usr/local/man
CONFDIR = $(DESTDIR)/usr/local/etc/mplayer
LIBDIR = $(DESTDIR)/usr/local/lib
#AR = ar
CC = cc
HOST_CC = cc
AWK = gawk
RANLIB = true
INSTALL = install
# OPTFLAGS = -O4 -march=pentium4 -mcpu=pentium4 -pipe -fomit-frame-pointer -ffast-math
EXTRA_INC =
OPTFLAGS = -I../libvo -I../../libvo -fno-PIC -O4 -march=pentium4 -mcpu=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 $(EXTRA_INC)
STRIPBINARIES = yes
HELP_FILE = help/help_mp-en.h

PRG = mplayer
PRG_MENCODER = mencoder



MPLAYER_NETWORK = yes
STREAMING_LIVE_DOT_COM = no
MPLAYER_NETWORK_LIB = -lnsl
DVBIN = no
VIDIX = yes
SHARED_PP = no
CONFIG_PP = yes
CONFIG_RISKY = yes
CONFIG_MP3LAME = no
LIBMENU = no
I18NLIBS =
MATROSKA = yes

OPENDIVX = no

MP3LIB = yes
LIBA52 = yes
LIBMPEG2 = yes

UNRARLIB = yes
HAVE_FFPOSTPROCESS = yes
PNG = yes
JPEG = yes
GIF = yes

EXTRA_LIB =
Z_LIB = -lz
HAVE_MLIB = no
WIN32_LIB =
STATIC_LIB =
ENCA_LIB =
HAVE_PTHREADS = yes
MATH_LIB = -lm

X11_INC =
X11DIR =

HAVE_XVMC_ACCEL = no

# for libavcodec:
SRC_PATH=..
LIBPREF=lib
LIBSUF=.a
SLIBPREF=lib
SLIBSUF=.so

# video output
X_LIB = -lnsl
GGI_LIB =
MLIB_LIB =
MLIB_INC =
DXR2_INC =
DVB_INC =
PNG_LIB = -lpng -lz
JPEG_LIB = -ljpeg
GIF_LIB = -lungif
SDL_LIB =
SVGA_LIB = -lvgagl -lvga -lm
AA_LIB =
CACA_INC =
CACA_LIB =

# audio output
ALSA_LIB = -lasound -ldl -lpthread
NAS_LIB =
ARTS_LIB =
ARTS_INC =
ESD_LIB = -L/usr/lib -lesd -laudiofile -lm -lasound
ESD_INC =
POLYP_LIB =
POLYP_INC =
JACK_LIB =
JACK_INC =
SGIAUDIO_LIB =

# input/demuxer/codecs
TERMCAP_LIB = -ltermcap
LIRC_LIB =
LIRCC_LIB =
DVDREAD_LIB = -Llibmpdvdkit2 -lmpdvdkit
DVDKIT = no
DVDKIT2 = yes
DVDKIT_SHARED = no
SDL_INC =
W32_DEP =
W32_LIB =
DS_DEP =
DS_LIB =
AV_DEP = libavcodec/libavcodec.a libavformat/libavformat.a
AV_LIB = libavcodec/libavcodec.a libavformat/libavformat.a
CONFIG_LIBAVFORMAT = yes
ZORAN = no
FAME = no
FAME_LIB =
MP1E_DEP =
MP1E_LIB =
ARCH_LIB = -lpthread -ldl
XVID = no
XVID_INC =
XVID_LIB =
X264 = no
X264_INC =
X264_LIB =
CONFIG_DTS = no
DTS_INC =
DTS_LIB =
DECORE_LIB =
MENCODER = yes
ENCORE_LIB =
DIRECTFB_INC =
DIRECTFB_LIB =
CDPARANOIA_INC =
CDPARANOIA_LIB = -lcdda_interface -lcdda_paranoia
FREETYPE_INC =
FREETYPE_LIB =
FONTCONFIG_INC =
FONTCONFIG_LIB =
FRIBIDI_INC =
FRIBIDI_LIB =
LIBLZO_LIB=
MAD_LIB = -lmad
VORBIS_LIB = -lvorbis -logg
THEORA_LIB =
FAAD_LIB =
INTERNAL_FAAD = yes
SMBSUPPORT_LIB = -lsmbclient
XMMS_PLUGINS = no
XMMS_LIB =
MACOSX = no
MACOSX_FINDER_SUPPORT = no
MACOSX_FRAMEWORKS =
TOOLAME=no
TOOLAME_EXTRAFLAGS=
TOOLAME_LIB=

# --- Some stuff for autoconfigure ----
TARGET_ARCH_X86 = yes
TARGET_WIN32 = no
TARGET_CPU=686
TARGET_MMX = yes
TARGET_MMX2 = yes
TARGET_3DNOW = no
TARGET_3DNOWEX = no
TARGET_SSE = yes
TARGET_ALTIVEC =
TARGET_VIS =

# --- GUI stuff ---
GTKLIB =
GLIBLIB =
GTK_LIBS =
GUI = no
DEBUG = -DDEBUG
 
Old 03-01-2005, 09:26 PM   #6
edison
LQ Newbie
 
Registered: Feb 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Hi all,

problem solved. The cause is some of the files are failed to untar due to timestamp expired. I get all the file and it works.

What a clumsy mistake.

Thx
Ed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Mplayer not working VampireL0rd Linux - Software 2 11-21-2005 07:35 AM
mplayer doesn't install in Slackware 10 Rhatlinux Linux - Software 11 10-31-2004 08:58 AM
Slackware 10 - Mplayer problems + more Kristijan Slackware 19 07-15-2004 09:47 AM
mplayer in Slackware iZvi Slackware 2 06-06-2004 03:06 PM
How to install mplayer gui after installing mplayer kaega2 Linux - Software 5 10-07-2003 11:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration