LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-19-2017, 04:06 AM   #1
erre_erre
LQ Newbie
 
Registered: May 2017
Posts: 4

Rep: Reputation: Disabled
Https + Suckless Surf


Good morning,

I'm trying to make login in the first page of my job's Juniper vpn,
with Suckless' Surf, from an up-to-date Arch, but it fails reloading
the same page.
Other browsers like Firefox works as expected but I'd like to avoid
them due their heavy weight and the brand new NPAPI concept.
There're no problems at all with connection or the like.

Notice that if I make the first login with Firefox and then continue
with Surf everything works. So i suspect certificates problems but
I can't find any useful log or messages. I'd checked dmesg, journal
and tried running it from console, gdb and also checking strace.

I'd already tried manually exporting relate certificates from Ff and adding
them as symlinks to /etc/ssl/certs. In /etc/ca-certificates/extracted/ and
/etc/ca-certificates/extracted/cadir as pem files. Put them as crt files in
/etc/ca-certificates/trust-source/anchors.
Added their keys to /etc/ssl/certs/ca-certificates.crt and /etc/ssl/cert.pem
(which is a symlink to /etc/ca-certificates/extracted/tls-ca-bundle.pem),
/etc/ssl/objsign-ca-bundle.pem, email-ca-bundle.pem and ca-bundle.trust.crt.

Checked commands update-ca-trust and trust extract-compat.

I'd also searched the forum and the web but still can't solve.
Tried with a compile version of the browser and downgrading and reinstalling
ca-certificates, mozilla-certificates, Firefox, Surf and Openssl.

Thanks in advance for any help.
 
Old 05-19-2017, 11:59 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,426
Blog Entries: 10

Rep: Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249Reputation: 5249
have you tried adjusting various settings like allowing javascript or changing the useragent?
Code:
man surf
is your friend.

if that doesn't help...
surf is just a very minimalistic frontend to the webkit/gtk+ engine, which is also used by e.g. chromium, IIRC.
i also think the surf version in [community] is a bit outdated. idk, maybe try the surf-git version.
 
Old 05-19-2017, 01:07 PM   #3
erre_erre
LQ Newbie
 
Registered: May 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks for the reply.

I'd already tried everthing you said except about trying the git version.
Tried now but didn't solved. Tried also other browsers even like zsurf.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Suckless Distro ? patrick295767 Linux - Distributions 9 08-25-2016 03:08 PM
LXer: FLOSS Weekly 355: Suckless LXer Syndicated Linux News 0 09-25-2015 06:21 AM
[SOLVED] Need suggestion:->>Failed HTTPS transfer to https://supportfiles.sun.com/curl manalisharmabe Solaris / OpenSolaris 11 01-10-2014 12:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration