LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Https + Suckless Surf (https://www.linuxquestions.org/questions/linux-software-2/https-suckless-surf-4175606267/)

erre_erre 05-19-2017 04:06 AM

Https + Suckless Surf
 
Good morning,

I'm trying to make login in the first page of my job's Juniper vpn,
with Suckless' Surf, from an up-to-date Arch, but it fails reloading
the same page.
Other browsers like Firefox works as expected but I'd like to avoid
them due their heavy weight and the brand new NPAPI concept.
There're no problems at all with connection or the like.

Notice that if I make the first login with Firefox and then continue
with Surf everything works. So i suspect certificates problems but
I can't find any useful log or messages. I'd checked dmesg, journal
and tried running it from console, gdb and also checking strace.

I'd already tried manually exporting relate certificates from Ff and adding
them as symlinks to /etc/ssl/certs. In /etc/ca-certificates/extracted/ and
/etc/ca-certificates/extracted/cadir as pem files. Put them as crt files in
/etc/ca-certificates/trust-source/anchors.
Added their keys to /etc/ssl/certs/ca-certificates.crt and /etc/ssl/cert.pem
(which is a symlink to /etc/ca-certificates/extracted/tls-ca-bundle.pem),
/etc/ssl/objsign-ca-bundle.pem, email-ca-bundle.pem and ca-bundle.trust.crt.

Checked commands update-ca-trust and trust extract-compat.

I'd also searched the forum and the web but still can't solve.
Tried with a compile version of the browser and downgrading and reinstalling
ca-certificates, mozilla-certificates, Firefox, Surf and Openssl.

Thanks in advance for any help.

ondoho 05-19-2017 11:59 AM

have you tried adjusting various settings like allowing javascript or changing the useragent?
Code:

man surf
is your friend.

if that doesn't help...
surf is just a very minimalistic frontend to the webkit/gtk+ engine, which is also used by e.g. chromium, IIRC.
i also think the surf version in [community] is a bit outdated. idk, maybe try the surf-git version.

erre_erre 05-19-2017 01:07 PM

Thanks for the reply.

I'd already tried everthing you said except about trying the git version.
Tried now but didn't solved. Tried also other browsers even like zsurf.


All times are GMT -5. The time now is 02:47 PM.