LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-11-2006, 01:00 AM   #1
rajnair0278
Member
 
Registered: Mar 2006
Posts: 62

Rep: Reputation: 15
Angry How does webserver determine Php Version???


Hello guys, is there anybody who could tell me how does my red hat linux 9 distro, apache webserver determine the version of php installed?? I have come to know the linux cd has php 4 inbuilt. So now after installing php 5.1, I have libphp5.so and libphp4.so both installed. I have the latest versions of GD lib, png, jpeg src, xml, php5.1 installed. But for no apparent reason it still shows the version as php 4.2.2 and no gd and old xml. Folks, I have come to a dead end. Dont want to format and re-install everything again. Any suggestions will be appeciated. Thx a ton.
 
Old 04-11-2006, 01:12 AM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,141

Rep: Reputation: 168Reputation: 168
In Apache's httpd.conf file there's a line that tells Apache which module to use. In mine it says:
Code:
LoadModule php4_module        modules/libphp4.so
Or did you mean that you have lines for both modules but you can't manually select the one that you want?
 
Old 04-11-2006, 01:53 AM   #3
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
And restart apache (httpd) after modifying httpd.conf.
 
Old 04-11-2006, 02:07 AM   #4
rajnair0278
Member
 
Registered: Mar 2006
Posts: 62

Original Poster
Rep: Reputation: 15
Thx for the info guys. I activated this line in httpd.coonf LoadModule php5_module /usr/local/httpd/modules/libphp5.so and got this error upon restarting apache

Syntax error on line 176 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/local/httpd/modules/libphp5.so into server: /usr/local/httpd/modules/libphp5.so: undefined symbol: xmlResetError.

Infact I have also uploaded the latest version of xml. Anything else should i check???
 
Old 04-11-2006, 05:23 AM   #5
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,141

Rep: Reputation: 168Reputation: 168
Did you compile the php module yourself or was it pre-compiled with a package? There are a couple of howtos at http://www.lamphowto.com/ and http://www.howtoforge.com/linux_apac..._ioncubeloader that might help - I've still got php 4 on my setup because my version of squirrelmail needs it.
 
Old 04-11-2006, 05:31 AM   #6
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
I know that Squirrelmail requirement is php4 but I've been using Squirrelmail on php5 from Slackware testing without any problems. I don't know, maybe your Squirrelmail just requires some special php4 functions.
 
Old 04-11-2006, 05:54 AM   #7
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,141

Rep: Reputation: 168Reputation: 168
I didn't think I was doing anything special with mine, but I tried php 5 a while back and had a problem. On the squirrelmail web site they said it wouldn't work without version 4 (unless I wanted to patch squirrelmail from CVS). I went back to php 4 and the problem went away.

So here I am, too lazy to upgrade squirrelmail so I can upgrade php - it's not visible on the internet so I'm not too worried about it
 
Old 04-11-2006, 06:40 AM   #8
rajnair0278
Member
 
Registered: Mar 2006
Posts: 62

Original Poster
Rep: Reputation: 15
Yes I did compile and re-complie it several times but to no avail. Finally I had to reformat my server. Since it was new I could afford it. Will be installing all the S/Ws again. Any good sites offering help on installations and troubleshooting is welcome. I am aware of the above sites mentioned by gilead. I just hope it works this time. Keeping fingers crossed. Thx again guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to determine chipset version? crazibri Linux - Wireless Networking 1 04-08-2006 11:38 PM
Webserver not displaying the new version of php??? Why? rajnair0278 Linux - Software 4 03-27-2006 07:08 AM
I would like to be able to determine my kernel version. Gueron Linux - Newbie 3 10-10-2005 02:24 PM
Determine version of Linux OS? amiableboy Linux - Newbie 2 07-21-2005 04:16 AM
how can i determine what version of XFree86 i am using? guitarfella Slackware 1 12-14-2004 09:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration