LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-27-2006, 05:53 AM   #1
rajnair0278
Member
 
Registered: Mar 2006
Posts: 62

Rep: Reputation: 15
Unhappy Webserver not displaying the new version of php??? Why?


I have installed Php5.1 on Linux 9 Apache 2.0. However i have still not been abe to get phpinfo to recognize the newer version of php inspaite of several configures and make and make installs. It still shows 4.2.2. I know when you install Linux it comes with an inbuilt bundled package of php. My webserver seems to fetching the old 4x version somehow. How do I make it point to Php5 libraries and files?? I have also read somewhere that you dont need to uninstall the old version while upgrading?? It will automatically read php 5 files after configure. Is it true?? Any suggestion will be appreciated. Thx
 
Old 03-27-2006, 05:57 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
Check your httpd.conf to see if you have the following:
Code:
LoadModule php5_module modules/libphp5.so
Perhaps the path to libphp5.so is different in your case. If also exists a similar line with libphp4.so you have to comment that out to be able to use php5
 
Old 03-27-2006, 06:37 AM   #3
rajnair0278
Member
 
Registered: Mar 2006
Posts: 62

Original Poster
Rep: Reputation: 15
I checked my httpd.conf. It didnt have any such line either for php4 or 5. Now am wondering how is it loading the libphp4.so file. Nevertheless, i copied one line from the list and added one similar to the one you provided above, ofcoure changing the path of my libphp5.so. But when I restarted my webserver got undefined:xmlResetError. Any idea what is this error?? I have installed libxml 2.6.23 but it reflects 2.5.4 inspite of upgrading it. Dont know why it shows the old versions of evrything that I have installed.

Last edited by rajnair0278; 03-27-2006 at 06:49 AM.
 
Old 03-27-2006, 06:51 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
You should re-compile php with xml support, i.e something like:
Code:
./configure --with-xml --with-libxml-dir=/path/to/libxml --other-options-you-want
 
Old 03-27-2006, 07:08 AM   #5
rajnair0278
Member
 
Registered: Mar 2006
Posts: 62

Original Poster
Rep: Reputation: 15
Thx for the reply.

./configure --prefix=/usr/local/php --with-apxs2=/usr/local/apache/bin/apxs --with-config-file-path=/usr/local/php --with-mysql=/usr/local/mysql --with-gd=/usr/local --with-zlib=/usr/local --with-png=/usr/local --with-jpeg=/usr/local --with-libxml2=/usr/local/libxml2 this is how i configured my php.(dont know how many times) after installing all the applications.

Any other step to be done??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat 9.0 Webserver not displaying Asian fonts AHjuncti Linux - Software 2 09-19-2005 03:34 PM
displaying variables in flash from php zowey Programming 0 10-04-2004 03:54 PM
php4 problem _ downloading index.php instead of displaying tharris Debian 2 10-24-2003 06:13 PM
displaying apache version jonfa Linux - General 1 09-10-2003 04:28 AM
What webserver/version is this? rverlander LQ Suggestions & Feedback 4 07-09-2002 07:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration