LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-24-2016, 01:28 PM   #1
ben aur
LQ Newbie
 
Registered: Sep 2016
Location: mid-wales
Distribution: ubuntu 14.04 kxstudio, manjaro & mint
Posts: 6

Rep: Reputation: Disabled
Hotkeys not working in ubuntu 14.04


Recently installed Ubuntu 14.04 (kxstudio) on a lenovo R500 Thinkpad. Some of the hotkeys appear to be ineffective. F2, F4, ctrl-w, ctrl-c etc. are all fine. The most inconvenient failures so far are the inability to change workspaces using alt+ctl+arrow keys and no 'super' key. Any ideas?
 
Old 09-25-2016, 06:56 AM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,669

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Hi, welcome to LQ!

They have the keys. Often, when Fn keys are factory set to other features they provide a Function Key indicated somewhere along the Ctl, Alt, Space row. If none found, F2 or F12 are used for switching purpose: viz, it is pressed first to get briefly into F1-F12 usage; in my case it is offered for about brief 5 seconds, so to make sure I just hold it then press other Fn key for the usual function. I met this when I lost way to get into shell via Ctl+Alt+Fn, I searched and found none, only to discover that a small "Fn" key was beside Ctl key (I thought that it was a Win key), so when I pressed it (short-press) then CTL+ALT+F3 it took me to the usual shell.

Hope this idea can help. Good luck.

m.m.
 
Old 09-25-2016, 03:36 PM   #3
ben aur
LQ Newbie
 
Registered: Sep 2016
Location: mid-wales
Distribution: ubuntu 14.04 kxstudio, manjaro & mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
thanks for the welcome and the reply.
the fn key on my machine, as far as i can tell, is limited to making the screen brighter/dimmer and switching the keyboard light on and off.
press and hold f12 leads to a blank screen with a cursor flashin in the top left corner and no way back in.
i think it's especially confusing because kxstudio has a kde gui but is ubu14.04. none of the tutorials show menus that look anything like mine and i haven't used kde for years. i've one or two key queries as a result o this but reckon it's better to deal with 'em one at a time.
ta for being there.
 
Old 09-27-2016, 10:52 PM   #4
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,669

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Hie ben aur,

I have tried to view some lenovo R500 Thinkpad keypads in the web I notice that there is an "Fn" key below the left Shift beside the Ctl key, some colored in blue. To use the keys F1, F2, F3, ... back to usual conventions press that "Fn" key first at the bottom of the pad.

Hope it works.

m.m.
 
1 members found this post helpful.
Old 09-28-2016, 10:57 AM   #5
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,844

Rep: Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162
If you run the command xev in a terminal, you can check what the Windows key is being recognised as. You may need to run the keyboard configuration tool to make sure that it is the Super key.

KDE's keyboard shortcuts configuration tool enables you to alter things like "switch workspace" or "move to new workspace", so you can check there that Ctrl-Alt-↑ and so on are set.

Last edited by DavidMcCann; 09-29-2016 at 10:32 AM. Reason: clarification
 
1 members found this post helpful.
Old 09-30-2016, 03:24 AM   #6
ben aur
LQ Newbie
 
Registered: Sep 2016
Location: mid-wales
Distribution: ubuntu 14.04 kxstudio, manjaro & mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
The keyboard shortcut configuration tool! looked it up, brilliant! I could really use that. It's not available in my settings menu as it stands. I get k/b, mouse, touchpad & joystick only. 's a very useful direction though. Thanks.
 
Old 09-30-2016, 03:32 AM   #7
ben aur
LQ Newbie
 
Registered: Sep 2016
Location: mid-wales
Distribution: ubuntu 14.04 kxstudio, manjaro & mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
[QUOTE=DavidMcCann;5610989]If you run the command xev in a terminal,
I tried this, too. It created a small window with a black box outlined within. The terminal, as far as i could tell, was showing detailed info of the precise location of the mouse expressed as axes. not sure this is what was expected?
 
Old 09-30-2016, 03:33 AM   #8
ben aur
LQ Newbie
 
Registered: Sep 2016
Location: mid-wales
Distribution: ubuntu 14.04 kxstudio, manjaro & mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
Unhappy

[QUOTE=DavidMcCann;5610989]If you run the command xev in a terminal,
I tried this, too. It created a small window with a black box outlined within. The terminal, as far as i could tell, was showing detailed info of the precise location of the mouse expressed as axes. not sure this is what was expected?
 
Old 09-30-2016, 11:40 AM   #9
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,844

Rep: Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162
Yes, xev does respond to the mouse. But when you press a key, you get two reports: "KeyPress event" and "KeyRelease event" like
Code:
KeyPress event, serial 32, synthetic NO, window 0x3600001,
    root 0x112, subw 0x0, time 6116949, (60,-371), root:(299,162),
    state 0x0, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False
Note the "Super-L" that confirms that the keycode 133 has been assigned to the left Super.
 
1 members found this post helpful.
Old 10-03-2016, 11:08 AM   #10
ben aur
LQ Newbie
 
Registered: Sep 2016
Location: mid-wales
Distribution: ubuntu 14.04 kxstudio, manjaro & mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
That's another useful post thanks David. Everyday's a school day.
I concluded that the kxstudio/ubuntu was, in this case, impaired in several ways. I've installed a gnome desktop which appears to have sorted it all out and everything's hunky dory now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
EeePC 1015PED HotKeys w/Ubuntu 10.10 netbook... tedlarson Linux - Laptop and Netbook 2 11-10-2010 10:18 AM
Lenovo SL Series Hotkeys - Almost works! (Ubuntu Jaunty) pietruszewski Linux - Laptop and Netbook 0 03-05-2009 09:31 PM
Linux on a Sony VGN-C25G - How to get the hotkeys working? nardz Linux - Hardware 7 02-14-2008 03:54 AM
fluxbox hotkeys not working fatblueduck Linux - Software 4 02-27-2005 04:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration