Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-12-2001, 10:30 PM   #1
LQ Newbie
Registered: Jun 2001
Distribution: Mepis, baby. MEPIS!!!
Posts: 13

Rep: Reputation: 0

Ok, let me explain the entire problem:

During installation, DrakX is identifying my hard drive as an hde, not an hda. So in essence, it's labeling my partitions as the following...

hde1 = FAT32
hde2 = FAT 32
hde6 = Linux Native Partition
hde7 = Linux Swap Partition

When it does this, it writes it in fstab, which is on the /etc directory of hda6, as hde6 and hde7, when it should be hda6 and hda7. The reason that I know it is hda6 is that I can boot Linux from hda6 at the boot prompt, and the fact I don't have five hard drives.

And when I boot Linux, it goes to the same problem above when loading X:

Current State: Booting:

fsck.ext2: No such device or address while trying to open /dev/hda6

Failed to check file system: Do you want to repair the errors?

Yes or No

If I click either yes or no, it exits me to the root prompt, where I can open fstab from the /etc directory in vi... Now the problem is, I can open it and edit it in vi, but I can't save it back to it's original place. Remember, Linux is still thinking my Linux native partition is hde6, while it's hda6... and it won't know it until I save the fstab file saying that it's hda6, which I can't do because Linux still thinks it's...

Paradoxes suck... -chuckles-

Same problem with the swap file, btw. Linux thinks it's a hde7 when it's hda7... still have to edit that in fstab before it will load correctly...

Any help with this one?


Old 07-13-2001, 01:30 AM   #2
Senior Member
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Looks like whatever controller you are using is enumerating in a non-standard fashion. Try this...

depending on kernel and what you named your label (in lilo) for your config...

kernels < 2.4.x use the following, note that 'linux' is the default label for the default installs. If yours is different (in lilo.conf) use yours.
LILO boot: linux pci=reverse
and for kernels 2.4x and up it's
LILO boot: linux ide=reverse
Old 07-13-2001, 03:21 AM   #3
Registered: Mar 2001
Location: West Texas
Distribution: Red Hat 8.0
Posts: 50

Rep: Reputation: 15
Found a place that may offer a solution
Old 07-13-2001, 03:51 AM   #4
Senior Member
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
You running a UDMA 100 controller?? If so these are seen as additional IDE channel, hence are hde, hdf, hdg, hdh.

You need to boot from a boot disk that doesn't use your existing hard disk partitions for its file systems (like a demo CD, or maybe a recuse disk), mount your root partition to somewhere, then edit /etc/fstab then restart.


Old 07-14-2001, 12:02 PM   #5
LQ Newbie
Registered: Jun 2001
Distribution: Mepis, baby. MEPIS!!!
Posts: 13

Original Poster
Rep: Reputation: 0
Thank you all for your help... but it didn't work. Well, it did partially, during boot startup I did see it swap from hde to hda. But the problem is fstab is still saying hde instead of hda... so I can't mount correctly. It comes up with an error saying it can't find it in fstab or mtab... which is written during the install... is there anyway to change it during the install? Or even afterward?

Oh, and thank you mcleodnine and Fried. After reading the link I did find that I had a PCI IDE card in the computer...

Old 07-14-2001, 03:05 PM   #6
Senior Member
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Well if you want to try and start te install again, try and pass the 'reverse' option when it boots. That way it should install on the right piece of real estate. Make sure you edit the lilo.conf file with the
or pci=reverse depending on your kernel.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
grr, DHCP cdc7 Linux - Networking 4 01-10-2005 11:54 AM
grr, Compiling? damaster406 Linux - Software 9 12-24-2004 07:47 PM
grub.conf, grr! tmp_versions Linux - Software 6 08-30-2004 03:31 AM
more partition questions... grr... neweternity4321 Linux - Newbie 5 07-12-2004 03:48 AM
grr... ach1lles Linux - Newbie 2 04-17-2004 07:26 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:31 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration