LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-10-2005, 12:33 AM   #1
cdc7
LQ Newbie
 
Registered: Jan 2005
Distribution: Redhat 6.2
Posts: 5

Rep: Reputation: 0
grr, DHCP


Hi!

I have a router downstairs that all the computers in the house connect to, and I use Comcast cable.
Using Redhat 6.2 under Gnome, I went to the Network Configurator from the Control Panel, and am having trouble setting up the network connection for that computer.

I've looked around but haven't found things to fit my problem, or get it through my newb self.

When I try to go to www,google,com in Netscape, two errors come up.
The first says
Quote:
Netscape is unable to locate the server www,google,com.
Please check the server name and try again.
The second error has this:
Quote:
"Warning: the following hosts are unknown:
home.netscape.com
home6.netscape.com
internic.net

This means that some or all hosts will be unreachable.
Perhaps there is a problem with your name server? If your site must use a non-root name server, you will need to set the $SOCKS_NS environment variable to point at the appropiate name server. It may (or may not) be necessary to set this variable, or the SOCKS host preference, to the IP address of the host in question rather than its name.

Consult your system adminstrator.
Alright.. I don't know what most of this stuff means..

To make a long post longer =/
Under Routing in the Network Configurator, I set up the default gateway as 192.168.0.1 and the default gateway device eth0.
Interface: eth0, network address: 68.50.15.13, netmask: 255.255.255.0, gateway: 192.168.0.1
For "names", I put hostname: cj241911-a and the domain dlcty1.va.home.com

I got most of the numbers from either telnetting the router on this WinXP computer, or the LAN control panel on XP.

Thank you!
 
Old 01-10-2005, 01:26 AM   #2
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
1. Can you ping your router? ping 192.168.0.1
2. Can you ping a server on the internet, such as google? ping www.google.com
3. Paste the output of ifconfig eth0 (do this as root)

Last edited by student04; 01-10-2005 at 01:28 AM.
 
Old 01-10-2005, 01:39 AM   #3
cdc7
LQ Newbie
 
Registered: Jan 2005
Distribution: Redhat 6.2
Posts: 5

Original Poster
Rep: Reputation: 0
1. connect: Network is unreachable
2. ping: unknown host www.google.com
3. eth0: error fetching interface information: Device not found

btw, just ifconfig gives me lo information, and eth0 IS activated

Last edited by cdc7; 01-10-2005 at 01:44 AM.
 
Old 01-10-2005, 01:47 AM   #4
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
err so.. you can't ping your router.. which means that it is either dropping packets or you haven't been assigned an IP.

Try the following (I'm assuming that you've set the router up on dhcp)
Code:
# ifconfig eth0 up
# dhclient eth0
Then try 3 (from above), then 1&2

Last edited by student04; 01-10-2005 at 01:48 AM.
 
Old 01-10-2005, 11:54 AM   #5
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
Re: grr, DHCP

Quote:
Originally posted by cdc7
Interface: eth0, network address: 68.50.15.13, netmask: 255.255.255.0, gateway: 192.168.0.1
For "names", I put hostname: cj241911-a and the domain dlcty1.va.home.com
well, for me, it looks like your local IP/Netmask doesn't fit your gateway's one,
try setting your local ip to 192.168.0.<SomethingNotUsedInYourNet> with
> ifconfig eth0 192.168.0.xxx up

OR, if you are _sure_ that your dhcp server is working, execute

> dhclient eth0

and check the output of
> dhclient --status (or -s, don't remember...) after executing

(on debian, the dhcpclient is called pump, (pump -i eth0/pump -s) maybe this also works with you)




and try to ping again:
> ping 192.168.0.1

could you send your output from
> ifconfig


Flo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grr, Compiling? damaster406 Linux - Software 9 12-24-2004 07:47 PM
grub.conf, grr! tmp_versions Linux - Software 6 08-30-2004 03:31 AM
grr... ach1lles Linux - Newbie 2 04-17-2004 07:26 PM
Grr ho hum *.ISO linear Linux - General 2 10-13-2001 10:43 PM
-grr- ProdicalFlame Linux - Software 5 07-14-2001 03:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration