LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-07-2004, 08:49 PM   #1
Jiawen
Member
 
Registered: Aug 2003
Location: Twin Cities, MN, US
Distribution: Mandriva -> Ubuntu
Posts: 106

Rep: Reputation: 15
Gnome 2.6.2 and chkfontpath/XFree86 problems


I'm trying to install Gnome 2.6 on my Mandrake 9.2 Chinese (Traditional TW) system. I seem to be in dependency hell.

Gnome 2.6 shows up in the RPMdrake list, but when I try to install it, I get the following error:
Code:
The following packages have to be removed for other to be upgraded:

chkfontpath-1.9.10-1mdk.i586 (due to missing XFree86-xfs)

Is it okay to continue?
When I try to install XFree86-xfs, I get the following message:
Code:
Some package requested cannot be installed:
XFree86-xfs-4.3-32.2.100mdk.i586 (due to unsatisfied XFree86-libs[== 4.3-32.2.100mdk])
do you agree ?
As far as I can tell, that package doesn't exist. There is, however, something called libxfree-4.3-32.2.100mdk. However, when I try to install that, I get the following error:
Code:
Some package requested cannot be installed:
XFree86-4.3-24.5.92mdk.i586 (due to unsatisfied libxfree86[== 4.3-24.5.92mdk])
libxfree86-4.3-24.5.92mdk.i586
do you agree ?
I found and tried to install libxfree86-4.3-24.5.92mdk, but I then get this error:
Code:
Some package requested cannot be installed:
XFree86-server-4.3-24.5.92mdk.i586 (due to missing XFree86-xfs-4.3-23mdk.i586)
XFree86-xfs-4.3-23mdk.i586 (trying to promote XFree86-xfs)
chkfontpath-1.9.10-1mdk.i586
xorg-x11-xfs-6.7.0-3mdk.i586 (due to unsatisfied chkfontpath[*])
do you agree ?
So the thing requires an earlier version of itself?!? And I've now looped back to the chkfontpath requirement. Is this not the very definition of dependency hell?

What should I do? Try to install gnome-2.6.2 with nodeps? I'm pretty lost here.

Thanks in advance for any help!

Update: I have tried other programs besides Gnome 2.6.2 and had the same problems.

Last edited by Jiawen; 11-07-2004 at 09:09 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X11? Xfree86? Gnome? oasisbhrnw99 Linux - Newbie 2 07-27-2005 11:58 PM
chkfontpath raffi Slackware 2 12-19-2004 02:25 PM
Installing Xfree86 and GNOME Ryoojin Linux - Software 2 09-19-2003 09:24 PM
Upgraded XFree86 and now no gnome etc plisken Linux - General 5 05-23-2003 01:48 PM
XFree86 4.3.0 - staring in GNOME nilch Linux - Software 1 03-16-2003 11:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration