LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-07-2021, 09:39 AM   #1
Lingyu
LQ Newbie
 
Registered: Dec 2021
Posts: 1

Rep: Reputation: Disabled
Exclamation GLIBC version problem with Anaconda installation


When I install Anaconda on a Linux server, it displays "The version of GLIBC is no longer supported. Found version 2.12, which is less than 2.17". But I don't have root privileges to change the GLIBC version. Changing the GLIBC version may also cause other compilation software to fail to run. And when I installed Anaconda before, this problem did not occur. It was suddenly that the GLIBC version was too low when running the code. I uninstalled Anaconda and tried to reinstall it, but now I installed Anaconda and the problem started to appear. How can I solve this problem?
 
Old 12-07-2021, 10:03 AM   #2
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 7,715
Blog Entries: 19

Rep: Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510Reputation: 4510
You could install the glibc you need in a non-standard library directory that you have access to, and then set LD_LIBRARY_PATH for the anaconda run so as to include that directory. That shouldn't have any effect on other software which will look for libraries only on the paths set in ld.so.conf.
 
Old 12-07-2021, 10:17 AM   #3
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 3,688

Rep: Reputation: Disabled
Glibc 2.12 sounds like RHEL 6 or its derivative. The regular support for them ended a year ago. No wonder current Anaconda release doesn't support them anymore. The supported Glibc 2.17 is part of RHEL/CentOS 7.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 6.9. Glibc-2.23 / 6.9.1. Installation of Glibc newuser21 Linux From Scratch 6 06-18-2016 12:23 PM
[SOLVED] 6.9. Glibc-2.23 / 6.9.1. Installation of Glibc newuser21 Linux From Scratch 6 06-16-2016 08:46 AM
[SOLVED] centos5 both 32bit glibc and 64 glibc exist, how to delete the 32bit version zousheng Linux - Newbie 2 04-03-2013 09:17 AM
i have an error when i try to install Glibc(5.7. Glibc-2.8-20080929, Version 6.4) robineecc1 Linux From Scratch 0 12-14-2008 11:45 AM
RH 9.0 glibc rpm says it needs glibc-common, but glibc-common is installed whitshade Red Hat 2 04-28-2007 05:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration