LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-27-2003, 09:50 AM   #1
KoS
Member
 
Registered: Jul 2003
Location: Chicago, IL
Distribution: RH 9
Posts: 51

Rep: Reputation: 15
Gaim and libgtkspell.so.0 question


First I would like to sat that I am right now a complete Linux n00b. I have RH9 and am trying to get gaim installed and to work. I have the newest version d/l RPM. When I try to install it I get the message about libgtkspell.so.0 no able to be found. I d/l the gtkspell-2.4.0-1.src.rpm and the tar.gz How do install either of these. I am in root and try to run the RPM file it does nothing that I casn see. Please give me a quick run down of what I am supposed to do. Thanks in advance for all the help.
 
Old 07-27-2003, 10:08 AM   #2
dkaplowitz
Member
 
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
There are things like apt and redcarpet that you can use to install certain packages with all the dependencies added. Also, GAIM comes with certain distros, like Redhat.

If you just want to install what you have, then extract the .gz file by running

"tar -zxvf " in the directory where it's downloaded. That will create a directory. Go in that directory and look for README and INSTALL. Read those. They should give you install instructions, like
"make"
"make install", yadda yadda.
(you will have to be root for the last part of it)

After the depency, run "rpm -ihv" on the rpm (as root).

Good luck.
 
Old 07-27-2003, 10:34 AM   #3
KoS
Member
 
Registered: Jul 2003
Location: Chicago, IL
Distribution: RH 9
Posts: 51

Original Poster
Rep: Reputation: 15
Thanks for the help with untaring the file. I ran it and I think it installed fine. As far as I can tell at least. When I tried to run the RPM file I got this message:

[root@localhost download]# rpm -ihv gtkspell-2.0.4-1.i386.rpm
warning: gtkspell-2.0.4-1.i386.rpm: V3 DSA signature: NOKEY, key ID 897da07a
error: Failed dependencies:
libaspell.so.15 is needed by gtkspell-2.0.4-1
[root@localhost download]#

Not sure what this is saying. I am doing this so I DO have the libgtkspell.so file. Also would I have to restart or logout for this file to show? I trued to run the gaim RPM again and it still tells me that it cann't locate the libgtkspell.so.0 I am almost positvie that the tar file I had was to add the gtkspell file. I know that during the install of the tar file it shows it so. I would paste the install stuff for that but it's 9 pages. Thanks for the help so far. I can feel myself getting closer.
 
Old 07-27-2003, 10:47 AM   #4
dkaplowitz
Member
 
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
I didn't read your post thoroughly...what I failed to notice was that you had the RPM for both packages. Can you do a "rpm -ivh filename" on the dependency package and then try the GAIM package?

Also, which distro of Linux are you running?
 
Old 07-27-2003, 10:51 PM   #5
KoS
Member
 
Registered: Jul 2003
Location: Chicago, IL
Distribution: RH 9
Posts: 51

Original Poster
Rep: Reputation: 15
The package I have is gtkspell-2.0.4-1.i386.rpm . I'm almost sure this is right, but could be wrong. When I run rpm -ivh gtkspell-2.0.4-1.i386.rpm I get this message:

[root@localhost download]# rpm -ihv gtkspell-2.0.4-1.i386.rpm
warning: gtkspell-2.0.4-1.i386.rpm: V3 DSA signature: NOKEY, key ID 897da07a
error: Failed dependencies:
libaspell.so.15 is needed by gtkspell-2.0.4-1
[root@localhost download]#


I don't know the key or why it needs it or where or what libaspell.so.15 is. Gaim still won't install, but I'm sure you sure you know that after this. Still lost. Your help is greatly appreciated.
 
Old 07-27-2003, 11:00 PM   #6
dkaplowitz
Member
 
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
if you have both rpms in the same "download" directory, try rpm -ivh *.rpm ...maybe this will work. Otherwise, maybe you need the older version of the dependency.

Again, if you have one of the bigger (more commercial) distros of Linux, you can probably just install it from the "add/remove applications" menu that the os provides.
 
Old 07-28-2003, 03:43 PM   #7
KoS
Member
 
Registered: Jul 2003
Location: Chicago, IL
Distribution: RH 9
Posts: 51

Original Poster
Rep: Reputation: 15
I have d/l every gtkspell rpm or tar I can find. I have ran or have tried to run all of them and most worked, but gaim still comes up with the message that it needs the libgtkspell.so.0. I'm lost Has anyone installed gaim and had this problem but was able to fix it??? If so PLEASE let me know what you did. I can't install this without it and I have no idea what I'm doing wrong. I tried to go threw the RH9 add/remove but it says I have everything installed and doesn't give any options other than to start removing things.
 
Old 07-28-2003, 04:00 PM   #8
troll
LQ Newbie
 
Registered: Jul 2003
Distribution: rh9
Posts: 2

Rep: Reputation: 0
I take it you installed rh9 but wanted to upgrade to newer gaim (as I did) which I think is gtk2 and now requires gtkspell

Looks like it's complaining about aspell. You should check if it's installed as well.

rpm -qa | grep -i aspell

A little trick I like to use, if I don't know what library it's complaining about, is go to rpmfind.net and paste the library into the search, and it should return what package it's from. Then just grab the one that fits you best.

If you don't have aspell installed, I think gtkspell needs that. So you should just need the gtkspell and aspell packages and install them together, like was suggested, just those in a seperate dir, then rpm -Uvh *.rpm (I like to use U in case an older version is already installed) I don't see why it won't work then. Can't hurt to throw the gaim rpm in there also and include it in the *.rpm install.

I hope this makes sense, I'm no expert, but I have newer gaim installed on rh9, so I must have been doing something right.

Troll
 
Old 07-28-2003, 04:11 PM   #9
KoS
Member
 
Registered: Jul 2003
Location: Chicago, IL
Distribution: RH 9
Posts: 51

Original Poster
Rep: Reputation: 15
I went to the Gaim irc chat room and asked around. I got it to work now. I needed the file gtkspell-2.0.2-1.i386.rpm I ran this and then gaim .66 installed w/o any problems. I thank everyone that has helped me woth this problem. Oh and if anyone else is haveing the problem it was at

http://gtkspell.sourceforge.net/down...0.2-1.i386.rpm

Yeah it works.
 
Old 07-28-2003, 04:22 PM   #10
troll
LQ Newbie
 
Registered: Jul 2003
Distribution: rh9
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by KoS
I went to the Gaim irc chat room and asked around. I got it to work now. I needed the file gtkspell-2.0.2-1.i386.rpm I ran this and then gaim .66 installed w/o any problems. I thank everyone that has helped me woth this problem. Oh and if anyone else is haveing the problem it was at

http://gtkspell.sourceforge.net/down...0.2-1.i386.rpm

Yeah it works.
Wait, so it wouldn't work with the 2.0.4 you had? I used 2.0.4 gtkspell rpm without trouble. I think I just needed to install aspell, because of the dependency error you were getting.

Oh well, glad to see you got it working.

Troll
 
Old 07-28-2003, 10:33 PM   #11
KoS
Member
 
Registered: Jul 2003
Location: Chicago, IL
Distribution: RH 9
Posts: 51

Original Poster
Rep: Reputation: 15
No I installed the 2.0.4 and it still didn't work. No idea why but it wouldn't. I got the 2.0.2 and installed it and then I installed gaim w/o any problems. I don't have any idea since I'm a linux noob but it did work.??
 
Old 08-01-2003, 02:20 AM   #12
Cafrow
Member
 
Registered: Aug 2003
Location: Mesa, AZ
Distribution: Redhat 9
Posts: 45

Rep: Reputation: 15
Hey thanks bro. I was just trying to install the new Gaim so that I could use the MSN feature of it. THanks for helping out and telling us how you ended up getting it to work.
 
Old 08-10-2003, 03:44 AM   #13
shaowen
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
Thanx,KoS!
 
Old 08-18-2003, 07:23 AM   #14
hzocm
LQ Newbie
 
Registered: Aug 2003
Location: France
Posts: 1

Rep: Reputation: 0
thanks u KoS!! I have fixe with your method!
 
Old 08-21-2003, 12:09 AM   #15
WaTcHeR
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
I had the same problem on RH. The above .rpm fixed it up.

Thanks

--Thomas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GAIM and libgtkspell theonebeyond Linux - Software 2 11-19-2004 12:37 AM
GAIM question joker20 Linux - Software 1 09-16-2004 09:37 PM
libgtkspell / gaim: relocation error davoman Linux - Software 0 04-14-2004 05:35 AM
Sorry to ask another GAIM question dubya Linux - Software 2 03-06-2004 10:24 PM
Can't install libgtkspell SolarBear Linux - Software 1 11-24-2003 04:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration