LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-14-2005, 06:59 PM   #1
raffi
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Rep: Reputation: 15
firefox & superkaramba themes


Hi!
I'd like to run superkaramba themes on my fluxbox desktop (slack 10.0), but I can't make them work properly. I have neither kde nor gnome installed. I installed superkaramba succesfully, but I don't know what I need else. I suppose some kde packages are required, currently I downloaded kdebase, kdelibs, arts, but that didn't help.
First of all, when I lunch superkaramba from console, it says:

QPixmap: Cannot create a QPixmap when no GUI is being used

But then the welcome screen appears and everything seems to be fine. However, when, for instance, I try to open cynapses_karamba monitor theme, I get these errors:

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 2
Minor opcode: 0
Resource id: 0x12000b4
superkaramba: TaskManager::TaskManager()
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x12000b4
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 14
Minor opcode: 0
Resource id: 0x12000b4
.
.
.
ImportError: No module named sys_mon
------------------------------------------------------
What does ImportError mean?

It means that I couldn't load a python add-on for sys_mon.theme
If this is a regular theme and doesn't use python
extensions, then nothing is wrong.
------------------------------------------------------
/path/to/osinfo.sh: /path/to/osinfo.sh: No such file or directory
/bin/bash: line 1: kde-config: command not found
/bin/bash: line 1: /sbin/ip: No such file or directory
/bin/bash: line 1: sensors: command not found
/bin/bash: line 1: /path/to/mails_pop3.pl: No such file or directory


Any ideas?
 
Old 01-15-2005, 06:41 AM   #2
sludink
Member
 
Registered: Jan 2005
Location: Brabant, the Netherlands
Distribution: Gentoo 2004.x (2.6.10 hardened)
Posts: 91

Rep: Reputation: 15
Well, I tried to check dependencies for superkaramba 0.34 using my gentoo distro. It gave one of the lenghtiest list I ever saw, but remarkable was, it uses:
kde-env-3,
python-fschsum-1.7.1, and of course
python 2.3.4.

The full (Gentoo, including support for arts, with only glibc installed) list of dependencies for superkaramba 0.34 was:

alsa-lib-1.0.6
arts-1.3.1
audiofile-0.2.6-r1
autoconf-2.59-r5
automake-1.8.5-r1
baselayout-1.9.4-r6
bash-2.05b-r9
bc-1.06-r5
binutils-2.15.90.0.1.1-r3
bison-1.875
blackdown-jdk-1.4.2.01
bzip2-1.0.2-r3
cpio-2.5
cracklib-2.7-r10
cronbase-0.3.1
cups-1.1.20-r5
db-1.85-r1
db-4.1.25_p1-r4
debianutils-1.16.7-r4
diffutils-2.8.4-r4
expat-1.95.8
fam-2.7.0-r2
file-4.12
flex-2.5.4a-r5
fontconfig-2.2.3
freetype-2.1.5-r1
gawk-3.1.3-r1
gcc-3.3.4-r1
gcc-config-1.3.6-r4
gdbm-1.8.3-r1
gentoo-dev-sources-2.6.9-r9
gettext-0.12.1-r2
ghostscript-7.07.1-r7
giflib-4.1.0-r3
glib-1.2.10-r5
glib-2.4.7
glibc-2.3.4.20040808-r1
gnu-gs-fonts-std-8.11
gnuconfig-20040214
grep-2.5.1-r6
groff-1.19.1-r2
hashalot-0.3
java-config-1.2.11
jpeg-6b-r4
kde-env-3-r3lcms-1.12
kdelibs-3.3.1-r2
libart_lgpl-2.3.16
libgcrypt-1.1.94
libgpg-error-1.0-r1
libid3tag-0.15.1b
libidn-0.3.7
libmad-0.15.1b
libmng-1.0.4
libogg-1.1.2
libpcre-4.5
libperl-5.8.5
libpng-1.2.7
libtool-1.5.2-r7
libungif-4.1.0.1b
libvorbis-1.1.0
libxml2-2.6.15-r1
libxslt-1.1.9-r1
linux-headers-2.4.21-r1
m4-1.4.1
make-3.80-r1
man-1.5m-r2
miscfiles-1.3-r1
module-init-tools-3.0-r2
ncurses-5.4-r5
opengl-update-1.8.2
openssl-0.9.7d-r2
pam-0.77-r1
pam-login-3.14
patch-2.5.9
perl-5.8.5-r2
pkgconfig-0.15.0tk-8.4.6-r1
portage-2.0.51-r3
portmap-5b-r9
python-2.3.4
python-fchksum-1.7.1
qt-3.3.3
readline-4.3-r5
rpm2targz-9.0-r2
sed-4.0.9
sgml-common-0.6.3-r4
superkaramba-0.34
sysvinit
tcl-8.4.6
tcp-wrappers-7.6-r8
texinfo-4.7-r1
tiff-3.7.0
ttmkfdir-3.0.9-r2
ucl-1.01-r1
utempter-0.5.5.5
util-linux-2.12-r4
which-2.16
xorg-x11-6.8.0-r3
xterm-196
zlib-1.2.1-r3
 
Old 01-21-2005, 06:30 PM   #3
p0z3r
Member
 
Registered: Apr 2004
Posts: 88

Rep: Reputation: 15
In your configure step you should notice that it doesn't find the Python headers and libraries.
Install the python-devel package and do a make again.
That should fix your problem, however the transparency doesn't work properly in Fluxbox and I'm currently working on a way to implement that.
-Ryan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Superkaramba Themes and more! VemeC General 1 08-17-2005 04:00 PM
SuperKaramba - black background on all themes J_K9 Linux - Software 7 07-06-2005 04:23 PM
Installing themes and superkaramba coolbreeze7000 Debian 4 03-14-2005 12:13 PM
Superkaramba themes zarathaz Linux - Software 2 11-14-2004 02:59 PM
Problem with Superkaramba themes robpom Linux - Software 8 08-29-2004 11:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration